Bug 183490 - Konsole auto copy selection to clipboard to avoid confusion between shortcuts for pasting from clipboard and selection
Summary: Konsole auto copy selection to clipboard to avoid confusion between shortcuts...
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: copy-paste (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-06 23:59 UTC by Unknown
Modified: 2012-04-25 04:57 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments
Add "Copy to Clipboard on selection" option for profile (8.02 KB, patch)
2012-01-29 16:03 UTC, Adam Batkin
Details
Finer grained choices for X Selection/Clipboard (25.45 KB, patch)
2012-01-30 07:07 UTC, Adam Batkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2009-02-06 23:59:48 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Ubuntu Packages

I mostly use keyboard shortcuts while using Konsole.

For pasting selection, the shortcut is "Shift+Insert" and for pasting from clipboard, the default shortcut is "Ctrl+Shift+V".

Many times, there are needs to copy some text from outside konsole and paste it inside. Also, many a times, there are needs to copy from selection (within konsole) and paste it within.
So, lot of times, it is confusing between using which shortcut for which type of copy.

So, it will be really great, if we can combine these two copies to a single shortcut for Paste, in Konsole alone.

I tried to use "Synchronize contents of the clipboard and the selection" option in Klipper, but that messes the whole thing up, if I need to replace a selection with the copied text (it again copies the text which is selected to be replaced).

Could you please help me out in this? Even if combining the clipboard & selection in Konsole is not made the default behaviour, atleast an option to combine them both will really help people like me, who often get confused, as to which shortcut to use to paste the copied stuff.

Thanks a lot...
Comment 1 Robert Knight 2009-02-07 13:07:18 UTC
Actually with the default settings, Shift+Insert and Ctrl+Shift+V both paste from the clipboard.  Ctrl+Shift+Insert or middle-mouse click pastes the selection.

I take your point about the confusion having a selection and copy-paste buffer sometimes causes.  I personally tend only to use explicit copy and paste and ignore the selection.
Comment 2 Unknown 2009-04-13 15:05:29 UTC
Since there are multiple clipboards, it is generally confusing for a user like me who used to use Putty in windows. In Putty, selection will copy the text to the clipboard and Mouse Right-Click (or Shift Insert) will paste the text from clipboard. 
So, it would be really helpful, if there is an option to combine the both behaviours in Konsole, to avoid such confusions, especially for a new user.

Thanks a lot...
Comment 3 Matthew Woehlke 2009-05-22 00:44:37 UTC
> it would be really helpful, if there is an option to combine the both behaviours

There is... in klipper. ('synchronize clipboard and selection')
Comment 4 Jekyll Wu 2011-08-21 05:02:20 UTC
I do not quite follow the mentioned confusion :

1). If users want to 'paste selection', just use middle-click of mouse. Although I do prefer using keyboard shortcut to do this job, I guess most users choose middle-click in this situation.

2). If users want to 'paste clipboard', just use keyboard shortcut or context menu.

So *most* users will not be confused by the different *shortcuts* of 'paste selection' and 'paste clipboard'. They use mouse for one and keyboard for another.

Yes, *power* users preferring keyboard will notice that difference. But power users should be able to understand and remember it quickly, right? After all, the difference between selection and clipboard is a longstanding common knowledge, at least for power users.

I do not think implementing this optional feature will help many users. I'll close it.
Comment 5 Adam Batkin 2012-01-29 16:03:54 UTC
Created attachment 68302 [details]
Add "Copy to Clipboard on selection" option for profile

I have added a patch which adds an option to the Profile to use the Clipboard instead of X Selection when selecting text.

Here is my rationale for why this is useful:
I often find myself using different operating systems; Linux, Mac, Windows. The latter two don't have a concept of "Selection" in the way that X Windows does. So in terminal emulators on Mac/Windows, I always use Shift+Insert to paste text, whether it was copied from another program, or selected within a terminal.

On Linux, I mostly use the Clipboard, not the Selection. The only exception to this is in a terminal, where I frequently highlight text and need to use it in another application, or even back in a terminal. But I have some very strong "muscle memory" to always use Shift+Insert...after all, if I've copied something from another app (to the Clipboard), that's what I need. And since I'm constantly switching between computers running different operating systems (which don't have a Selection buffer) I'm used to always using Shift+Insert for paste.

I work quickly, and having to think about whether to use Shift+Insert or Ctrl+Shift+Insert, depending on where I happened to copy a piece of text from, is too much work. I want to be able to concentrate on the problem at-hand, instead of worrying about using different keystrokes depending on context.

This patch leave the default behaviour alone, but allows the user to enable the use of Clipboard instead of Selection when selecting text in Konsole, as a Profile option.
Comment 6 Adam Batkin 2012-01-30 07:07:20 UTC
Created attachment 68329 [details]
Finer grained choices for X Selection/Clipboard

New patch changes a few things:

* Creates new "Mouse" Profile Options tab with all of the mouse stuff
* Selected text can now go to X Selection AND/OR Clipboard (instead of OR)
* Middle-Mouse clicks can paste from X Selection or Profile

The whole rationale here is that I almost never care about the X Selection (and I'm probably not alone). And in the few cases where I DO care, well, that's my problem. So this patch leaves all of the defaults as-is (no one will notice a change) but for people for whom it makes a difference, now they can control what is going on.
Comment 7 Kurt Hindenburg 2012-02-18 21:56:56 UTC
This seems to duplicate some of what klipper can do.  Although I often use konsole w/o a full KDE desktop and other might not have klipper running or know about it.  
On a side note, adding a mouse tab  causes the other tab text to get shorten (at least on 1 of my systems).

I'm not positive about putting this in.

Please give feedback on patch.

git.reviewboard.kde.org/r/103861/
Comment 8 Adam Batkin 2012-02-19 00:11:49 UTC
A couple comments:

1) I'm happy to eliminate the mouse tab, and put all the options back where they were ... I just thought that it would be easier to put all the mouse stuff in one place.

2) This sort-of duplicates klipper's "Synchronize contents of the clipboard and the selection" functionality. But that feature of klipper is seriously broken. Although it does exactly what it says on the tin, if you enable it, you end up in a world of pain, so I can't enable that feature. (For example, let's say you copy something in one program, then go into another program and want to paste what you just copied...but there is already something in the text box. So you highlight what's in the text box, hit Delete and then Paste...well, since you highlighted something, that overwrote your clipboard).

In other words, klipper does not solve this problem, so support within konsole would be very useful.

Also, as mentioned, I often find myself with konsole but not in an environment in which I can run klipper.
Comment 9 Madars 2012-04-10 15:14:47 UTC
This could be very useful thing in Konsole, as in daily use selection buffer really makes a pain for productive work. Currently I have patched gnome-terminal to get same functionality. But having this functionality in KDE mainline would be very welcome!
Comment 10 Aleksandrs 2012-04-12 07:35:39 UTC
This change would be useful for me too! I need this kind of behavior only in Konsole. Would be great if you put it in!
Comment 11 Jekyll Wu 2012-04-25 04:57:13 UTC
Git commit bb818010b42a3d6fcdc4a057f0afd2e7b7a85b9f by Jekyll Wu.
Committed on 25/04/2012 at 06:08.
Pushed by jekyllwu into branch 'master'.

Add two profile options for the copy & paste behavior of mouse

  * support "automatially copy selected text into clipboard"
  * mouse middle button can be customized to paste from selectio or
    clipboard

The first feature might look like a unnecessary duplicate of the
"synchronize selection and clipboard" feature of Klipper. However, that
klipper feature is generally problematic, while doing it only in Konsole
is generally useful and harmless.
FIXED-IN: 4.9.0
REVIEW: 103861
DIGEST:

M  +48   -15   src/EditProfileDialog.cpp
M  +10   -3    src/EditProfileDialog.h
M  +159  -85   src/EditProfileDialog.ui
M  +8    -0    src/Enumeration.h
M  +8    -0    src/Profile.cpp
M  +16   -0    src/Profile.h
M  +4    -4    src/SessionController.cpp
M  +1    -1    src/SessionController.h
M  +56   -18   src/TerminalDisplay.cpp
M  +16   -7    src/TerminalDisplay.h
M  +7    -0    src/ViewManager.cpp

http://commits.kde.org/konsole/bb818010b42a3d6fcdc4a057f0afd2e7b7a85b9f