Bug 183321 - Konqueror crashes after closing its main window
Summary: Konqueror crashes after closing its main window
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: 4.2.0
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-05 16:59 UTC by gambas
Modified: 2009-02-21 23:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gambas 2009-02-05 16:59:43 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Mandriva RPMs

This is reproductable!

Go to http://www.article11.info/spip/spip.php?article289
Close the window.

Here is the backtrace:

Application : Konqueror (konqueror), signal SIGABRT
[Current thread is 1 (Thread 0xb5eca6d0 (LWP 30143))]

Thread 2 (Thread 0xb11dfb90 (LWP 609)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb7dcf101 in select () from /lib/i686/libc.so.6
#2  0xb70c45dc in QProcessManager::run (this=0x960cda0) at io/qprocess_unix.cpp:301
#3  0xb6fed89f in QThreadPrivate::start (arg=0x960cda0) at thread/qthread_unix.cpp:185
#4  0xb6511315 in start_thread () from /lib/i686/libpthread.so.0
#5  0xb7dd6dde in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb5eca6d0 (LWP 30143)):
[KCrash Handler]
#6  0xffffe430 in __kernel_vsyscall ()
#7  0xb7d27d90 in raise () from /lib/i686/libc.so.6
#8  0xb7d297f8 in abort () from /lib/i686/libc.so.6
#9  0xb7d20cce in __assert_fail () from /lib/i686/libc.so.6
#10 0xb3cde9ab in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.2.0/khtml/khtml_global.cpp:258
#11 0xb45e809d in ~KHTMLFactory (this=0x9a7e858) at /usr/src/debug/kdelibs-4.2.0/khtml/khtml_factory.cpp:35
#12 0xb70ff8b8 in QObjectCleanupHandler::clear (this=0x9a71a10) at kernel/qobjectcleanuphandler.cpp:136
#13 0xb70ff911 in ~QObjectCleanupHandler (this=0x9a71a10) at kernel/qobjectcleanuphandler.cpp:82
#14 0xb73e79ad in destroy () at /usr/src/debug/kdelibs-4.2.0/kdecore/util/kpluginfactory.cpp:29
#15 0xb72c29c9 in ~KCleanUpGlobalStatic (this=0xb74858a8) at /usr/src/debug/kdelibs-4.2.0/kdecore/kernel/kglobal.h:62
#16 0xb7d2ae69 in exit () from /lib/i686/libc.so.6
#17 0xb7d145cd in __libc_start_main () from /lib/i686/libc.so.6
#18 0x08048491 in _start ()
Comment 1 Maksim Orlovich 2009-02-21 23:18:57 UTC

*** This bug has been marked as a duplicate of bug 151453 ***