Bug 183299 - Turn off automatic class diagram reshape -- "Lock in place"
Summary: Turn off automatic class diagram reshape -- "Lock in place"
Status: RESOLVED DUPLICATE of bug 160604
Alias: None
Product: umbrello
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-05 13:39 UTC by Oliver Maurhart
Modified: 2012-05-31 21:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Maurhart 2009-02-05 13:39:42 UTC
Version:            (using KDE 4.2.0)
Compiler:          gcc-4.3.3 
OS:                Linux
Installed from:    Gentoo Packages

Umbrello is a great, great tool! ... and I would like to see:

I modify my class diagrams, e.g. resize classes and move them around, I finally find a layout which looks nice to me.

However umbrello starts reshaping the diagram whenever I change visibilty of attributes/operations/something, export the diagram to a picture etc.

I would like to disable this umbrello reshaping feature completely. Like having a "Lock in place" button somewhere to prevent umbrello from rearranging my elements since the result seldom looks good to me.
Comment 1 Oliver Maurhart 2009-02-05 14:11:28 UTC
To mention: actually the resizing of the classes is pretty annoying.
Comment 2 Ralf Habacker 2012-05-31 21:32:28 UTC

*** This bug has been marked as a duplicate of bug 160604 ***