Bug 182932 - KPilot 5.2.0 syncs with large palm databases cause a timeout on the Palm
Summary: KPilot 5.2.0 syncs with large palm databases cause a timeout on the Palm
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kpilot
Classification: Applications
Component: Calendar Conduit (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Bertjan Broeksema
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-02 23:51 UTC by Matthias Stiehler
Modified: 2010-03-14 01:36 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Debug information as requested (264.83 KB, application/gzip)
2009-02-20 17:56 UTC, Marcus Gama
Details
Result of kcrash, after kpilotdaemon crash (3.51 KB, application/octet-stream)
2009-02-20 18:00 UTC, Marcus Gama
Details
More debug information (93.94 KB, application/gzip)
2009-02-21 11:33 UTC, Marcus Gama
Details
Data generated by KCrash (4.16 KB, application/octet-stream)
2009-02-21 11:34 UTC, Marcus Gama
Details
debug info (9.19 KB, application/gzip)
2009-05-07 07:50 UTC, vaccinus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Stiehler 2009-02-02 23:51:54 UTC
Version:           5.2.0 (using KDE 4.2.0)
OS:                Linux
Installed from:    Ubuntu Packages

The Sync between KPilot 5.2.0 and Palm Centro don't go. When I start it than is it ok for the time being:
>Version: KPilot 5.2.0 (KDE 4.2.0)
>Version: pilot-link 0.12.3
>Version: KDE 4.2.00 (KDE 4.2.0)
>Version: Qt 4.4.3
>
>Schnellabgleichs-Protokoll
>
>09:38:44 KPilot-Dienst wird gestartet ...
>09:38:44 Dienst wurde gestartet.
>09:38:44 Der Status des Dienstes ist „läuft nicht“
>09:38:44 Der nächste Schnellabgleich wird Schnellabgleich sein. Bitte
> drücken Sie den Knopf für den Schnellabgleich. 09:38:44 Pilot-Gerät usb://
> existiert nicht. Das Gerät ist wahrscheinlich ein USB-Gerät und erscheint
> erst während einem Schnellabgleich. 09:38:54 Letzter PC wird überprüft ...
>09:38:54 KPilot 5.2.0 (KDE 4.2.0) Schnellabgleich wird gestartet ...
>09:38:54 Auf dem Pilot wird Zeichensatz ISO-8859-15 verwendet.
>09:38:54 [Datei-Installierer]
>09:38:54 Keine Dateien zu installieren
>09:38:54 [Abgleichmodul kpilot-conduit-calendar]
>09:40:18 Invalid record mapping. Doing first sync.
>09:40:18 Doing first sync. This may take a while.
But it don't go continue. And then the Palm show the report (in german):
"The connection between Palm and Desktop is interrupt"
The Protocoll in KPilot is not change.
When the sync with calendar is not in plan then the sync is ok.
Comment 1 Marcus Gama 2009-02-20 01:42:23 UTC
Same happened with me. Kpilotdaemon crash, but Kpilot remains working.

I'm using Akonadi + Kontact + KPilot. For the address book and TODO tasks, it was possible sync with no problems. But every time that I try to sync my Agenda, the kpilotdaemon crashes. Akonadi is working OK. More information about this issue:

- My OS is Kubuntu 8.10 and KDE 4.2
- More details:
Version: KPilot 5.2.0 (KDE 4.2.0)
Version: pilot-link 0.12.3
Version: KDE 4.2.00 (KDE 4.2.0)
Version: Qt 4.4.3
 

- My Agenda is not small (.ics file has about 600kb - 2000 registers), and this crash happens on the first sync)
 
- If I turn calendar conduit off, everything works OK

 Last message in KPilot:
20:31:47 [Canal kpilot-conduit-calendar] 
20:32:08 Invalid record mapping. Doing first sync.
20:32:08 Doing first sync. This may take a while.

After some time, KPilotDaemon crash, but KPilot window remains open.
Comment 2 Jason 'vanRijn' Kasper 2009-02-20 08:22:44 UTC
Hi Marcus, thanks for the information. The problem with the original post is that KPilot currently doesn't handle large databases very well. The problem is that it takes so long that the Handheld times out and the connection dies. I'm not sure if what you're seeing is the same thing. Can you please run "kpilotDaemon --debug=9 > ~/kpilotDaemon.debug 2>&1" for me and attach the output to this bug? Also, if you're getting an actual crash, please give me the backtrace.

Thanks! =:)
Comment 3 Marcus Gama 2009-02-20 17:56:34 UTC
Created attachment 31501 [details]
Debug information as requested

This attachment is the result of "kpilotDaemon --debug=9 > ~/kpilotDaemon.debug 2>&1" as requested.
Comment 4 Marcus Gama 2009-02-20 18:00:26 UTC
Created attachment 31502 [details]
Result of kcrash, after kpilotdaemon crash

I don't know if this is the backtrace requested. If I can help with any information, please, let me know (if I need to run a specific shell command to collect more information, etc).
Comment 5 Jason 'vanRijn' Kasper 2009-02-20 20:32:22 UTC
Hi Marcus! Ahhhh, okay, you're hitting a different problem. The good news, though, is that I'm pretty sure we fixed this one already! =:) If it's at all possible, can you build kpilot from source (http://kpilot.org/develop.php has instructions) from the branches/KDE/4.2/kdepim/kpilot directory? We have made quite a few bug fixes since KDE 4.2.0 was released. If you still hit this crash with the newest code, then please let me know. Actually, please let me know either way. =:)
Comment 6 Marcus Gama 2009-02-21 11:33:10 UTC
Created attachment 31516 [details]
More debug information

I'm not sure if I compiled correctly, but anyway, the problem persists. Debug information attached.
Comment 7 Marcus Gama 2009-02-21 11:34:19 UTC
Created attachment 31517 [details]
Data generated by KCrash

Crash still persist.
Comment 8 Jason 'vanRijn' Kasper 2009-02-21 17:47:41 UTC
Hi Marcus! Ahh, I see. it looks like you're hitting bug #183631 which causes a crash when we deal with events that end at midnight. Bertjan just put a fix in for that last night. Could you try to svn up and try things again? Can you report back on that bug instead of this one so we can keep things straight?

Thanks!! =:)
Comment 9 Douglas Harms 2009-04-06 04:00:21 UTC
I've posted a patch for review at http://reviewboard.kde.org/r/531/
Comment 10 huck416 2009-04-20 06:06:54 UTC
Having same issue with Kpilot hanging at...
22:02:16 Doing regular sync...
22:02:16 [Conduit kpilot-conduit-contacts] 
22:02:18 Invalid record mapping. Doing first sync.
22:02:18 Doing first sync. This may take a while.

Then the connection is lost on the Palm Akonadi has been sync'd. std.ics and std.vcf files are less than 50kb each. Contacts has 181 entries. Calendar very few. Tried to follow instructions at http://cvs.codeyard.net/kpilot/develop.php but could not get correct location for line "dget -x http://.............../c/cmake/cmake_VERSIONSTRING-DEBIANREVISION.dsc"

make seemed to work ok although went very quikly and did not get the colorful progress as expected so think it may not have worked correctly.

Version: KPilot 5.2.0 (KDE 4.2.0)
Version: pilot-link 0.12.3
Version: KDE 4.2.00 (KDE 4.2.0)
Version: Qt 4.4.3

Over to you guys...thx
Comment 11 Jason 'vanRijn' Kasper 2009-04-20 06:25:29 UTC
Oh, gosh, Huck, I'm sorry. I think you're hitting a different problem. Please update to the KDE 4.2.2 version of KPilot. I believe that if you run "kpilotDaemon --debug=9", you'll find that we're failing in a comparison/equality test.
Comment 12 vaccinus 2009-05-07 07:50:01 UTC
Created attachment 33417 [details]
debug info
Comment 13 vaccinus 2009-05-07 12:03:48 UTC
Hi! 
Debug log atteched in previous post (there was some problem with web..)

Kubuntu 9.04
Linux linux 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

Version: KPilot 5.2.2 (KDE 4.2.2)
Version: pilot-link 0.12.3
Version: KDE 4.2.2 (KDE 4.2.2)
Version: Qt 4.5.0



Kcrash:
"Program: KPilot Daemon (kpilotDaemon), signal SIGABRT
[Current thread is 0 (LWP 11371)]

Thread 3 (Thread 0xb48d1b90 (LWP 11372)):
#0  0xb613c0ac in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0xb6a3306b in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6a33241 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6a34e2c in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6a3161a in ?? () from /usr/lib/libQtCore.so.4
#5  0xb61d89c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb61d8dda in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb61d9268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb6a31457 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#9  0xb6a0406a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#10 0xb6a044aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#11 0xb690e639 in QThread::exec () from /usr/lib/libQtCore.so.4
#12 0xb7f425aa in ?? () from /usr/lib/libkpilot.so.4
#13 0xb691196e in ?? () from /usr/lib/libQtCore.so.4
#14 0xb634e4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0xb66dc49e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb3effb90 (LWP 11373)):
#0  0xb7f8d430 in __kernel_vsyscall ()
#1  0xb66d47b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xb69e3380 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb691196e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb634e4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb66dc49e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5f089e0 (LWP 11371)):
[KCrash Handler]
#6  0xb7f8d430 in __kernel_vsyscall ()
#7  0xb66236d0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6625098 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb6909595 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb6909681 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb6909775 in qt_assert () from /usr/lib/libQtCore.so.4
#12 0xb329e30e in ?? () from /usr/lib/kde4/kpilot_conduit_contacts.so
#13 0xb30c7d96 in RecordConduit::syncRecords () from /usr/lib/libkpilot_conduit_base.so
#14 0xb30c8788 in RecordConduit::hotOrFullSync () from /usr/lib/libkpilot_conduit_base.so
#15 0xb30cda72 in RecordConduit::exec () from /usr/lib/libkpilot_conduit_base.so
#16 0xb7f2c402 in SyncAction::execConduit () from /usr/lib/libkpilot.so.4
#17 0xb7f2c7cb in SyncAction::qt_metacall () from /usr/lib/libkpilot.so.4
#18 0xb7f30f22 in ConduitAction::qt_metacall () from /usr/lib/libkpilot.so.4
#19 0xb6a1bca8 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb6a1c932 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb6a210a7 in ?? () from /usr/lib/libQtCore.so.4
#22 0xb6a211cc in ?? () from /usr/lib/libQtCore.so.4
#23 0xb6a1615f in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb6ed7f2c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#25 0xb6ee022e in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb7afb94d in KApplication::notify () from /usr/lib/libkdeui.so.5
#27 0xb6a05a3b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#28 0xb6a34d71 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb6a314e0 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb61d5b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb61d90eb in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb61d9268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb6a31438 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#34 0xb6f793f5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb6a0406a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb6a044aa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb6a06959 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb6ed7da7 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x080735bd in _start ()"

Good luck! :)
Comment 14 Bertjan Broeksema 2009-05-30 14:10:07 UTC
Huck,

From the debug log:

company/organization not equal
....
ASSERT: "equal( pcRec, hhRec )" in file /build/buildd/kdepim-4.2.2/kpilot/conduits/contacts/contactsconduit.cc, line 485

There seems a bug in the code to compare two contacts. I'll check if this bug still exists in trunk.
Comment 15 Paul Lemmons 2009-09-04 07:44:35 UTC
I too am experiencing this bug. When I look at .xsession-errors I see hundreds of thousands of lines that show one string being compared to another. The strings are the appointment names. I have thousands of appointments. It took about 50 minutes for it to complete but by then the pilot (Palm TX) had log ago timed out.
Comment 16 Christophe Giboudeaux 2009-12-11 17:13:57 UTC
Unfortunately, KPilot is unmaintained due to lack of manpower and will not be part of KDE SC 4.4.

This bug reports will now be closed.