Bug 182508 - search & replace doesn't work with vi input mode
Summary: search & replace doesn't work with vi input mode
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: Vi Input Mode (show other bugs)
Version: unspecified
Platform: Compiled Sources All
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 307608 330071 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-30 23:22 UTC by Gabe Yoder
Modified: 2014-01-19 10:21 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabe Yoder 2009-01-30 23:22:52 UTC
Version:            (using KDE 4.2.0)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Compiled From Sources

When using the vi input mode, the search & replace dialog does not function correctly.  The "Next" button causes the cursor to always jump to the first occurrence of the search string in the file.  Similarly, the "Previous" button always jumps to the last occurrence.  The "Replace" button doesn't appear to do anything at all.
Comment 1 Erlend Hamberg 2009-01-30 23:30:01 UTC
thanks for the report!

i'm able to reproduce this and i'll have a look at it.
Comment 2 Simon St James 2012-10-20 14:22:41 UTC
*** Bug 307608 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Cullmann 2012-11-03 12:21:17 UTC
Simon, could you give your patch a new try :=) Seems you are interested in fixing this ;)
Comment 4 Simon St James 2012-11-03 12:36:56 UTC
(In reply to comment #3)
> Simon, could you give your patch a new try :=) Seems you are interested in
> fixing this ;)

Hi Christoph,

I think I'll probably end up taking a competely different tack and implementing an (optional) Vi Command Mode that lives in the Vi status  bar, and leaving the Kate Search/ Replace dialog untouched - there's already quite a lot of Vi mode special cases in there, and even more would need to be required for what I have planned :)
Comment 5 Michal Humpula 2014-01-17 12:57:59 UTC
*** Bug 330071 has been marked as a duplicate of this bug. ***
Comment 6 Michal Humpula 2014-01-19 10:21:44 UTC
In general the searchbar works in vi-mode, but there is too much of special case handling involved, that some corner cases breaks. The only way to fix it on kde 4 branch is to add even more special case handling to the searchbar code. So as for kde 4 branch, corner cases wont be fixed. In KF5 the searchbar is completely replaced by KateViEmulatedCommandBar, which doesn't exhibit the problems. So closing as fixed in 5.0.