Bug 182472 - kded and kdirwatch not recognizing new .desktop files
Summary: kded and kdirwatch not recognizing new .desktop files
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-30 19:27 UTC by Rex Dieter
Modified: 2009-01-30 21:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rex Dieter 2009-01-30 19:27:45 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Fedora RPMs

Since 4.2.0 release, kded doesn't seem to detect newly installed .desktop files and rerun kbuildsycoca4.

iirc, it *did* work in kde-4.0.96 (but don't quote me on that).
Comment 1 Jure Repinc 2009-01-30 20:00:06 UTC
Also confirmed on Mandriva 2009.1 Cooker upgraded to KDE 4.2.0 final.
Comment 2 David Faure 2009-01-30 21:28:30 UTC
SVN commit 918838 by dfaure:

Fix regression introduced by r910248; two bools (b_checkUpdates and bCheckUpdates) for the same thing,
and b_checkUpdates was always false, so the directories were never watched, and people had to run
kbuildsycoca4 by hand after installing new desktop files.
BUG: 182472


 M  +8 -9      kded.cpp  
 M  +1 -3      kded.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=918838