Bug 182367 - By default, no way to browse tags assigned in Dolphin (maybe show "tags:/" KIOSlave as a Bookmark by default)
Summary: By default, no way to browse tags assigned in Dolphin (maybe show "tags:/" KI...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Unspecified
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
: 286079 304406 375117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-30 00:39 UTC by Dotan Cohen
Modified: 2019-03-20 00:52 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-01-30 00:39:36 UTC
Version:            (using KDE 4.2.0)
Installed from:    Ubuntu Packages

In Dolphin one can assign tags to files and to directories. However, there does not seem to be a way to browse the assigned tags. If there is no way to browse the tags, then this bug is a Request for Enhancement to add that functionality. If there _is_ a way, then this bug requests that it be made more obvious.
Comment 1 Angel Blue01 2009-03-11 18:53:08 UTC
This is probably one of the many things of Nepomuk that will be solved in some future version of KDE
Comment 2 Dotan Cohen 2009-03-11 19:51:43 UTC
Thank you AngelBlue01 for making an uninformed guess about what you think an incomplete application might "probably" do with Dolphin.

Bugzilla is not a discussion forum or a crystal ball. Please do not pollute it with uninformed comments. If you are not a Nepomuk or Dolphin developer, please do not guess what integration between the two applications you think may be possible, other than filing a feature request for a specific type of integration. Thanks.
Comment 3 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:21:36 UTC
Resetting assignee to default as per bug #305719
Comment 4 Nate Graham 2017-09-02 20:34:51 UTC
As of today, Dolphin actually does have a visible tag browsing UI. It's just hidden by default, because it's empty until at least one tag has been created. You can access it by going to "tags:/". You can even make a bookmark out of it to have it always show up under the location panel's Places header.

We should investigate ways to resolve this situation. Some random ideas:
1. The first time a tag is created, make a "tags:/" bookmark appear under the Location panel's Places header
2. The first time a tag is created, create a new header in the location panel called "Tags", with an entry below it for each tag created (this is what macOS Finder does, and it's very nice)
3. Ship Dolphin with a "tags:/" bookmark by default, but when you navigate there when there are no tags, change the empty white background to a message informing the user that it will fill up with tags as they are created
Comment 5 Nate Graham 2017-09-02 23:00:41 UTC
*** Bug 286079 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2017-09-02 23:22:53 UTC
*** Bug 375117 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2017-09-02 23:24:05 UTC
Option 4: make "tags:/" appear as a bookmark in Places by default, and work on improving the presentation later.
Comment 8 Nate Graham 2017-09-03 00:05:55 UTC
Patch submitted that pursues the path of least resistance (Option 4): https://phabricator.kde.org/D7668

If the patch is accepted, I will work on improving the usability, probably adding some explanatory text in the background.
Comment 9 Nate Graham 2017-09-03 06:13:34 UTC
*** Bug 304406 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2017-09-28 00:55:22 UTC
We are now pursuing a better, more comprehensive change: https://phabricator.kde.org/D7700
Comment 11 Nicolas Fella 2018-11-13 17:06:23 UTC
Git commit 2ae8a0c374cd175380945fc7fae1a38957272435 by Nicolas Fella.
Committed on 13/11/2018 at 17:06.
Pushed by nicolasfella into branch 'master'.

Show list of tags in PlacesView

Summary:
Show list of available Tags in PlacesView. In addition show "All tags" entry.

Test Plan: Assign some tags to files, force a reindex of the files and restart Dolphin to see the result

Reviewers: #dolphin, #kde_applications, alexeymin, ngraham

Reviewed By: #dolphin, #kde_applications, alexeymin, ngraham

Subscribers: kde-frameworks-devel, bruns, rkflx, mmustac, spoorun, michaelh, renatoo, anthonyfieroni, cfeck, elvisangelaccio, emmanuelp, ngraham, alexeymin, #dolphin

Tags: #dolphin, #frameworks

Maniphest Tasks: T8349

Differential Revision: https://phabricator.kde.org/D7700

M  +7    -0    src/filewidgets/kfileplacesitem.cpp
M  +2    -1    src/filewidgets/kfileplacesitem_p.h
M  +53   -2    src/filewidgets/kfileplacesmodel.cpp
M  +2    -1    src/filewidgets/kfileplacesmodel.h

https://commits.kde.org/kio/2ae8a0c374cd175380945fc7fae1a38957272435
Comment 12 Nicolas Fella 2019-03-20 00:52:34 UTC
Git commit 523acf53dadcb3f27278feec357bf7ce2f42fc0f by Nicolas Fella.
Committed on 20/03/2019 at 00:49.
Pushed by nicolasfella into branch 'master'.

Show list of tags in PlacesView

Summary:
Show list of available Tags in PlacesView. In addition show "All tags" entry.

Test Plan: Assign some tags to files, force a reindex of the files and restart Dolphin to see the result

Reviewers: #dolphin, #kde_applications, alexeymin, ngraham, broulik

Reviewed By: #dolphin, #kde_applications, alexeymin, ngraham

Subscribers: broulik, kde-frameworks-devel, bruns, rkflx, mmustac, spoorun, michaelh, renatoo, anthonyfieroni, cfeck, elvisangelaccio, emmanuelp, ngraham, alexeymin, #dolphin

Tags: #dolphin, #frameworks

Maniphest Tasks: T8349

Differential Revision: https://phabricator.kde.org/D7700

M  +17   -0    src/filewidgets/kfileplacesitem.cpp
M  +4    -1    src/filewidgets/kfileplacesitem_p.h
M  +99   -23   src/filewidgets/kfileplacesmodel.cpp
M  +3    -1    src/filewidgets/kfileplacesmodel.h

https://commits.kde.org/kio/523acf53dadcb3f27278feec357bf7ce2f42fc0f