Bug 182257 - Dolphin doesn't play animated GIFs in the preview on mouseover.
Summary: Dolphin doesn't play animated GIFs in the preview on mouseover.
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: panels: information (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR wishlist with 12 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 263222 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-29 06:39 UTC by Downhill Games
Modified: 2019-09-21 14:28 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.11.80


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Downhill Games 2009-01-29 06:39:47 UTC
Version:           1.2 (using KDE 4.2.0)
OS:                Linux
Installed from:    Ubuntu Packages

Hello folks!

Dolphin, as you know, has this really nifty feature in the "Information" pane that allows you to see files quickly without having to open them, hit some preview key or context menu entry, etc. It's nice! However, right now it only shows the first frame for GIFs. This is fine they're non-animated and/or if you don't have, say, 6 animated GIFs in a folder that only slightly vary. You can probably think of other use cases where a full-length thumbnail of animated GIFs would be useful :)

Please include this in Dolphin.

Thank you for all your *wonderful* work on KDE4! Keep it up, folks! =D

Also, thank you for your time,
Downhill
Comment 1 Frank Reininghaus 2011-01-15 16:41:58 UTC
*** Bug 263222 has been marked as a duplicate of this bug. ***
Comment 2 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:22:27 UTC
Resetting assignee to default as per bug #305719
Comment 3 Méven Car 2019-09-01 16:05:39 UTC
Patch proposed: https://phabricator.kde.org/D23538
Comment 4 Elvis Angelaccio 2019-09-21 14:28:42 UTC
Git commit c0ca8f2c79c9b0e9f6db47dd86a1434d4e3de5bb by Elvis Angelaccio, on behalf of Ismael Asensio.
Committed on 21/09/2019 at 14:25.
Pushed by elvisangelaccio into branch 'master'.

[dolphin] Animate gifs on preview

Summary:
Adds the capability to view animated images on the preview in the information panel.
This was a request from a user back in 2009 (https://bugs.kde.org/show_bug.cgi?id=182257), but I think nowadays with stickers/memes and what not, it's even more useful.
It keeps the size default transition of the preview viewer before starting the animation, so that the visual integration is smoother.

{F7289110}
FIXED-IN: 19.11.80

Test Plan: Open the information panel and hover over some animated images (gif/webp/mng)

Reviewers: #dolphin, #vdg, ngraham, elvisangelaccio

Reviewed By: #vdg, ngraham

Subscribers: pino, fuksitter, meven, broulik, kfm-devel

Tags: #dolphin

Differential Revision: https://phabricator.kde.org/D23538

M  +9    -1    src/panels/information/informationpanelcontent.cpp
M  +73   -5    src/panels/information/pixmapviewer.cpp
M  +14   -0    src/panels/information/pixmapviewer.h

https://commits.kde.org/dolphin/c0ca8f2c79c9b0e9f6db47dd86a1434d4e3de5bb