Bug 182082 - KWin runs only on one screen in dual TwinView setup
Summary: KWin runs only on one screen in dual TwinView setup
Status: RESOLVED DUPLICATE of bug 256242
Alias: None
Product: kwin
Classification: Unclassified
Component: multi-screen (show other bugs)
Version: unspecified
Platform: Debian testing Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-27 12:28 UTC by Arne Schmitz
Modified: 2011-01-22 12:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Schmitz 2009-01-27 12:28:13 UTC
Version:            (using KDE 3.5.9)
Installed from:    Debian testing/unstable Packages

What I did:

I have a machine with two graphics cards, each having two DVI outputs. I connected 4 screens to those cards, each card functioning in TwinView clone mode (for stereo rendering), both cards combined to form two X displays, :0.0 and :0.1.

What I expected:

I expected kwin to manage both screens.

What I got instead:

Kwin runs only on :0.0, but not on :0.1, while the rest of KDE correctly shows up on the second screen.  I can manually run a second kwin, but that is just a workaround.
Comment 1 Michael Leupold 2010-10-10 13:33:12 UTC
Unfortunately none of us have such a setup. Can you still reproduce this bug using a recent version of KDE (eg. KDE 4.5)?
Comment 2 imehl_adresse 2010-11-10 13:05:05 UTC
I can confirm this with kde-4.5.3 on gentoo.

I have 2 graphics and 3 displays. 

kwin only starts on DISPLAY=:0.0 but not on :0.1.

Also Kephal couldnt detect multi displays, if a display is on the second GFX.k
Comment 3 imehl_adresse 2010-11-10 13:06:14 UTC
I can confirm this with kde-4.5.3 on gentoo using fglrx

I have 2 graphics and 3 displays. 

kwin only starts on DISPLAY=:0.0 but not on :0.1.

Also Kephal couldnt detect multi displays, if a display is on the second GFX.
Comment 4 Thomas Lübking 2010-11-10 18:37:50 UTC
see bug #256242
Comment 5 Martin Flöser 2011-01-22 12:56:38 UTC
it should be possible to start kwin on the second head. It just does not start automatically.

*** This bug has been marked as a duplicate of bug 256242 ***