Bug 182037 - Two sequential clicks on Unapply difference crash Kompare
Summary: Two sequential clicks on Unapply difference crash Kompare
Status: RESOLVED DUPLICATE of bug 169692
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-26 23:15 UTC by Grzegorz Kossakowski
Modified: 2009-01-26 23:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Kossakowski 2009-01-26 23:15:23 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Open some patch in Kompare and click two times on Unapply difference button.

Kompare will crash returning following report:
Program: Kompare (kompare), sygnał SIGSEGV
[Current thread is 1 (Thread 0xb5bcb700 (LWP 14205))]

Thread 1 (Thread 0xb5bcb700 (LWP 14205)):
[KCrash Handler]
#6  0xb80462cd in Diff2::KompareModelList::slotActionUnApplyDifference() () from /usr/lib/libkomparediff2.so.4
#7  0xb804ad4d in Diff2::KompareModelList::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkomparediff2.so.4
#8  0xb67ba580 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#9  0xb67ba980 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /usr/lib/libQtCore.so.4
#10 0xb6c59631 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
#11 0xb6c59f9f in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
#12 0xb707e032 in QToolButton::nextCheckState() () from /usr/lib/libQtGui.so.4
#13 0xb6fa1893 in ?? () from /usr/lib/libQtGui.so.4
#14 0xb6fa1b66 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb707e52c in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb6cb7a62 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb6f9fbfe in QAbstractButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
#18 0xb707dff4 in QToolButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
#19 0xb6c5f8fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb6c68111 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb76309dd in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb67a5961 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb6c6739e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#24 0xb6cd1746 in ?? () from /usr/lib/libQtGui.so.4
#25 0xb6cd0af5 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb6cf90ba in ?? () from /usr/lib/libQtGui.so.4
#27 0xb5f989a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0xb5f9c063 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0xb5f9c221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0xb67cffb8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb6cf87b5 in ?? () from /usr/lib/libQtGui.so.4
#32 0xb67a401a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0xb67a41da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0xb67a6895 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#35 0xb6c5f777 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#36 0x0805038d in _start ()
Comment 1 Kevin Kofler 2009-01-26 23:31:42 UTC

*** This bug has been marked as a duplicate of bug 169692 ***