Bug 181612 - QuickLaunch widget: icons can not be rearranged by dragging them around
Summary: QuickLaunch widget: icons can not be rearranged by dragging them around
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-quicklaunch (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Lukas Appelhans
URL:
Keywords:
: 185400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-22 17:21 UTC by vatbier
Modified: 2009-05-11 18:29 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vatbier 2009-01-22 17:21:03 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Quicklaunch
Version 0.1
Using KDE 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1))
in virtual machine kde4daily in Virtualbox.

Is the source of this Quicklaunch widget the same as the one in 
http://kde-look.org/content/show.php/QuickLauncher+Applet?content=78061 ?
That one is already at version 0.5 and has the ability to "rearrange icons by dragging them in place".
Please update to version 0.5 if it is compatible with KDE 4.2.
Comment 1 Jonathan Thomas 2009-03-26 01:05:23 UTC
*** Bug 185400 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Thomas 2009-03-26 01:06:41 UTC
To answer your questions:
-These are not the same widgets
-The kde-look widget is not compatible with KDE 4.2

Icon re-arranging would have to be implemented from scratch for the official Quicklaunch plasmoid.
Comment 3 Lukas Appelhans 2009-05-11 18:29:44 UTC
SVN commit 966617 by lappelhans:

-Make icons being rearrangeable, patch by Shafqat Bhuiyan, thank you 
very much!
-Fix crash when dropping something on an existing icon...
CCMAIL:priomsrb@gmail.com
BUG:181612


 M  +36 -4     quicklaunchApplet.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=966617