Bug 181606 - Ugly Eclipse pop-up menu fade-in when using desktop effects.
Summary: Ugly Eclipse pop-up menu fade-in when using desktop effects.
Status: RESOLVED DUPLICATE of bug 170462
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-22 16:37 UTC by Duncan Doyle
Modified: 2009-01-22 17:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Duncan Doyle 2009-01-22 16:37:38 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Eclipse 3.4 (on a SUN Java 6 1.6.10 JVM), KDE 4.2RC1 using KWin as Window Manager with desktop effects enabled. 

When I open a pop-up menu in Eclipse, the menu is first shortly displayed as a black box, after which the menu-items appear. It looks to me that the fade-in doesn't work properly on these kind of menus, resulting in a rather ugly behavior of these pop-up menus.

This behavior does not occur with other non-KDE apps (e.g. Firefox, OpenOffice), nor does it occur when using Eclipse on KDE with Compiz as Window Manager.
Comment 1 Martin Flöser 2009-01-22 16:47:50 UTC
What distribution are you using? I'm wondering if this is a duplicate of bug #170462.
Comment 2 Duncan Doyle 2009-01-22 17:56:11 UTC
I'm on Kubuntu Intrepid Ibex with KDE 4.2 RC1 from http://ppa.launchpad.net/kubuntu-experimental/ubuntu

I read the bug-report and it seems like the same issue. I did some additional testing and once in a while, the pop-up menus are not black, but indeed display garbage (happens sometimes on a restore of the full Eclipse window as well by the way).

I marked the bug as a duplicate as it seems a to be the same issue. I will open a new one if this isn't fixed in the upcoming Jaunty Jackalope release.

*** This bug has been marked as a duplicate of bug 170462 ***