Bug 181552 - New widget styles should be installable via GHNS
Summary: New widget styles should be installable via GHNS
Status: RESOLVED NOT A BUG
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 4.1
Platform: Compiled Sources Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-22 00:25 UTC by Michael Stather
Modified: 2018-06-20 13:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stather 2009-01-22 00:25:05 UTC
Version:            (using Devel)
Installed from:    Compiled sources

I can install new plasma themes and also wallpapers in the appearance settings dialog of the desktop, but I currently can't download theme packages in the appearance control panel.
This could be added and be a nice addition IMHO
Comment 1 Pino Toscano 2009-01-22 00:42:56 UTC
Given that widget style are binary plugins, they cannot be shipped and installed as they were images, but they need to be compiled on the machine where they have to be run.
Comment 2 John 2018-04-13 16:08:56 UTC
(In reply to Pino Toscano from comment #1)
> Given that widget style are binary plugins, they cannot be shipped and
> installed as they were images, but they need to be compiled on the machine
> where they have to be run.

Does this still apply?
I ask this because i would like to reopen this bug, if the above comment does not make sense anymore. At present time there are a lot of things we can already download from GHNS and this would be a plus!
Comment 3 John 2018-04-13 16:12:48 UTC
I'm referring to adding a button for GHNS to download Widget Styles in System Settings > Application Style > Applications
in case i was not clear enough :)
Comment 4 Christoph Feck 2018-04-13 21:37:29 UTC
Widget styles are still binary plugins. Some of these, e.g. QtCurve, might offer GHNS support separately.
Comment 5 John 2018-04-16 16:27:45 UTC
(In reply to Christoph Feck from comment #4)
> Widget styles are still binary plugins. Some of these, e.g. QtCurve, might
> offer GHNS support separately.

Hi Christoph. I was talking with Nate in his blog ( https://pointieststick.wordpress.com/2018/04/07/this-week-in-usability-productivity-part-13/comment-page-1/#comment-908 ) about this bug report.

From what i understand, you think the limitation still applies (making it useless to reopen the bug), right?
Comment 6 John 2018-06-19 10:51:15 UTC
(In reply to Christoph Feck from comment #4)
> Widget styles are still binary plugins. Some of these, e.g. QtCurve, might
> offer GHNS support separately.

@Christoph Feck could you please check if the explanation you gave above also applies for bug reports #393052 and #386621 ?

Thank You
Comment 7 Christoph Feck 2018-06-20 13:35:48 UTC
Unsure. Plasma uses QML (which is just extended JavaScript), so it might be possible to extend it without binary plugins.