Bug 181474 - podcasts not downloading or saving
Summary: podcasts not downloading or saving
Status: RESOLVED DUPLICATE of bug 180851
Alias: None
Product: amarok
Classification: Applications
Component: Podcast (show other bugs)
Version: 2.0.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-21 09:00 UTC by Steve Cordwell
Modified: 2009-01-22 01:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Cordwell 2009-01-21 09:00:43 UTC
Version:           2.0.1 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

When I add a podcast with "Add Podcast" and click "Ok", the podcasts are added ok (but some of them are also added as a 'subpodcast' to other podcasts), but when I click "Download Episode" it doesn't download at all. There is not even any folders or files created in ~/.kde/apps/amarok/podcasts. For example there is no /home/stevo/.kde/share/apps/amarok/podcasts/Wantok, even though I added the "Wantok" podcast and clicked "Download Episode". I also tried setting "Download when available" to true for this podcast under "Configure" but the podcast was still not downloaded.
However I can stream the podcasts with no trouble. But after I have listened to a podcast, it is still not saved to my hard-drive.
I would like to be able to download podcasts at my university campus (because its free) and listen to them later at home.
Comment 1 Bart Cerneels 2009-01-21 20:21:49 UTC
The duplicates is a know problem see http://bugs.kde.org/show_bug.cgi?id=181516 . The inability to download is already fixed and will be included in 2.0.2. This shouldn't be an issue anymore with the current version if you restart amarok. Just remember to restart when you want to download episodes of a new podcast.

Sorry for the inconvenience. You are helping me fix it for the next version with this bug report though, thanks.

*** This bug has been marked as a duplicate of bug 180851 ***
Comment 2 Steve Cordwell 2009-01-22 01:30:33 UTC
oh ok. sorry about that, i tried searching to see if it was already reported but i guess i didn't try hard enough :)