Bug 181323 - Blank Screen After Waking Up from Suspend
Summary: Blank Screen After Waking Up from Suspend
Status: RESOLVED DUPLICATE of bug 184062
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 176644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-19 18:09 UTC by Mehul Rajput
Modified: 2010-05-11 05:58 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mehul Rajput 2009-01-19 18:09:56 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

OK this is a problem I can consistently replicate.

I use desktop effects in gnome and in kde4. In gnome when I suspend and resume everything works, applications, panels etc.

In KDE4 if I suspend and resume then applications work using alt + tab, but the panel are blank, only system tray icons are visible, the show hide icon is not displayed. None of the other items in panels are displayed e.g. task manager, pager, clock, there is just white back ground in panel. 

On the desktop, no widgets are there only white back ground, mouse clicks does on work on this white back ground.

The menu short cut of alt + f1 does not work.

If I now restart kdm from tty1, and then login then there is just a blank black screen, auto start application are getting started as their notifications are displayed, but nothing else.

This problem is resolved only by reboot, I do it from kdm login window or from tty1.
Comment 1 Markus Straub 2009-01-21 09:48:11 UTC
I don't use desktop effects but have the same problem for KDE 4.2 RC1:
When the PC wakes up from suspend to RAM, the Panel and the Desktop - if it isn't covered by any open programs - are blank.  Exceptions are the systray and windows that are already open - they work normally.

In my case the panel and the desktop continue working as soon as the WLAN connection is established!
Comment 2 Mehul Rajput 2009-01-28 05:10:47 UTC
I think there is something wierd going on. If I do not plugin my lan cable, the desktop is responsive. but as soon as I plugin the lan cable the desktop hangs. May be this is helpful tip, something wrong with network management applet which hangs the desktop.
Comment 3 Markus Straub 2009-01-29 09:00:45 UTC
The bug is still present in KDE 4.2 final.

Also I found out, that the hang only occurs when the following (and only) network share is mounted over cifs: 

//192.168.0.100/goods /mnt/goods cifs defaults,user,credentials=/etc/samba/user,dir_mode=0777,file_mode=0777,iocharset=utf8,auto,uid=markus,serverino 0 0
Comment 4 Aaron J. Seigo 2009-06-23 02:09:23 UTC
*** Bug 176644 has been marked as a duplicate of this bug. ***
Comment 5 Aaron J. Seigo 2009-06-23 02:20:11 UTC
@Mehul: do you have a folderview set to remote content? or any other widgets that are using the network?

@Markus: do you have a folderview viewing that location on disk? if you remove the kickoff launcher and repeat the experiment, does it still happen for you?
Comment 6 Dario Andres 2009-07-18 20:31:29 UTC
Marking as NEEDSINFO
Comment 7 Markus Straub 2009-07-22 11:13:17 UTC
@Aaron: thanks for caring about this bug!

o) No, I don't have a folder view of that disc location
o) No, if I remove the Kickoff Application Launcher, it does not happen anymore! (The system is responsive from the beginning, not only when (in my case) the WLAN connection has been established)
Comment 8 Dario Andres 2009-07-22 16:15:18 UTC
Hi, comment 7 remember me bug 184062 (kickoff blocking plasma when some network partition is killed because of the lost of internet connection). Could you check it if you find some other coincidence ?
Thanks
Comment 9 Aaron J. Seigo 2010-05-11 05:58:05 UTC

*** This bug has been marked as a duplicate of bug 184062 ***