Bug 181268 - kdebluetooth crash then disconnect bluetoothhardware
Summary: kdebluetooth crash then disconnect bluetoothhardware
Status: RESOLVED FIXED
Alias: None
Product: kde-bluetooth
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Tom Patzig
URL:
Keywords:
: 181888 183231 183477 186051 191321 195655 196354 197371 200849 203044 206057 213531 214880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-19 09:03 UTC by Johann-Nikolaus Andreae
Modified: 2017-10-18 12:50 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
backtrace (7.77 KB, text/plain)
2009-01-19 09:04 UTC, Johann-Nikolaus Andreae
Details
crash after removing bluetooth device (8.89 KB, application/octet-stream)
2009-05-06 16:59 UTC, marcela maslanova
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johann-Nikolaus Andreae 2009-01-19 09:03:30 UTC
Version:           kdebluetooth4-0.3 (using Devel)
OS:                Linux
Installed from:    Compiled sources

I start kbluetooth4
- Connect the bluetoothhardware using the hardware switch of the notebook.
- The bluetooth icon appear at the trybar
- Disconnect the hardware
- kbluetooth4 crash
Comment 1 Johann-Nikolaus Andreae 2009-01-19 09:04:18 UTC
Created attachment 30410 [details]
backtrace
Comment 2 Dario Andres 2009-01-19 12:04:18 UTC
Pasted backtrace from comment 1:

Anwendung: KBluetooth4 - The KDE4 Bluetooth Framework (kbluetooth4), Signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[Current thread is 1 (Thread 0xb5f61700 (LWP 5256))]

Thread 1 (Thread 0xb5f61700 (LWP 5256)):
[KCrash Handler]
#6  0x0f000030 in ?? ()
#7  0xb73eec06 in QDBusConnectionPrivate::activateCall (this=0x80faa38, object=0x812f728, flags=273, msg=@0x812c990) at qdbusintegrator.cpp:710
#8  0xb73ef461 in QDBusConnectionPrivate::activateObject (this=0x80faa38, node=@0x812c97c, msg=@0x812c990, pathStartPos=18) at qdbusintegrator.cpp:1305
#9  0xb73ef95a in QDBusActivateObjectEvent::placeMetaCall (this=0x812c950) at qdbusintegrator.cpp:1399
#10 0xb72f2b51 in QObject::event (this=0xbf8a3020, e=0x812c950) at kernel/qobject.cpp:1154
#11 0xb72e2b8b in QCoreApplication::event (this=0xbf8a3020, e=0x812c950) at kernel/qcoreapplication.cpp:1391
#12 0xb69c1606 in QApplication::event (this=0xbf8a3020, e=0x812c950) at kernel/qapplication.cpp:2187
#13 0xb69bbd0c in QApplicationPrivate::notify_helper (this=0x808d860, receiver=0xbf8a3020, e=0x812c950) at kernel/qapplication.cpp:3803
#14 0xb69c3b6e in QApplication::notify (this=0xbf8a3020, receiver=0xbf8a3020, e=0x812c950) at kernel/qapplication.cpp:3393
#15 0xb7af98fd in KApplication::notify (this=0xbf8a3020, receiver=0xbf8a3020, event=0x812c950) at /usr/src/debug/kdelibs-4.1.96/kdeui/kernel/kapplication.cpp:307
#16 0xb72e3231 in QCoreApplication::notifyInternal (this=0xbf8a3020, receiver=0xbf8a3020, event=0x812c950) at kernel/qcoreapplication.cpp:586
#17 0xb72e3ea5 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8073f68) at kernel/qcoreapplication.h:208
#18 0xb72e409d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1097
#19 0xb730dc6f in postEventSourceDispatch (s=0x808fb20) at kernel/qcoreapplication.h:213
#20 0xb62d69a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0xb62da063 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0xb62da221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0xb730d8b8 in QEventDispatcherGlib::processEvents (this=0x808cd70, flags={i = -1081467064}) at kernel/qeventdispatcher_glib.cpp:318
#24 0xb6a54c95 in QGuiEventDispatcherGlib::processEvents (this=0x808cd70, flags={i = -1081467016}) at kernel/qguieventdispatcher_glib.cpp:197
#25 0xb72e18ea in QEventLoop::processEvents (this=0xbf8a20c4, flags={i = -1081466952}) at kernel/qeventloop.cpp:142
#26 0xb72e1aaa in QEventLoop::exec (this=0xbf8a20c4, flags={i = -1081466640}) at kernel/qeventloop.cpp:193
#27 0xb73f19c1 in QDBusConnectionPrivate::sendWithReply (this=0x8229a88, message=@0xbf8a2248, sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1693
#28 0xb73dda81 in QDBusConnection::call (this=0x81d608c, message=@0xbf8a2248, mode=QDBus::BlockWithGui, timeout=-1) at qdbusconnection.cpp:511
#29 0xb73faa4b in QDBusAbstractInterface::callWithArgumentList (this=0x8115c98, mode=QDBus::BlockWithGui, method=@0xbf8a23e8, args=@0xbf8a2328) at qdbusabstractinterface.cpp:396
#30 0xb73fc8fd in QDBusAbstractInterface::call (this=0x8115c98, mode=QDBus::BlockWithGui, method=@0xbf8a23e8, arg1=@0xbf8a23d8, arg2=@0xbf8a23cc, arg3=@0xbf8a23c0, arg4=@0xbf8a23b4, 
    arg5=@0xbf8a23a8, arg6=@0xbf8a239c, arg7=@0xbf8a2390, arg8=@0xbf8a2384) at qdbusabstractinterface.cpp:629
#31 0x08062b2f in ObexServer::stop (this=0x8199200) at /usr/src/debug/kdebluetooth4-0.3/src/obexserver/obexserver.cpp:100
#32 0x0805207a in KBlueTray::offlineMode (this=0xbf8a2f84) at /usr/src/debug/kdebluetooth4-0.3/src/trayicon.cpp:239
#33 0x08053f13 in KBlueTray::adapterRemoved (this=0xbf8a2f84, ubi=@0xbf8a26a0) at /usr/src/debug/kdebluetooth4-0.3/src/trayicon.cpp:294
#34 0x08050ea0 in KBlueTray::qt_metacall (this=0xbf8a2f84, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbf8a253c) at /usr/src/debug/kdebluetooth4-0.3/build/src/moc_trayicon.cpp:141
#35 0xb72f7e71 in QMetaObject::activate (sender=0x80edf90, from_signal_index=5, to_signal_index=5, argv=0xbf8a253c) at kernel/qobject.cpp:3035
#36 0xb72f8c02 in QMetaObject::activate (sender=0x80edf90, m=0xb7841ac8, local_signal_index=1, argv=0xbf8a253c) at kernel/qobject.cpp:3105
#37 0xb7831993 in Solid::Control::BluetoothManager::interfaceRemoved (this=0x80edf90, _t1=@0xbf8a26a0) at /usr/src/debug/kdebase-workspace-4.1.96/build/libs/solid/control/bluetoothmanager.moc:104
#38 0xb7831ca2 in Solid::Control::BluetoothManagerPrivate::_k_interfaceRemoved (this=0x80ee010, ubi=@0xbf8a26a0) at /usr/src/debug/kdebase-workspace-4.1.96/libs/solid/control/bluetoothmanager.cpp:271
#39 0xb7832c05 in Solid::Control::BluetoothManager::qt_metacall (this=0x80edf90, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf8a266c)
    at /usr/src/debug/kdebase-workspace-4.1.96/build/libs/solid/control/bluetoothmanager.moc:84
#40 0xb72f7e71 in QMetaObject::activate (sender=0x81361f8, from_signal_index=5, to_signal_index=5, argv=0xbf8a266c) at kernel/qobject.cpp:3035
#41 0xb72f8c02 in QMetaObject::activate (sender=0x81361f8, m=0xb637ed88, local_signal_index=1, argv=0xbf8a266c) at kernel/qobject.cpp:3105
#42 0xb637a523 in Solid::Control::Ifaces::BluetoothManager::interfaceRemoved (this=0x81361f8, _t1=@0xbf8a26a0)
    at /usr/src/debug/kdebase-workspace-4.1.96/build/libs/solid/control/ifaces/bluetoothmanager.moc:90
#43 0xb46ace22 in BluezBluetoothManager::slotDeviceRemoved (this=0x81361f8, adapter=@0x81e2af0) at /usr/src/debug/kdebase-workspace-4.1.96/solid/bluez/bluez-bluetoothmanager.cpp:202
#44 0xb46ad8b5 in BluezBluetoothManager::qt_metacall (this=0x81361f8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf8a284c)
    at /usr/src/debug/kdebase-workspace-4.1.96/build/solid/bluez/bluez-bluetoothmanager.moc:73
#45 0xb73ede8f in QDBusConnectionPrivate::deliverCall (this=0x80faa38, object=0x81361f8, msg=@0x81688fc, metaTypes=@0x8168900, slotIdx=8) at qdbusintegrator.cpp:848
#46 0xb73f5217 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#47 0xb72f2b51 in QObject::event (this=0x81361f8, e=0x81688d0) at kernel/qobject.cpp:1154
#48 0xb69bbd0c in QApplicationPrivate::notify_helper (this=0x808d860, receiver=0x81361f8, e=0x81688d0) at kernel/qapplication.cpp:3803
#49 0xb69c3b6e in QApplication::notify (this=0xbf8a3020, receiver=0x81361f8, e=0x81688d0) at kernel/qapplication.cpp:3393
#50 0xb7af98fd in KApplication::notify (this=0xbf8a3020, receiver=0x81361f8, event=0x81688d0) at /usr/src/debug/kdelibs-4.1.96/kdeui/kernel/kapplication.cpp:307
#51 0xb72e3231 in QCoreApplication::notifyInternal (this=0xbf8a3020, receiver=0x81361f8, event=0x81688d0) at kernel/qcoreapplication.cpp:586
#52 0xb72e3ea5 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8073f68) at kernel/qcoreapplication.h:208
#53 0xb72e409d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1097
#54 0xb730dc6f in postEventSourceDispatch (s=0x808fb20) at kernel/qcoreapplication.h:213
#55 0xb62d69a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#56 0xb62da063 in ?? () from /usr/lib/libglib-2.0.so.0
#57 0xb62da221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#58 0xb730d8b8 in QEventDispatcherGlib::processEvents (this=0x808cd70, flags={i = -1081463192}) at kernel/qeventdispatcher_glib.cpp:318
#59 0xb6a54c95 in QGuiEventDispatcherGlib::processEvents (this=0x808cd70, flags={i = -1081463144}) at kernel/qguieventdispatcher_glib.cpp:197
#60 0xb72e18ea in QEventLoop::processEvents (this=0xbf8a2f10, flags={i = -1081463080}) at kernel/qeventloop.cpp:142
#61 0xb72e1aaa in QEventLoop::exec (this=0xbf8a2f10, flags={i = -1081463016}) at kernel/qeventloop.cpp:193
#62 0xb72e4165 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:851
#63 0xb69bbb87 in QApplication::exec () at kernel/qapplication.cpp:3331
#64 0x08051a0e in main (argc=1, argv=0xbf8a3124) at /usr/src/debug/kdebluetooth4-0.3/src/main.cpp:77

Comment 3 Tom Patzig 2009-01-19 18:02:46 UTC
I see... the problem might be caused by the blocking dbus calls to stop the obex-data-server when changing to offline mode. Although i never get these problems on my machine.
Regardless, i removed these blocking calls and made them asynchrounus.

Please check with the latest svn checkout if the issue still occurs.



Comment 4 Dario Andres 2009-01-25 18:34:58 UTC
*** Bug 181888 has been marked as a duplicate of this bug. ***
Comment 5 Manuel Stahl 2009-02-01 20:16:35 UTC
Same here with version 1:0.3-0ubuntu0.1:

Anwendung: KBluetooth4 - The KDE4 Bluetooth Framework (kbluetooth4), Signal SIGSEGV

Thread 1 (Thread 0xb61196c0 (LWP 2079)):
[KCrash Handler]
#6  0x09000010 in ?? ()
#7  0xb6c1d156 in QDBusConnectionPrivate::activateCall (this=0x9202678, object=0x9299cc8, flags=273, msg=@0x9199a78) at qdbusintegrator.cpp:711
#8  0xb6c1d9b1 in QDBusConnectionPrivate::activateObject (this=0x9202678, node=@0x9199a64, msg=@0x9199a78, pathStartPos=18) at qdbusintegrator.cpp:1306
#9  0xb6c1deaa in QDBusActivateObjectEvent::placeMetaCall (this=0x9199a38) at qdbusintegrator.cpp:1400
#10 0xb76c2771 in QObject::event (this=0xbfa06b20, e=0x9199a38) at kernel/qobject.cpp:1155
#11 0xb76b27cb in QCoreApplication::event (this=0xbfa06b20, e=0x9199a38) at kernel/qcoreapplication.cpp:1385
#12 0xb6da9206 in QApplication::event (this=0xbfa06b20, e=0x9199a38) at kernel/qapplication.cpp:2187
#13 0xb6da38ec in QApplicationPrivate::notify_helper (this=0x91ab498, receiver=0xbfa06b20, e=0x9199a38) at kernel/qapplication.cpp:3803
#14 0xb6dab72e in QApplication::notify (this=0xbfa06b20, receiver=0xbfa06b20, e=0x9199a38) at kernel/qapplication.cpp:3393
#15 0xb7b9a06d in KApplication::notify (this=0xbfa06b20, receiver=0xbfa06b20, event=0x9199a38) at /build/buildd/kde4libs-4.2.0/kdeui/kernel/kapplication.cpp:307
#16 0xb76b2e61 in QCoreApplication::notifyInternal (this=0xbfa06b20, receiver=0xbfa06b20, event=0x9199a38) at kernel/qcoreapplication.cpp:587
#17 0xb76b3ae5 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x918bf18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:209
#18 0xb76b3cdd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1091
#19 0xb76dd82f in postEventSourceDispatch (s=0x91ad720) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:214
#20 0xb64766f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0xb6479da3 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0xb6479f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0xb76dd478 in QEventDispatcherGlib::processEvents (this=0x91aa6c8, flags={i = -1080010232}) at kernel/qeventdispatcher_glib.cpp:319
#24 0xb6e3dea5 in QGuiEventDispatcherGlib::processEvents (this=0x91aa6c8, flags={i = -1080010184}) at kernel/qguieventdispatcher_glib.cpp:198
#25 0xb76b152a in QEventLoop::processEvents (this=0xbfa05b80, flags={i = -1080010120}) at kernel/qeventloop.cpp:143
#26 0xb76b16ea in QEventLoop::exec (this=0xbfa05b80, flags={i = -1080009824}) at kernel/qeventloop.cpp:194
#27 0xb6c2052b in QDBusConnectionPrivate::sendWithReply (this=0x92af2f8, message=@0xbfa05cf8, sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1692
#28 0xb6c0aa31 in QDBusConnection::call (this=0x91a9d6c, message=@0xbfa05cf8, mode=QDBus::BlockWithGui, timeout=-1) at qdbusconnection.cpp:512
#29 0xb6c29dab in QDBusAbstractInterface::callWithArgumentList (this=0x92d4938, mode=QDBus::BlockWithGui, method=@0xbfa05ea4, args=@0xbfa05dd8) at qdbusabstractinterface.cpp:397
#30 0xb6c2bc5d in QDBusAbstractInterface::call (this=0x92d4938, mode=QDBus::BlockWithGui, method=@0xbfa05ea4, arg1=@0xbfa05e8c, arg2=@0xbfa05e80, arg3=@0xbfa05e74, arg4=@0xbfa05e68, 
    arg5=@0xbfa05e5c, arg6=@0xbfa05e50, arg7=@0xbfa05e44, arg8=@0xbfa05e38) at qdbusabstractinterface.cpp:630
#31 0x08065f83 in _start ()
Comment 6 Tom Patzig 2009-02-02 12:30:39 UTC
(In reply to comment #5)

Does that occur, with the latest svn checkout? I have fixed some blocking dbus calls within there (comment #3) .
Please try that.
Comment 7 Guillermo Belli 2009-02-03 16:33:08 UTC
I this is related: When disconnecting the bluetooth adapter (using the notebook button), KBluetooth4 crashes with signal 11. It happens every time I turn off the BT adapter.

Here's the backtrace, altough it says it is of no use:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f7407de76f0 (LWP 4489)]
0x00007f740418a5f0 in __nanosleep_nocancel () from /lib/libc.so.6
[Current thread is 0 (process 4489)]

Thread 1 (Thread 0x7f7407de76f0 (LWP 4489)):
#0  0x00007f740418a5f0 in __nanosleep_nocancel () from /lib/libc.so.6
#1  0x00007f740418a447 in sleep () from /lib/libc.so.6
#2  0x00007f74073c1cbf in KCrash::startDrKonqi (argv=0x7fff0fe1a868, argc=17) at /build/buildd/kde4libs-4.2.0/kdeui/util/kcrash.cpp:412
#3  0x00007f74073c25ca in KCrash::defaultCrashHandler (sig=11) at /build/buildd/kde4libs-4.2.0/kdeui/util/kcrash.cpp:337
#4  <signal handler called>
#5  0x00007f74058b8cc5 in QObject::property () from /usr/lib/libQtCore.so.4
#6  0x00007f7405bb5d5e in ?? () from /usr/lib/libQtDBus.so.4
#7  0x00007f7405bb6791 in ?? () from /usr/lib/libQtDBus.so.4
#8  0x00007f7405bb6aa8 in ?? () from /usr/lib/libQtDBus.so.4
#9  0x00007f74058b5da5 in QObject::event () from /usr/lib/libQtCore.so.4
#10 0x00007f7404dce34a in QApplication::event () from /usr/lib/libQtGui.so.4
#11 0x00007f7404dc8c3d in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#12 0x00007f7404dd09ba in QApplication::notify () from /usr/lib/libQtGui.so.4
#13 0x00007f740735c5db in KApplication::notify (this=0x7fff0fe1d4c0, receiver=0x7fff0fe1d4c0, event=0x13d4160) at /build/buildd/kde4libs-4.2.0/kdeui/kernel/kapplication.cpp:307
#14 0x00007f74058a6d61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#15 0x00007f74058a79fa in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#16 0x00007f74058cf4d3 in ?? () from /usr/lib/libQtCore.so.4
#17 0x00007f7400fb4d3b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0x00007f7400fb850d in ?? () from /usr/lib/libglib-2.0.so.0
#19 0x00007f7400fb86cb in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#20 0x00007f74058cf15f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#21 0x00007f7404e5aa6f in ?? () from /usr/lib/libQtGui.so.4
#22 0x00007f74058a5682 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#23 0x00007f74058a580d in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#24 0x00007f7405bb8f5d in ?? () from /usr/lib/libQtDBus.so.4
#25 0x00007f7405ba3933 in QDBusConnection::call () from /usr/lib/libQtDBus.so.4
#26 0x00007f7405bc1d5f in QDBusAbstractInterface::callWithArgumentList () from /usr/lib/libQtDBus.so.4
#27 0x00007f7405bc3aac in QDBusAbstractInterface::call () from /usr/lib/libQtDBus.so.4
#28 0x0000000000420e8e in _start ()
#0  0x00007f740418a5f0 in __nanosleep_nocancel () from /lib/libc.so.6
Comment 8 Dario Andres 2009-02-06 22:09:11 UTC
*** Bug 183477 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2009-02-09 23:59:01 UTC
*** Bug 183231 has been marked as a duplicate of this bug. ***
Comment 10 Jonathan Thomas 2009-03-03 20:26:10 UTC
*** Bug 186051 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2009-05-02 17:02:48 UTC
*** Bug 191321 has been marked as a duplicate of this bug. ***
Comment 12 maui.bugzilla@mailnull.com 2009-05-04 06:19:10 UTC
I have similar behavoir here.

My laptop is an Acer Aspire 5520-5378.

When my new Kubuntu 9.10 amd64 starts up, bluetooth is enabled by default (I think this behavoir isn't ok, I would wish to have bluetooth disabled by default)

Once I started KDE session, an icon of bluetooth apears in the system tray.

If I press the laptop's button of the bluetooth device, KBluetooth4 crashes with signal 11 (SIGSEGV) - with useless backtrace.

If I start KBluetooth4 by pressing the laptop button, it seems to be ok (bluetooth icon apears ok)... If I press again the button, icon disappears ok.

But if I press button to start again, and then press button again, the same crash ocurrs.
Comment 13 marcela maslanova 2009-05-06 16:57:08 UTC
We (Fedora) play with automatic switch on/off bluetooth service. KBluetooth4 simply crashed, when the bluetooth is removed. Probably it crashed it can't find the service. There should be only change of icon, which says the service is not available as it is in gnome bluetooth-applet.
Comment 14 marcela maslanova 2009-05-06 16:59:37 UTC
Created attachment 33399 [details]
crash after removing bluetooth device
Comment 15 Dario Andres 2009-06-09 01:24:16 UTC
*** Bug 195655 has been marked as a duplicate of this bug. ***
Comment 16 Guillermo Belli 2009-06-09 02:46:58 UTC
I'm using Kubuntu 9.04 with KDE 4.2.4, the bug is still present. I can append a backtrace if you ask me to.
Comment 17 Guillermo Belli 2009-06-11 21:24:09 UTC
I installed KDE 4.3 Beta2, and the kbluetooth problem seems to be fixed. I can activate and desactivate the bluetooth dapter and kbluetooth does not crash, and works as it should (icon appears when adapter is active, dissapears when adapter is disabled).
Comment 18 Christophe Giboudeaux 2009-06-14 15:54:38 UTC
*** Bug 196354 has been marked as a duplicate of this bug. ***
Comment 19 Dario Andres 2009-06-21 14:44:25 UTC
*** Bug 197371 has been marked as a duplicate of this bug. ***
Comment 20 Dario Andres 2009-07-21 00:48:48 UTC
*** Bug 200849 has been marked as a duplicate of this bug. ***
Comment 21 Dario Andres 2009-08-08 16:12:35 UTC
*** Bug 203044 has been marked as a duplicate of this bug. ***
Comment 22 Nai Xia 2009-08-11 14:25:58 UTC
kde 4.3.0 here, bug still exists.
Comment 23 Dario Andres 2009-09-03 01:23:00 UTC
*** Bug 206057 has been marked as a duplicate of this bug. ***
Comment 24 Alex Fiestas 2009-09-23 20:29:01 UTC
Hi, can you test if this bug is still reproducible in kbluetooth 0.4 version?

Thanks.
Comment 25 Nai Xia 2009-09-24 07:51:09 UTC
Hi
It's seems already fixed in 0.3 of KDE 4.3.1 to me :)

On Thursday 24 September 2009 02:29:10 Alex Fiestas wrote:
> https://bugs.kde.org/show_bug.cgi?id=181268
> 
> 
> Alex Fiestas <alex@eyeos.org> changed:
> 
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
> - CC|                            |alex@eyeos.org
> 
> 
> 
> 
> --- Comment #24 from Alex Fiestas <alex eyeos org>  2009-09-23 20:29:01 ---
> Hi, can you test if this bug is still reproducible in kbluetooth 0.4
>  version?
> 
> Thanks.
> 
__________________________________________________
�Ͽ�ע���Ż�����������������?
http://cn.mail.yahoo.com
Comment 26 Anssi Saari 2009-10-03 18:21:27 UTC
(In reply to comment #25)

> It's seems already fixed in 0.3 of KDE 4.3.1 to me :)

But not for me, have those same versions (I reported this same problem in bug #206057 which was marked as a duplicate of this one). Curiously, I just had things working today, kbluetooth4 0.3 didn't crash no matter how many times I turned bt off and on, but now after a reboot it's back to square one.

I also pulled kdebluetooth4 0.4 from svn and built that. After a little testing, no crashes when turning bt on and off. It does crash when trying to send "text from clipboard" though, but it's a new feature, so... Expected behaviour? Or maybe it needs some other component to be newer? Or maybe I should just report that as a bug.
Comment 27 Alex Fiestas 2009-10-26 12:10:54 UTC
Ok so this bug is fixed, the clipboard is fixed too.

thanks for the report!
Comment 28 Jonathan Thomas 2009-11-10 02:15:36 UTC
*** Bug 213531 has been marked as a duplicate of this bug. ***
Comment 29 Jonathan Thomas 2009-11-16 23:15:20 UTC
*** Bug 214880 has been marked as a duplicate of this bug. ***