Bug 180767 - screen flashes when konqueror loses focus in full screen mode
Summary: screen flashes when konqueror loses focus in full screen mode
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-15 06:30 UTC by Brett Cohen
Modified: 2009-10-14 08:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
focus settings (12.42 KB, image/png)
2009-01-15 06:36 UTC, Brett Cohen
Details
window management settings (32.81 KB, image/png)
2009-01-15 06:36 UTC, Brett Cohen
Details
appearance settings (57.10 KB, image/png)
2009-01-15 06:37 UTC, Brett Cohen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brett Cohen 2009-01-15 06:30:07 UTC
Version:           Version 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1)) (using Devel)
OS:                Linux
Installed from:    Compiled sources

when Konqueror is put into full screen mode (F11) any action that causes the main window to lose focus (clicking on a drop down, activating yakuake etc) will cause the screen to flash (it appears the background of the login screen is the image that is flashed). 
This only happens in full screen mode and only when "enable desktop effects" is active.
Comment 1 Brett Cohen 2009-01-15 06:36:24 UTC
Created attachment 30258 [details]
focus settings
Comment 2 Brett Cohen 2009-01-15 06:36:54 UTC
Created attachment 30259 [details]
window management settings
Comment 3 Brett Cohen 2009-01-15 06:37:21 UTC
Created attachment 30260 [details]
appearance settings
Comment 4 Brett Cohen 2009-01-15 06:41:05 UTC
here is the results of lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and
945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility
X1600]
02:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
02:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE
1394 Host Controller
02:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card
Reader (SD/MMC/MS/MS PRO/xD)
02:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD
Host Controller
02:06.4 Communication controller: Texas Instruments PCIxx12 GemCore based
SmartCard controller
08:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5753M Gigabit
Ethernet PCI Express (rev 21)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan]
Network Connection (rev 02)

kde4-config --version
Qt: 4.4.3
KDE: 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1))
kde4-config: 1.0

4.2 is looking awesome - thanks
Comment 5 Pete Miller 2009-08-07 10:41:23 UTC
In 4.3 this is still a problem. Now however the screen flashes black for a second instead of showing the login screen background image.

This should not be assigned to Konqueror however because I see the same glitch in other full screen applications. I can reproduce the same black flash in both Xine and TVTime when fullscreen is toggled on and off.

I use kosd (http://www.kde-apps.org/content/show.php/KOSD?content=81457) to display volume when using a LIRC remote and I also see this black flash before the kosd display shows up in all of these apps when at fullscreen.
Comment 6 Pete Miller 2009-08-07 10:44:02 UTC
I forgot to mention I use the Nvidia proprietary drivers, in case that makes a difference.
Comment 7 Martin Flöser 2009-10-14 08:23:26 UTC

*** This bug has been marked as a duplicate of bug 177495 ***