Bug 180742 - jpg image dimensions are not given in the Information Panel
Summary: jpg image dimensions are not given in the Information Panel
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-14 23:28 UTC by Nate Herron
Modified: 2010-09-17 14:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Herron 2009-01-14 23:28:35 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

If I select a png file, for example, the Information Panel shows me the dimensions of the image (640x480). But if I select a jpg image the dimensions are not displayed. I therefore need to click on the image file and Gwenview shows the dimensions. I have not tested many image file types, but it makes sense that they all should have their dimensions listed in the Information Panel, but especially jpgs.
Comment 1 Peter Penz 2009-01-16 11:15:10 UTC
I agree. It seems that currently the provided meta data system only reads the dimensions from JPEGs EXIF data...
Comment 2 Peter Penz 2009-02-17 21:37:36 UTC
SVN commit 927542 by ppenz:

* Use Nepomuk for getting the meta data instead of KFileMetaInfo.
* Use a QScrollArea widget to embedd the meta data, as Nepomuk provides so much meta information that it might not fit into the panel.

Open issues:
* Add the possibility to configure which kind of meta information should be shown.
* Check whether the receiving of the meta data for one file also might block the UI like when using KFileMetaInfo in combination with strigi.

CCMAIL: sebastian@trueg.de
BUG: 180742
BUG: 181592

 M  +46 -67    informationpanel.cpp  
 M  +6 -7      informationpanel.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=927542
Comment 3 Todd 2010-09-17 07:00:56 UTC
I still have this problem in KDE 4.5.1.  Gif and png show dimension, jpeg does not.
Comment 4 Peter Penz 2010-09-17 14:56:49 UTC
@Todd: The root cause for this is in the corresponding metadata-decoder provided by strigi. It worked in 4.5.1 for JPEGs that contain no EXIF-information or an EXIF-information with valid width/height, but did not work for JPEGs that have EXIF but no width/height in it. I created a patch for this in kdesupport and I think this should be available in 4.5.2 (kdesupport has no explicit 4.5.x tags, so I'm not 100 % sure).