Bug 180538 - ark should not archive symlinks as real files
Summary: ark should not archive symlinks as real files
Status: RESOLVED FIXED
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
: 214354 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-13 10:55 UTC by vatbier
Modified: 2010-10-16 08:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vatbier 2009-01-13 10:55:10 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Mandriva RPMs

Ark Version 2.11.999

Trying to archive my /etc with "kdesu ark" :
Result is a big .tar.gz of 33 MB whereas with Ark of KDE 3.5.10 it was only 13 MB.
When I look in .tar.gz file I see that /etc/alternatives/ is full with real files and not with empty symlinks.

I had to use Gnome Archive Manager to be able to get a .tar.gz file of only 13 MB.

Symlinks should not be archived as real files!
Comment 1 vatbier 2009-05-30 14:35:23 UTC
Ark Version 2.12
Using KDE 4.2.2

Same behaviour.

Ark needs an option like Gnome Archive Manager has: "Exclude folders that are symbolic links".

Please fix this.
Comment 2 S. Christian Collins 2009-06-08 01:04:32 UTC
...or at least have the option to include symbolic links as they are.
Comment 3 Raphael Kubo da Costa 2009-11-13 14:25:16 UTC
*** Bug 214354 has been marked as a duplicate of this bug. ***
Comment 4 vatbier 2010-07-10 17:19:52 UTC
Ark Version 2.13
Using KDE 4.3.5

Still the same problem!

Come on, KDE developers, please fix it.
Comment 5 Raphael Kubo da Costa 2010-10-16 08:16:10 UTC
I think I've just fixed this with revisions 1186375 (trunk) and 1186377 (4.5 branch) -- see bug 253059 for more details.

KDE SC 4.5.3 should contain the fix.