Bug 180082 - Random kate crashes under different situations [KateCodeFoldingNode::getEnd , KateIconBorder::showBlock, KateIconBorder::mouseMoveEvent]
Summary: Random kate crashes under different situations [KateCodeFoldingNode::getEnd ,...
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: folding (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 196123 198261 208312 209553 209816 209892 215424 218015 220017 227208 235394 245443 256915 257929 264654 266024 280603 284273 287465 294403 301475 303626 307952 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-09 00:24 UTC by EmmanuelS
Modified: 2012-10-06 02:20 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description EmmanuelS 2009-01-09 00:24:55 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Hello:)

Using Neon KDE-NIGHTLY packages (20090106+svn906850) I encountered a kate crash.

First time Crash. Situation was :
- working on highlighted PHP file
- no code-folding was activated
- just came from another application by alt+tabing, at same time I was moving the mouse to select some content in Kate
- pressed the delete key to remove a few words

Then <Crash>

I can't really reproduce this problem because the action steps are quite simple and would usually always work.
I guess only the speed of doing it and the rather busy state harddrive I/O of my computer did matter.

Backtrace:
Application: Kate (kate), signal SIGSEGV

Thread 1 (Thread 0xb5f849a0 (LWP 8342)):
[KCrash Handler]
#6  KateCodeFoldingNode::getEnd (this=0x9ff8f50, tree=0xa059534, end=0xbfd82854) at /build/buildd/kde-nightly-kdelibs-20090106+svn906850/kate/syntax/katecodefolding.cpp:86
#7  0xb479abbe in KateIconBorder::showBlock (this=0xa01e7a8, line=4) at /build/buildd/kde-nightly-kdelibs-20090106+svn906850/kate/view/kateviewhelpers.cpp:1312
#8  0xb479be3a in KateIconBorder::mouseMoveEvent (this=0xa01e7a8, e=0xbfd82e38) at /build/buildd/kde-nightly-kdelibs-20090106+svn906850/kate/view/kateviewhelpers.cpp:1365
#9  0xb7298ee0 in QWidget::event () from /opt/project-neon/lib/libQtGui.so.4
#10 0xb72406fc in QApplicationPrivate::notify_helper () from /opt/project-neon/lib/libQtGui.so.4
#11 0xb7248437 in QApplication::notify () from /opt/project-neon/lib/libQtGui.so.4
#12 0xb7be9183 in KApplication::notify (this=0xbfd838e0, receiver=0xa01e7a8, event=0xbfd82e38) at /build/buildd/kde-nightly-kdelibs-20090106+svn906850/kdeui/kernel/kapplication.cpp:307
#13 0xb6e15591 in QCoreApplication::notifyInternal () from /opt/project-neon/lib/libQtCore.so.4
#14 0xb724767a in QApplicationPrivate::sendMouseEvent () from /opt/project-neon/lib/libQtGui.so.4
#15 0xb72adfe0 in ?? () from /opt/project-neon/lib/libQtGui.so.4
#16 0xb72ad01b in QApplication::x11ProcessEvent () from /opt/project-neon/lib/libQtGui.so.4
#17 0xb72d4bda in ?? () from /opt/project-neon/lib/libQtGui.so.4
#18 0xb625d6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0xb6260da3 in ?? () from /usr/lib/libglib-2.0.so.0
#20 0xb6260f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#21 0xb6e3eea8 in QEventDispatcherGlib::processEvents () from /opt/project-neon/lib/libQtCore.so.4
#22 0xb72d42e5 in ?? () from /opt/project-neon/lib/libQtGui.so.4
#23 0xb6e13f9a in QEventLoop::processEvents () from /opt/project-neon/lib/libQtCore.so.4
#24 0xb6e1415a in QEventLoop::exec () from /opt/project-neon/lib/libQtCore.so.4
#25 0xb6e191fd in QCoreApplication::exec () from /opt/project-neon/lib/libQtCore.so.4
#26 0xb7240427 in QApplication::exec () from /opt/project-neon/lib/libQtGui.so.4
#27 0xb8060f6d in kdemain (argc=1, argv=0xbfd83e64) at /build/buildd/kde-nightly-kdesdk-20090106+svn906854/kate/app/katemain.cpp:250
#28 0x08048702 in main (argc=195984, argv=0xb6a1a598) at /build/buildd/kde-nightly-kdesdk-20090106+svn906854/obj-i486-linux-gnu/kate/app/kate_dummy.cpp:3
Comment 1 Dominik Haumann 2009-06-04 20:15:00 UTC
maybe related: bug #192961, bug #192961.
A reliable way to reproduce would be appreciated.
Comment 2 Christophe Giboudeaux 2009-06-12 12:35:43 UTC
*** Bug 196123 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Cullmann 2009-07-08 12:48:38 UTC
*** Bug 198261 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2009-09-25 02:32:23 UTC
*** Bug 208312 has been marked as a duplicate of this bug. ***
Comment 5 Milian Wolff 2009-10-06 01:59:03 UTC
*** Bug 209553 has been marked as a duplicate of this bug. ***
Comment 6 Milian Wolff 2009-10-08 22:01:16 UTC
*** Bug 209892 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-10-09 01:06:18 UTC
*** Bug 209816 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-11-21 14:50:08 UTC
Updated backtrace from bug 215424:
---
#6  KateCodeFoldingNode::getEnd (this=0x85e5070, tree=0x8388804,
end=0xbfe5bca8) at ../../kate/syntax/katecodefolding.cpp:86
#7  0x01e90a7c in KateIconBorder::showBlock (this=0x84a93e0, line=1) at
../../kate/view/kateviewhelpers.cpp:1275
#8  0x01e9129a in KateIconBorder::mouseMoveEvent (this=0x84a93e0, e=0xbfe5c2e0)
at ../../kate/view/kateviewhelpers.cpp:1328
Comment 9 Dario Andres 2009-11-21 14:50:10 UTC
*** Bug 215424 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2009-12-10 18:07:09 UTC
*** Bug 218015 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2009-12-25 21:27:24 UTC
From bug 220017:
---
What I was doing when the application crashed:
I was working in Kile, typing text (no special characters) and/or moving the
mouse, and it suddenly crashes...

It was at 01:30 so it might be related to autosave (which is configured to
trigger every 30 mins).
Comment 12 Dario Andres 2009-12-25 21:27:27 UTC
*** Bug 220017 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2010-02-16 22:44:24 UTC
From bug 227208:
---
What I was doing when the application crashed:
Kate crashed when I was playing with mouse selection:
I clicked with the left button and was moving the mouse when it crashed.
Comment 14 Dario Andres 2010-02-16 22:44:28 UTC
*** Bug 227208 has been marked as a duplicate of this bug. ***
Comment 15 Dominik Haumann 2010-05-09 08:40:36 UTC
*** Bug 235394 has been marked as a duplicate of this bug. ***
Comment 16 Dario Andres 2010-11-27 23:08:39 UTC
[Comment from a bug triager]
From bug 245443:
I searched a .CPP document for a token, and KWrite crashes when I pressed
"Continue searching"

From bug 256915:
I marked a bookmark, then scrolled all the way to the beginning of the document
and then went to the bookmark I previously marked with the Bookmarks menu. Kate
crashed right after that.

I don't know what could have caused this. I had firefox opened, two nautilus
windows, and a terminal window. The document was a java source file with more
than 1000 lines of code. There were few bookmarks (no more than 8).

From bug 257929:
-- Information about the crash:
I just was coding a script in php 5 when Kate crashed and those two times.

Updated backtrace from bug 245443 (KDE SC 4.4.4):
[KCrash Handler]
#5  KateCodeFoldingNode::getEnd (this=0x1e0ee20, tree=0x190dd90,
end=0x7fff5d883dc0) at ../../kate/syntax/katecodefolding.cpp:86
#6  0x00007fc4f883fe15 in KateIconBorder::showBlock (this=0x1927230) at
../../kate/view/kateviewhelpers.cpp:1318
#7  0x00007fc4f8840434 in KateIconBorder::qt_metacall (this=0x1927230,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5d883fe0)
at ./kateviewhelpers.moc:160
...
Comment 17 Dario Andres 2010-11-27 23:09:10 UTC
*** Bug 245443 has been marked as a duplicate of this bug. ***
Comment 18 Dario Andres 2010-11-27 23:09:13 UTC
*** Bug 256915 has been marked as a duplicate of this bug. ***
Comment 19 Dario Andres 2010-11-27 23:09:15 UTC
*** Bug 257929 has been marked as a duplicate of this bug. ***
Comment 20 Dario Andres 2011-01-29 13:50:25 UTC
[Comment from a bug triager]
From bug 264654:
I had a some .phtml files open (Magentos html/php files)
Then I surfed some in Opera and then KATE crashed.
I wasn't currently editing any files.
KATE has been up and running all day, and I never noticed any problem.
Comment 21 Dario Andres 2011-01-29 13:50:32 UTC
*** Bug 264654 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Cullmann 2011-06-05 17:21:20 UTC
Sorry, without an updated backtrace for some KDE >= 4.6 we can't do a lot here :/ Code changed a lot since then. Beside I hope current Kate codecompletion GSoC will rewrite that parts
Comment 23 Dominik Haumann 2011-06-25 16:13:29 UTC
*** Bug 266024 has been marked as a duplicate of this bug. ***
Comment 24 Dominik Haumann 2011-09-20 21:20:39 UTC
*** Bug 280603 has been marked as a duplicate of this bug. ***
Comment 25 Milian Wolff 2011-10-19 11:10:54 UTC
*** Bug 284273 has been marked as a duplicate of this bug. ***
Comment 26 Milian Wolff 2011-10-19 11:11:33 UTC
from bug 284273 that confirms this bug with kde 4.7.1:

Application: kdevelop (4.2.3)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I was checking a php page for a view and i wanted to fold a fragment of code
inside a class, but it wanted to fold all the class, so i looked inside where
was an error, and 2 or 3 hierarchy down. it crahsed.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fea1649c780 (LWP 2382))]

jump to:prev threadnext threadcrash
Thread 14 (Thread 0x7fe9fd84e700 (LWP 2383)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00007fea1499111e in wait (time=1000, this=0x1d7f4f0) at
thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1d541c0, time=1000) at
thread/qwaitcondition_unix.cpp:160
#3  0x00007fea10d5bc7b in ?? () from /usr/lib/libkdevplatformlanguage.so.3
#4  0x00007fea14990d05 in QThreadPrivate::start (arg=0x1d541a0) at
thread/qthread_unix.cpp:331
#5  0x00007fea129e6efc in start_thread (arg=0x7fe9fd84e700) at
pthread_create.c:304
#6  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 13 (Thread 0x7fe9f3b56700 (LWP 2385)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0x25ff040) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xba6ce0,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x25ff150,
th=0x25f0640) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25f0640) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25f0640) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25f0640) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25f0640) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25f0640) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe9f3b55e20, parent=0x25ff150, th=0x25f0640) at
../../../threadweaver/Weaver/Thread.cpp:87
#10 0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x25f0640) at
../../../threadweaver/Weaver/Thread.cpp:142
#11 0x00007fea14990d05 in QThreadPrivate::start (arg=0x25f0640) at
thread/qthread_unix.cpp:331
#12 0x00007fea129e6efc in start_thread (arg=0x7fe9f3b56700) at
pthread_create.c:304
#13 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 12 (Thread 0x7fe9f3355700 (LWP 2387)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0x25ff040) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xba6ce0,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x25ff150,
th=0x25fb3d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25fb3d0) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25fb3d0) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x25fb3d0) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe9f3354e20, parent=0x25ff150, th=0x25fb3d0) at
../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x25fb3d0) at
../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007fea14990d05 in QThreadPrivate::start (arg=0x25fb3d0) at
thread/qthread_unix.cpp:331
#10 0x00007fea129e6efc in start_thread (arg=0x7fe9f3355700) at
pthread_create.c:304
#11 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 11 (Thread 0x7fe9ed889700 (LWP 2390)):
#0  0x00007fea1210107b in __GI_clock_gettime (clock_id=1, tp=0x7fe9ed888b70) at
../sysdeps/unix/clock_gettime.c:100
#1  0x00007fea149e1074 in do_gettime (frac=0x7fe9ed888b88, sec=0x7fe9ed888b80)
at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00007fea14aa36ed in QTimerInfoList::updateCurrentTime (this=0x2708370) at
kernel/qeventdispatcher_unix.cpp:339
#4  0x00007fea14aa3a33 in QTimerInfoList::timerWait (this=0x2708370, tm=...) at
kernel/qeventdispatcher_unix.cpp:442
#5  0x00007fea14aa244c in timerSourcePrepareHelper (src=<optimized out>,
timeout=0x7fe9ed888c6c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007fea14aa24f5 in timerSourcePrepare (source=<optimized out>,
timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007fea0e5f3ff2 in g_main_context_prepare () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fea0e5f4dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fea0e5f5429 in g_main_context_iteration () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fea14aa2f3e in QEventDispatcherGlib::processEvents (this=0x26c5530,
flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00007fea14a76cf2 in QEventLoop::processEvents (this=<optimized out>,
flags=...) at kernel/qeventloop.cpp:149
#12 0x00007fea14a76ef7 in QEventLoop::exec (this=0x7fe9ed888e00, flags=...) at
kernel/qeventloop.cpp:201
#13 0x00007fea1498e27f in QThread::exec (this=<optimized out>) at
thread/qthread.cpp:498
#14 0x00007fea14990d05 in QThreadPrivate::start (arg=0x26ee160) at
thread/qthread_unix.cpp:331
#15 0x00007fea129e6efc in start_thread (arg=0x7fe9ed889700) at
pthread_create.c:304
#16 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 10 (Thread 0x7fe9e8d97700 (LWP 2391)):
#0  0x00007fea0e5f4393 in g_main_context_query () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fea0e5f4e6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fea0e5f5429 in g_main_context_iteration () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fea14aa2f3e in QEventDispatcherGlib::processEvents (this=0x294d860,
flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fea14a76cf2 in QEventLoop::processEvents (this=<optimized out>,
flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fea14a76ef7 in QEventLoop::exec (this=0x7fe9e8d96dd0, flags=...) at
kernel/qeventloop.cpp:201
#6  0x00007fea1498e27f in QThread::exec (this=<optimized out>) at
thread/qthread.cpp:498
#7  0x00007fea14a59cbf in QInotifyFileSystemWatcherEngine::run (this=0x284fea0)
at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fea14990d05 in QThreadPrivate::start (arg=0x284fea0) at
thread/qthread_unix.cpp:331
#9  0x00007fea129e6efc in start_thread (arg=0x7fe9e8d97700) at
pthread_create.c:304
#10 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 9 (Thread 0x7fe9e8544700 (LWP 2392)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe9fe5fbfe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fe9fe5fc019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fea129e6efc in start_thread (arg=0x7fe9e8544700) at
pthread_create.c:304
#4  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 8 (Thread 0x7fe9e6f71700 (LWP 2405)):
#0  0x00007fea1365b773 in __GI___poll (fds=<optimized out>, nfds=<optimized
out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fea0e5f4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fea0e5f5429 in g_main_context_iteration () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fea14aa2f3e in QEventDispatcherGlib::processEvents (this=0x3291500,
flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fea14a76cf2 in QEventLoop::processEvents (this=<optimized out>,
flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fea14a76ef7 in QEventLoop::exec (this=0x7fe9e6f70dd0, flags=...) at
kernel/qeventloop.cpp:201
#6  0x00007fea1498e27f in QThread::exec (this=<optimized out>) at
thread/qthread.cpp:498
#7  0x00007fea14a59cbf in QInotifyFileSystemWatcherEngine::run (this=0x3291660)
at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fea14990d05 in QThreadPrivate::start (arg=0x3291660) at
thread/qthread_unix.cpp:331
#9  0x00007fea129e6efc in start_thread (arg=0x7fe9e6f71700) at
pthread_create.c:304
#10 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 7 (Thread 0x7fe9e64d3700 (LWP 2455)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0xe5d6b0) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xd82820,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xc38220,
th=0x3282ee0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xdf2030, th=0x3282ee0) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe9e64d2e20, parent=0xc38220, th=0x3282ee0) at
../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x3282ee0) at
../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fea14990d05 in QThreadPrivate::start (arg=0x3282ee0) at
thread/qthread_unix.cpp:331
#8  0x00007fea129e6efc in start_thread (arg=0x7fe9e64d3700) at
pthread_create.c:304
#9  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 6 (Thread 0x7fe9e5cd2700 (LWP 2456)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0xe5d6b0) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xd82820,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xc38220,
th=0x3429440) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xdf2030, th=0x3429440) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xdf2030, th=0x3429440) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xdf2030, th=0x3429440) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe9e5cd1e20, parent=0xc38220, th=0x3429440) at
../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x3429440) at
../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007fea14990d05 in QThreadPrivate::start (arg=0x3429440) at
thread/qthread_unix.cpp:331
#10 0x00007fea129e6efc in start_thread (arg=0x7fe9e5cd2700) at
pthread_create.c:304
#11 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 5 (Thread 0x7fe9e533d700 (LWP 2457)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea0b74ac2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fea0b74ad59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fea129e6efc in start_thread (arg=0x7fe9e533d700) at
pthread_create.c:304
#4  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 4 (Thread 0x7fe9e4a3c700 (LWP 2458)):
#0  0x00007fea1365b773 in __GI___poll (fds=<optimized out>, nfds=<optimized
out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fea0e5f4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fea0e5f5429 in g_main_context_iteration () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fea14aa2f3e in QEventDispatcherGlib::processEvents (this=0x2845e20,
flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fea14a76cf2 in QEventLoop::processEvents (this=<optimized out>,
flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fea14a76ef7 in QEventLoop::exec (this=0x7fe9e4a3be00, flags=...) at
kernel/qeventloop.cpp:201
#6  0x00007fea1498e27f in QThread::exec (this=<optimized out>) at
thread/qthread.cpp:498
#7  0x00007fea14990d05 in QThreadPrivate::start (arg=0x284d1f0) at
thread/qthread_unix.cpp:331
#8  0x00007fea129e6efc in start_thread (arg=0x7fe9e4a3c700) at
pthread_create.c:304
#9  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 3 (Thread 0x7fe99e4fe700 (LWP 8804)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0x25ff040) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xba6ce0,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x25ff150,
th=0x2c2fa60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x2c2fa60) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x2c2fa60) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x2c2fa60) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fea0c130e24 in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x2c2fa60) at
../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe99e4fde20, parent=0x25ff150, th=0x2c2fa60) at
../../../threadweaver/Weaver/Thread.cpp:87
#9  0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x2c2fa60) at
../../../threadweaver/Weaver/Thread.cpp:142
#10 0x00007fea14990d05 in QThreadPrivate::start (arg=0x2c2fa60) at
thread/qthread_unix.cpp:331
#11 0x00007fea129e6efc in start_thread (arg=0x7fe99e4fe700) at
pthread_create.c:304
#12 0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 2 (Thread 0x7fe99dcfd700 (LWP 8805)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at
../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea149911ab in wait (time=18446744073709551615, this=0x25ff040) at
thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xba6ce0,
time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0c12e864 in
ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x25ff150,
th=0x3370d10) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fea0c130e0b in ThreadWeaver::WorkingHardState::applyForWork
(this=0xb5da30, th=0x3370d10) at
../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fea0c12fccf in ThreadWeaver::ThreadRunHelper::run
(this=0x7fe99dcfce20, parent=0x25ff150, th=0x3370d10) at
../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fea0c12fd5b in ThreadWeaver::Thread::run (this=0x3370d10) at
../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fea14990d05 in QThreadPrivate::start (arg=0x3370d10) at
thread/qthread_unix.cpp:331
#8  0x00007fea129e6efc in start_thread (arg=0x7fe99dcfd700) at
pthread_create.c:304
#9  0x00007fea1366789d in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

jump to:prev threadnext threadcrash
Thread 1 (Thread 0x7fea1649c780 (LWP 2382)):
[KCrash Handler]
#6  KateCodeFoldingNode::getEnd (this=0x41af400, tree=0x4135940,
end=0x7fffe2a200c0) at ../../part/syntax/katecodefolding.cpp:87
#7  0x00007fe9fea8926b in KateIconBorder::showBlock (this=0x2c3cbd0) at
../../part/view/kateviewhelpers.cpp:1318
#8  0x00007fe9fea8b67c in KateIconBorder::mouseMoveEvent (this=0x2c3cbd0,
e=0x7fffe2a20a30) at ../../part/view/kateviewhelpers.cpp:1380
#9  0x00007fea13e78cce in QWidget::event (this=0x2c3cbd0, event=0x7fffe2a20a30)
at kernel/qwidget.cpp:8280
#10 0x00007fea13e28424 in notify_helper (e=0x7fffe2a20a30, receiver=0x2c3cbd0,
this=0x9c8a80) at kernel/qapplication.cpp:4486
#11 QApplicationPrivate::notify_helper (this=0x9c8a80, receiver=0x2c3cbd0,
e=0x7fffe2a20a30) at kernel/qapplication.cpp:4458
#12 0x00007fea13e2dc6b in QApplication::notify (this=<optimized out>,
receiver=0x2c3cbd0, e=0x7fffe2a20a30) at kernel/qapplication.cpp:4047
#13 0x00007fea152561e6 in KApplication::notify (this=0x7fffe2a21840,
receiver=0x2c3cbd0, event=0x7fffe2a20a30) at
../../kdeui/kernel/kapplication.cpp:311
#14 0x000000000040a896 in _start ()

Reported using DrKonqi
Comment 27 Dominik Haumann 2011-10-19 18:41:29 UTC
I thought it's fixed for KDE 4.8?
Comment 28 Dominik Haumann 2011-12-10 13:16:36 UTC
*** Bug 287465 has been marked as a duplicate of this bug. ***
Comment 29 Dominik Haumann 2012-02-19 08:30:28 UTC
*** Bug 294403 has been marked as a duplicate of this bug. ***
Comment 30 Dominik Haumann 2012-02-19 08:31:50 UTC
As code folding changed quite a lot in KDE 4.8, we assume this is fixed.

However, if anyone sees this bug in KDE >= 4.8 again, please reopen.
Comment 31 Dominik Haumann 2012-06-24 09:39:30 UTC
*** Bug 301475 has been marked as a duplicate of this bug. ***
Comment 32 Dominik Haumann 2012-07-16 19:52:37 UTC
*** Bug 303626 has been marked as a duplicate of this bug. ***
Comment 33 Jekyll Wu 2012-10-06 02:20:00 UTC
*** Bug 307952 has been marked as a duplicate of this bug. ***