Bug 179845 - konsole crash on closing
Summary: konsole crash on closing
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 181046 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-06 21:44 UTC by Giovanni Venturi
Modified: 2009-01-17 12:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Venturi 2009-01-06 21:44:11 UTC
Version:           2.2 (using 4.1.87 (KDE 4.1.87 (KDE 4.2 >= 20090101)), compiled sources)
Compiler:          gcc
OS:                Linux (i686) release 2.6.28-desktop

Application: Konsole (konsole), signal SIGSEGV
0xb64ba43c in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 2840)]

Thread 2 (Thread 0xb48bab90 (LWP 2841)):
#0  0xb64f2957 in select () from /lib/libc.so.6
#1  0xb7394ec8 in QProcessManager::run (this=0x8094dd8) at io/qprocess_unix.cpp:300
#2  0xb726e5f5 in QThreadPrivate::start (arg=0x8094dd8) at thread/qthread_unix.cpp:184
#3  0xb71e8369 in start_thread () from /lib/libpthread.so.0
#4  0xb64f9cfe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5f106d0 (LWP 2840)):
[KCrash Handler]
#5  0xb7484123 in QListData::shared_null () from /opt/qt4-dev/lib/libQtCore.so.4
#6  0xb6e43010 in QStackedWidget::indexOf (this=0x814af28, widget=0x8247a68) at widgets/qstackedwidget.cpp:254
#7  0xb7ff1d15 in Konsole::TabbedViewContainer::removeViewWidget (this=0x814a6b0, view=0x8247a68) at /home/devel/kde4/KDE/kdebase/apps/konsole/src/ViewContainer.cpp:698
#8  0xb7ff1293 in Konsole::ViewContainer::viewDestroyed (this=0x814a6b0, object=0x8247a68) at /home/devel/kde4/KDE/kdebase/apps/konsole/src/ViewContainer.cpp:166
#9  0xb7ff144c in Konsole::ViewContainer::qt_metacall (this=0x814a6b0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbf94a820)
    at /home/devel/kde4/KDE/kdebase/build/apps/konsole/src/ViewContainer.moc:97
#10 0xb7ff3812 in Konsole::TabbedViewContainer::qt_metacall (this=0x814a6b0, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbf94a820)
    at /home/devel/kde4/KDE/kdebase/build/apps/konsole/src/ViewContainer.moc:265
#11 0xb73d743b in QMetaObject::activate (sender=0x8247a68, from_signal_index=<value optimized out>, to_signal_index=1, argv=0x8247a68) at kernel/qobject.cpp:3052
#12 0xb73d78fb in QMetaObject::activate (sender=0x8247a68, m=0xb747d9c8, from_local_signal_index=0, to_local_signal_index=1, argv=0xbf94a820) at kernel/qobject.cpp:3147
#13 0xb73d798d in QObject::destroyed (this=0x8247a68, _t1=0x8247a68) at .moc/debug-shared/moc_qobject.cpp:143
#14 0xb73dbd7d in ~QObject (this=0x8247a68) at kernel/qobject.cpp:765
#15 0xb695a041 in ~QWidget (this=0x8247a68) at kernel/qwidget.cpp:1319
#16 0xb7feaeee in ~TerminalDisplay (this=0x8247a68) at /home/devel/kde4/KDE/kdebase/apps/konsole/src/TerminalDisplay.cpp:387
#17 0xb73d6081 in QObjectPrivate::deleteChildren (this=0x8176d48) at kernel/qobject.cpp:1840
#18 0xb695a14d in ~QWidget (this=0x814af28) at kernel/qwidget.cpp:1306
#19 0xb6dc968f in ~QFrame (this=0x814af28) at widgets/qframe.cpp:238
#20 0xb6e42c15 in ~QStackedWidget (this=0x814af28) at widgets/qstackedwidget.cpp:147
#21 0xb73d6081 in QObjectPrivate::deleteChildren (this=0x814b9c0) at kernel/qobject.cpp:1840
#22 0xb695c0f8 in ~QWidget (this=0x815e110) at kernel/qwidget.cpp:1306
#23 0xb73d6081 in QObjectPrivate::deleteChildren (this=0x8122de0) at kernel/qobject.cpp:1840
#24 0xb695a14d in ~QWidget (this=0x8122b60) at kernel/qwidget.cpp:1306
#25 0xb6dc968f in ~QFrame (this=0x8122b60) at widgets/qframe.cpp:238
#26 0xb6e3c8a5 in ~QSplitter (this=0x8122b60) at widgets/qsplitter.cpp:1003
#27 0xb7fff00d in ~ViewSplitter (this=0x8122b60) at /home/devel/kde4/KDE/kdebase/apps/konsole/src/ViewSplitter.h:48
#28 0xb73d6081 in QObjectPrivate::deleteChildren (this=0x8142178) at kernel/qobject.cpp:1840
#29 0xb695c0f8 in ~QWidget (this=0x813cef8) at kernel/qwidget.cpp:1306
#30 0xb73d6081 in QObjectPrivate::deleteChildren (this=0x80f5b38) at kernel/qobject.cpp:1840
#31 0xb695a14d in ~QWidget (this=0x80d21f8) at kernel/qwidget.cpp:1306
#32 0xb6de5dbf in ~QMainWindow (this=0x80d21f8) at widgets/qmainwindow.cpp:323
#33 0xb7a3158e in ~KMainWindow (this=0x80d21f8) at /home/devel/kde4/KDE/kdelibs/kdeui/widgets/kmainwindow.cpp:462
#34 0xb7a75e39 in ~KXmlGuiWindow (this=0x80d21f8, __vtt_parm=0xb80299b4) at /home/devel/kde4/KDE/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:127
#35 0xb800ae74 in ~MainWindow (this=0x80d21f8) at /home/devel/kde4/KDE/kdebase/apps/konsole/src/MainWindow.h:56
#36 0xb73d02b3 in qDeleteInEventHandler (o=0x8149720) at kernel/qobject.cpp:3737
#37 0xb73d1c8a in QObject::event (this=0x80d21f8, e=0x84b0840) at kernel/qobject.cpp:1088
#38 0xb6968aaf in QWidget::event (this=0x80d21f8, event=0x84b0840) at kernel/qwidget.cpp:7790
#39 0xb6de8702 in QMainWindow::event (this=0x80d21f8, event=0x84b0840) at widgets/qmainwindow.cpp:1381
#40 0xb7a2f5d5 in KMainWindow::event (this=0x80d21f8, ev=0x84b0840) at /home/devel/kde4/KDE/kdelibs/kdeui/widgets/kmainwindow.cpp:1081
#41 0xb7a76312 in KXmlGuiWindow::event (this=0x80d21f8, ev=0x84b0840) at /home/devel/kde4/KDE/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:131
#42 0xb6905e21 in QApplicationPrivate::notify_helper (this=0x8091dc0, receiver=0x80d21f8, e=0x84b0840) at kernel/qapplication.cpp:3967
#43 0xb6906c9c in QApplication::notify (this=0xbf94b604, receiver=0x80d21f8, e=0x84b0840) at kernel/qapplication.cpp:3932
#44 0xb7931cd1 in KApplication::notify (this=0xbf94b604, receiver=0x80d21f8, event=0x84b0840) at /home/devel/kde4/KDE/kdelibs/kdeui/kernel/kapplication.cpp:307
#45 0xb73bd89d in QCoreApplication::notifyInternal (this=0xbf94b604, receiver=0x80d21f8, event=0x84b0840) at kernel/qcoreapplication.cpp:584
#46 0xb73bf0e5 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x804b440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:208
#47 0xb73bf38c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1116
#48 0xb73f12ad in postEventSourceDispatch (s=0x8093f18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#49 0xb61f0146 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0xb61f34f3 in ?? () from /usr/lib/libglib-2.0.so.0
#51 0x08093e90 in ?? ()
#52 0x00000000 in ?? ()
Comment 1 Dario Andres 2009-01-07 00:53:24 UTC
What QT version are you using?
Comment 2 Giovanni Venturi 2009-01-07 19:33:27 UTC
4.5 beta1
Comment 3 Dario Andres 2009-01-07 19:36:44 UTC
So, it may be probably a duplicate of bug 170052
Comment 4 Alexis MENARD 2009-01-07 20:28:09 UTC
Fixed with commit 907272, the bug was in Konsole.
Comment 5 Dario Andres 2009-01-17 12:46:23 UTC
*** Bug 181046 has been marked as a duplicate of this bug. ***