Bug 179617 - kompare crash while applying differences after unapplying.
Summary: kompare crash while applying differences after unapplying.
Status: RESOLVED DUPLICATE of bug 169692
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-04 15:00 UTC by FiNeX
Modified: 2009-01-04 17:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FiNeX 2009-01-04 15:00:36 UTC
Steps to reproduce the crash (reproducible on current trunk, r902024)

1) start kompare with two files
2) click on "apply differences"
3) click on "unapply differences"
4) click again on "apply differences"

This will make kompare crash with the following backtrace:

Application: Kompare (kompare), signal SIGSEGV
0x00007fd93fed8001 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 31566)]

Thread 2 (Thread 0x7fd934cc5950 (LWP 31581)):
#0  0x00007fd93ff01d02 in select () from /lib/libc.so.6
#1  0x00007fd940c60ee6 in ?? () from /usr/lib/libQtCore.so.4
#2  0x00007fd940baad79 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fd940939fc7 in start_thread () from /lib/libpthread.so.0
#4  0x00007fd93ff085dd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd944627750 (LWP 31566)):
[KCrash Handler]
#5  Diff2::KompareModelList::slotActionApplyDifference (this=0x1292770) at /home/test/KDE4/src/kdesdk/kompare/libdiff2/komparemodellist.cpp:1425
#6  0x00007fd94412f4bd in Diff2::KompareModelList::qt_metacall (this=0x1292770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4c765a50)
    at /home/test/KDE4/src/build/kdesdk/kompare/libdiff2/komparemodellist.moc:146
#7  0x00007fd940c8dd00 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#8  0x00007fd9417b1367 in QAction::triggered () from /usr/lib/libQtGui.so.4
#9  0x00007fd9417b1b24 in QAction::activate () from /usr/lib/libQtGui.so.4
#10 0x00007fd941a7cc0a in ?? () from /usr/lib/libQtGui.so.4
#11 0x00007fd941a7ce85 in QAbstractButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#12 0x00007fd941b327ba in QToolButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#13 0x00007fd94180359c in QWidget::event () from /usr/lib/libQtGui.so.4
#14 0x00007fd9417b64dd in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#15 0x00007fd9417bd0ee in QApplication::notify () from /usr/lib/libQtGui.so.4
#16 0x00007fd9424bb55b in KApplication::notify (this=0x7fff4c767190, receiver=0x12f4e00, event=0x7fff4c766380) at /home/test/KDE4/src/kdelibs/kdeui/kernel/kapplication.cpp:307
#17 0x00007fd940c7c3d1 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#18 0x00007fd9417be498 in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#19 0x00007fd941814b1c in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007fd941813c99 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#21 0x00007fd941837744 in ?? () from /usr/lib/libQtGui.so.4
#22 0x00007fd93c760aa2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007fd93c76421d in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#24 0x00007fd93c7643db in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007fd940ca089f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#26 0x00007fd941836fff in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007fd940c7ad42 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#28 0x00007fd940c7aed5 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#29 0x00007fd940c7d025 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#30 0x000000000040a795 in main (argc=4, argv=0x7fff4c767aa8) at /home/test/KDE4/src/kdesdk/kompare/main.cpp:233
Comment 1 FiNeX 2009-01-04 17:09:39 UTC

*** This bug has been marked as a duplicate of bug 169692 ***