Bug 179487 - ktorrent crashed and caused the signal 11 SIGSEGV
Summary: ktorrent crashed and caused the signal 11 SIGSEGV
Status: RESOLVED DUPLICATE of bug 172198
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-03 13:02 UTC by tsi pura
Modified: 2009-01-03 13:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tsi pura 2009-01-03 13:02:54 UTC
Version:           Version 3.1.2 (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

there is no long descripiton... it just crashed. :) @ the time being the crash occured i was running linux mint (the latest) firefox, amarok and was browsing facebook(no script enabled for certain scripts)

Here are some things the kde crash handler whiped @ my face! :D

Application: KTorrent (ktorrent), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb5e468d0 (LWP 6683)]
[New Thread 0xac502b90 (LWP 6699)]
[New Thread 0xb4771b90 (LWP 6698)]
[KCrash handler]
#6  0x2e303431 in ?? ()
#7  0xb71725a3 in QSortFilterProxyModel::mapFromSource ()
   from /usr/lib/libQtGui.so.4
#8  0xb716c1f2 in QSortFilterProxyModel::parent () from /usr/lib/libQtGui.so.4
#9  0xb7123568 in QTreeView::indexRowSizeHint () from /usr/lib/libQtGui.so.4
#10 0xb7123c62 in ?? () from /usr/lib/libQtGui.so.4
#11 0xb7128c6a in QTreeView::verticalOffset () from /usr/lib/libQtGui.so.4
#12 0xb70f1540 in ?? () from /usr/lib/libQtGui.so.4
#13 0xb6c76490 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#14 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#15 0xb6c767be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#16 0xb6c767be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#17 0xb6c767be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#18 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#19 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#20 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#21 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#22 0xb6c767be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#23 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#24 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#25 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#26 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#27 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#28 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#29 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#30 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#31 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#32 0xb6c768b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#33 0xb6c767be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#34 0xb6c75d88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#35 0xb6de5fae in ?? () from /usr/lib/libQtGui.so.4
#36 0xb6de64a7 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6c77576 in QWidget::event () from /usr/lib/libQtGui.so.4
#38 0xb6fcb517 in QMainWindow::event () from /usr/lib/libQtGui.so.4
#39 0xb7b40958 in KMainWindow::event (this=0xa26cb30, ev=0xb2d7b48)
    at /build/buildd/kde4libs-4.1.3/kdeui/widgets/kmainwindow.cpp:1073
#40 0xb7b8415c in KXmlGuiWindow::event (this=0xa26cb30, ev=0xb2d7b48)
    at /build/buildd/kde4libs-4.1.3/kdeui/xmlgui/kxmlguiwindow.cpp:133
#41 0xb6c1f8ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#42 0xb6c277fa in QApplication::notify () from /usr/lib/libQtGui.so.4
#43 0xb7a6eb2d in KApplication::notify (this=0xbfd3347c, receiver=0xa26cb30, 
    event=0xb2d7b48)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#44 0xb752ee61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#45 0xb752fae5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#46 0xb752fcdd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#47 0xb755982f in ?? () from /usr/lib/libQtCore.so.4
#48 0xb621b6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb621eda3 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb621ef61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb7559478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#52 0xb6cb9ea5 in ?? () from /usr/lib/libQtGui.so.4
#53 0xb752d52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#54 0xb752d6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#55 0xb752fda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#56 0xb6c1f767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#57 0x0806441b in main (argc=4, argv=0xbfd337f4)
    at /build/buildd/ktorrent-3.1.2+dfsg.1/ktorrent/main.cpp:165
#0  0xb8031430 in __kernel_vsyscall ()
Comment 1 Joris Guisson 2009-01-03 13:16:29 UTC

*** This bug has been marked as a duplicate of bug 172198 ***