Bug 179112 - Feature Request: alt+tab for switching between tabs and column select
Summary: Feature Request: alt+tab for switching between tabs and column select
Status: RESOLVED DUPLICATE of bug 104997
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-30 07:39 UTC by Shreshtha
Modified: 2009-09-06 11:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shreshtha 2008-12-30 07:39:16 UTC
Version:           3.1.3 (using KDE 4.1.3)
Compiler:          Gcc 3.2.2  
OS:                Linux
Installed from:    Ubuntu Packages

ALT + TAB to switch between tabs will be very very useful feature.
Detail:
1. ALT + TAB once will switch to previous "working" tab.
2. ALT(pressed) + TAB (multiple times) keep on switching sequentially (or in the sequence of last accessed, more fancy request though!)


Column text select and replacement and editing will also be quite useful feature. Same as how done in VIM
"Visual Select - CTRL + v", then highlight using arrow key and then "Insert text - SHIFT + i".

For Linux interface we can have a switch to select the mode - normal and column select. Selection can be normal using shift and arrow key, with only difference that, in column mode up/down arrow key will not select the whole line but that column.

ALT + TAB is most needed!!!!

BR,
Shreshtha
Comment 1 Shreshtha 2008-12-30 08:51:12 UTC
My mistake - "CTRL + TAB" is the combination.
Replace all "ALT + TAB" with "CTRL + TAB" in the message above.
Comment 2 Kari Argillander 2009-01-11 02:20:29 UTC
Only what you have to do is go Setting -> Edit Shorcut and change "Next" shortcut from alt+right to ctrl+tab. So this is done already.
Comment 3 Thomas Friedrichsmeier 2009-09-06 11:14:37 UTC
The document switching mode requested in this report is the same as bug #104997.

"Column selection" mode is already available (called "block selection mode" in kwrite/kate; Edit -> Block Selection Mode).

*** This bug has been marked as a duplicate of bug 104997 ***