Bug 178895 - Kmail minimize to systray causes fullscreen Kwin repaint flickering
Summary: Kmail minimize to systray causes fullscreen Kwin repaint flickering
Status: RESOLVED DUPLICATE of bug 177985
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-27 16:01 UTC by adibudeen
Modified: 2009-01-02 10:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adibudeen 2008-12-27 16:01:39 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

I'm using an Nvidia GeForce 6600 FX, so I'm not sure if this is related to the Nvidia proprietary driver or not.

To reproduce, you need Kwin desktop effects on.  Also, enable the "show paint" effect.  Next, start kmail and enable the system tray option.  Click the close button on kmail to minimize it to the system tray, and the entire screen will start flickering, repainting continuously, causing the CPU usage of kwin and X to climb.

Stopping desktop effects and restarting it makes it go away, but anytime kmail is minimized to the tray, it returns.
Comment 1 Martin Flöser 2009-01-02 10:39:03 UTC

*** This bug has been marked as a duplicate of bug 177985 ***