Bug 178696 - Some jamendo albums are missing
Summary: Some jamendo albums are missing
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Internet Services (show other bugs)
Version: 2.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-24 22:58 UTC by Stéphane Magnenat
Modified: 2010-05-24 14:34 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Magnenat 2008-12-24 22:58:58 UTC
Version:           2.0 (using 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2)), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.27-9-generic

Some jamendo albums do not appear in Amarok, for instance:
- http://www.jamendo.com/en/album/30718
- http://www.jamendo.com/en/album/26105
I do not understand why, it is probably a bug somewhere in the database fetching.
Comment 1 Mark Kretschmann 2008-12-24 23:16:27 UTC
This one's for Casey :)
Comment 2 Sebastian Krämer 2009-01-24 11:32:17 UTC
I noticed that too (http://www.jamendo.com/de/album/22302). The other two albums created by the same artist are there.
Comment 3 Myriam Schweingruber 2009-01-31 11:10:17 UTC
Confirmed. Stöphane, could it be because of the é in your name?
Comment 4 Myriam Schweingruber 2009-01-31 11:22:41 UTC
Forget my previous comment, I simply can't find you at all, and it's the same problem with other artist. Seems like the local database is not fetching some entries at all. 
Comment 5 Torbjörn K. 2009-03-13 19:38:21 UTC
There are not only some albums missing. There are a lot missing.
I just downloaded the Jamendo-Database with a complete newly installed Amarok 2.0.2-24.3 (openSUSE 11.0 Repository) and Amarok prints out that about 8,000 albums are in the Jamendo-Database. Jamendo's website is talking about 17,000 albums.
Comment 6 Matija Šuklje 2009-05-02 14:02:26 UTC
I can confirm this on 2.0.2 on Gentoo AMD64.
Comment 7 Myriam Schweingruber 2009-05-02 14:13:31 UTC
@Nikolaj: any chance this gets fixed some time?
Comment 8 Sven Krohlas 2009-05-15 09:46:04 UTC
This has been fixed with:

SVN commit 968131 by dmeltzer:

Use an xml streamreader instead of dom to parse the jamendo file.  This uses much less memory.  Also switch to the new xml file from jamendo, which has many more albums and artists.  This probably fixes a bug, but I'm not looking it up
Comment 9 Stéphane Magnenat 2009-06-04 23:49:06 UTC
This bug is fixed in 2.1 indeed. However, there is still a bug with Jamendo (see #195272)
Comment 10 Matija Šuklje 2010-05-23 21:51:42 UTC
There's still a lot of albums missing. Should we REOPEN this bug or create a new one?
Comment 11 Sven Krohlas 2010-05-24 14:34:34 UTC
There already is one:
https://bugs.kde.org/show_bug.cgi?id=235184

As a general rule: creating new bugs is better as they contain less noise then. Developers need clean bug reports.