Bug 178542 - keypad numbers ignored when trying to switch desktops
Summary: keypad numbers ignored when trying to switch desktops
Status: RESOLVED DUPLICATE of bug 183458
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: shortcuts (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
: 144386 173974 177180 (view as bug list)
Depends on:
Reported: 2008-12-23 06:20 UTC by doc.evans
Modified: 2012-11-03 10:42 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description doc.evans 2008-12-23 06:20:01 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Ubuntu Packages

This is a long-standing (pre KDE4) bug. It may still be somewhere open in the database, but I couldn't find it, so I'm re-filing it specifically against KDE4. (I looked hard; I apologize if it's there.)

In System Settings | Keyboard & Mouse | Keyboard Shortcuts, one can set (for example) "Switch to desktop 1" by pressing the left Win key and the keypad "1". This is reported as "Meta-1" on my system, which in itself is a little strange; I would expect that it record it as "Win-KP1". Anyway, after applying this new definition, I would expect that hitting the same keys (left Win + KP1) would cause a switch to desktop 1. It doesn't. Pressing the entered combination produces no result at all.
Comment 1 FiNeX 2008-12-24 12:16:08 UTC
I can confirm this bug.
Comment 2 FiNeX 2008-12-24 12:16:32 UTC
P.S: I'm using trunk, r900835
Comment 3 Jonathan Thomas 2009-01-04 20:17:01 UTC
*** Bug 144386 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Thomas 2009-01-04 20:17:51 UTC
*** Bug 173974 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Thomas 2009-01-04 20:18:48 UTC
*** Bug 177180 has been marked as a duplicate of this bug. ***
Comment 6 dillonco 2009-01-14 22:04:45 UTC
To add to this, I'm finding that none of the keypad's keys (with or without NumLock) function in shortcuts.  If the key exists elsewhere (e.g. "1", Ins, etc.) than that key will work, but the keypad version does not.  In the case of other keys (e.g. "*", etc.) the shortcut never works because the other "*" is registered as Shift+*, not simply *.
As far as being pre-KDE4, I know that using the keypad's Ins key worked in 3.5, but never tried the numbers.
Using 4.1.3.
Comment 7 Garth 2009-03-10 02:29:23 UTC
I just noticed this bug after updating from 4.2 to 4.2.1.  I have shortcuts for switching the desktop left/right/up/down using ctrl+arrow key.  The left and right shortcuts work, the up and down do not.  They were working last week, but now are not.  I'm running amd64 Kubuntu Intrepid with the Launchpad KDE 4.2.1 packages.
Comment 8 Joakim Rosqvist 2009-03-17 20:49:39 UTC
In the Task Tracker on the qtsoftware website (formerly Trolltech), I noticed this suggestion:

QKeySequence: Be able to specify that a keysequence refers to a numpad key with the Keypad modifier


Could this be related to the KDE problem of mapping shortcuts to keypad-keys?
Comment 9 Chris Stankevitz 2010-07-03 03:49:08 UTC
me too. KDE 4.4.5.  If you set a shortcut to CTRL-ALT-3 (using the number pad 3), it is only activated when you press CTRL-ALT-3 (using the 3 above the W key).

Where do I fix it?  I have source, I'll do it, just tell me where to look.

Comment 10 shad 2011-10-18 08:46:33 UTC
KDE 4.7, bug still present. 
It really sucks when changing from gnome to KDE, for quick tiling in corners numpad is nicely suited to the job.
Comment 11 Martin Koller 2012-08-16 13:17:28 UTC

*** This bug has been marked as a duplicate of bug 183458 ***