Bug 178419 - PNG images are not shown until being fully downloaded
Summary: PNG images are not shown until being fully downloaded
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-22 02:24 UTC by Artem S. Tashkinov
Modified: 2020-06-06 11:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem S. Tashkinov 2008-12-22 02:24:22 UTC
Version:           4.2.0 SVN (using Devel)
Compiler:          4.2.4 vanilla
OS:                Linux
Installed from:    Compiled sources

Every other existing web browser can show PNG images while they are being loaded.

Konqueror cannot do that.
Comment 1 Maksim Orlovich 2008-12-22 02:47:28 UTC
Are you talking in a standalone viewer? What viewer are you using?
Comment 2 Artem S. Tashkinov 2008-12-22 10:02:38 UTC
Open any heavy enough (say > 2MB) PNG file in Konqueror like http://kde.org/announcements/announce_4.2-beta2/desktop.png

Firefox/Opera/IE will show this file progressively line by line, while Konqueror will only display this image after it has been fully downloaded.
Comment 3 Tommi Tervo 2008-12-22 10:19:18 UTC
Maksim asked you to tell which image viewer do you use? (View-> View Mode -> which one is selected). I can reproduce this behavior when using gwenview kpart, but embedded image viewer displays PNG image progressively.
 
Comment 4 Artem S. Tashkinov 2008-12-22 16:56:23 UTC
Thanks, Tommi!

I have now done the following: I ran Konqueror, then went to Settings -> Configure Konqueror -> File Management -> File Associations -> Image/PNG -> Embedding and set "Embeddable Image Viewer" the first in the "Service Preference Order". Now images are being shown correctly (progressively).

However the bug is that "Embeddable Image Viewer" should be set as default for Web browsing, because I cannot justify using GwenView kpart for the simple task of viewing PNG images in Konqueror.
Comment 5 Maksim Orlovich 2008-12-22 17:03:11 UTC
Gwenview has a lot more functionality, such as zooming. The "Embeddable Image Viewer" is just a thing wrapper around KHTML's internal decoders. Anyway, I bet bug 178406 is about the same issue; let's hope the reporter of that responds.
Comment 6 Maksim Orlovich 2008-12-22 21:24:48 UTC

*** This bug has been marked as a duplicate of bug 178406 ***
Comment 7 Artem S. Tashkinov 2008-12-22 22:12:00 UTC
I cannot see how these two bugs are related to each other but you probably know better. However I still believe that PNG images in Konqueror should be handled by "Embeddable Image Viewer" as it is far more convenient for users (and after all you can later open the images in GwenView if you want to transform them).
Comment 8 Aurelien Gateau 2008-12-22 22:57:14 UTC
I do not think 178419 is the same as this one. 178419 is about the lack of incremental display of images while they are loaded. Something the Gwenview KPart still lacks.
Comment 9 Artem S. Tashkinov 2009-02-21 10:01:21 UTC
This bug also applies for standalone JPEG and GIF images. I think until Gwenview KPart supports incremental display of images the defaults should be changed.
Comment 10 Artem S. Tashkinov 2010-01-26 15:27:29 UTC
KDE 4.4 still suffers from this problem.
Comment 11 Artem S. Tashkinov 2010-06-08 13:59:59 UTC
Still the issue in KDE 4.5 beta 1.
Comment 12 Artem S. Tashkinov 2010-11-27 17:02:07 UTC
Still broken in KDE 4.6 beta 1.

Sigh.
Comment 13 Artem S. Tashkinov 2014-11-01 22:10:47 UTC
At least in Fedora 21 this bug is fixed because Fedora uses GwenView by default.

Is GwenView the default in new KDE versions or it's only Fedora?
Comment 14 Nate Graham 2017-09-09 04:06:26 UTC
Gwenview is a standalone local image viewer, which as far as I can tell isn't relevant to the originally reported issue in Konqueror.
Comment 15 Artem S. Tashkinov 2020-06-06 11:59:27 UTC
Seems to be fixed in neon-testing-20200602-1042.iso (had to install via apt install konqueror) and also Konqueror seems to be abandoned.