Bug 178080 - Scanfolder: Crash after moving torrent to folder
Summary: Scanfolder: Crash after moving torrent to folder
Status: RESOLVED DUPLICATE of bug 172198
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-18 18:13 UTC by Xenophon
Modified: 2008-12-18 18:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xenophon 2008-12-18 18:13:20 UTC
Version:           3.1.2 (using 4.1.3 (KDE 4.1.3), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.27-9-generic

I downloaded a torrent and after moving it downloaded torrent to my "load" folder to load it silently, KTorrent crashed. I have a vague feeling that I might have reported a similar bug before, but, I can't find the issue.

Thanks!
-----------

Application: KTorrent (ktorrent), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5dad6c0 (LWP 8570)]
[New Thread 0xb33aeb90 (LWP 8630)]
[New Thread 0xb45dfb90 (LWP 8629)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x05050505 in ?? ()
#7  0xb70da5a3 in QSortFilterProxyModel::mapFromSource ()
   from /usr/lib/libQtGui.so.4
#8  0xb70d41f2 in QSortFilterProxyModel::parent () from /usr/lib/libQtGui.so.4
#9  0xb708b568 in QTreeView::indexRowSizeHint () from /usr/lib/libQtGui.so.4
#10 0xb708bc62 in ?? () from /usr/lib/libQtGui.so.4
#11 0xb7090c6a in QTreeView::verticalOffset () from /usr/lib/libQtGui.so.4
#12 0xb7059540 in ?? () from /usr/lib/libQtGui.so.4
#13 0xb6bde490 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#14 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#15 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#16 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#17 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#18 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#19 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#20 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#21 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#22 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#23 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#24 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#25 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#26 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#27 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#28 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#29 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#30 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#31 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#32 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#33 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#34 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#35 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#36 0xb6bde8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#37 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#38 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#39 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#40 0xb6bde7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#41 0xb6bddd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#42 0xb6d4dfae in ?? () from /usr/lib/libQtGui.so.4
#43 0xb6d4e4a7 in ?? () from /usr/lib/libQtGui.so.4
#44 0xb6bdf576 in QWidget::event () from /usr/lib/libQtGui.so.4
#45 0xb6f33517 in QMainWindow::event () from /usr/lib/libQtGui.so.4
#46 0xb7aa7958 in KMainWindow::event () from /usr/lib/libkdeui.so.5
#47 0xb7aeb15c in KXmlGuiWindow::event () from /usr/lib/libkdeui.so.5
#48 0xb6b878ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#49 0xb6b8f7fa in QApplication::notify () from /usr/lib/libQtGui.so.4
#50 0xb79d5b2d in KApplication::notify () from /usr/lib/libkdeui.so.5
#51 0xb7496e61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#52 0xb7497ae5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#53 0xb7497cdd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#54 0xb74c182f in ?? () from /usr/lib/libQtCore.so.4
#55 0xb61836f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#56 0xb6186da3 in ?? () from /usr/lib/libglib-2.0.so.0
#57 0xb6186f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#58 0xb74c1478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#59 0xb6c21ea5 in ?? () from /usr/lib/libQtGui.so.4
#60 0xb749552a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#61 0xb74956ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#62 0xb7497da5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#63 0xb6b87767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#64 0x0806441b in _start ()
#0  0xb7f9c430 in __kernel_vsyscall ()
Comment 1 Dario Andres 2008-12-18 18:36:08 UTC
The backtrace is the same as bug 172198. (qt bug, workaround applied in Ktorrent 3.1.5). Marking as duplicate of bug 172198

*** This bug has been marked as a duplicate of bug 172198 ***