Bug 178056 - [PATCH ] in shuffle mode amarok ignores repeat track mode
Summary: [PATCH ] in shuffle mode amarok ignores repeat track mode
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlist (show other bugs)
Version: 2.3-GIT
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.3.1
Assignee: Amarok Developers
URL:
Keywords:
: 210610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-18 12:42 UTC by christian tacke
Modified: 2009-10-31 12:11 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian tacke 2008-12-18 12:42:01 UTC
Version:           2.0 (using KDE 4.1.3)
Installed from:    Ubuntu Packages

I had shuffle tracks turned on but then decided to keep hearing only one song and activated repeat track, but when the song ended, amarok started playing another song, like it were still in shuffle mode.

but the most strage behavior is, that the song i wanted amarok to repeat was still shown in song info. 

When I turned off shuffle, it worked as expected. When I turned shuffle on again, it repeated the track again, but then fall back to the behavior described above.

Repeat mode should be of higher priority than shuffle mode, i think.

I use the german version, so i don't know how the entrys in the menu are named. hope i made myself clear.

Amarok 2 rocks, as expected :)
Comment 1 Seb Ruiz 2008-12-18 13:29:18 UTC
SVN commit 898553 by seb:

Don't fadeout paused media when stopping
BUG: 178056

 M  +1 -0      ChangeLog  
 M  +4 -3      src/EngineController.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=898553
Comment 2 Seb Ruiz 2008-12-18 13:32:32 UTC
Whoops, closed the wrong bug, sorry.
Comment 3 Myriam Schweingruber 2009-04-24 12:42:04 UTC
There is no news on this bug since it's report 4 months ago, and it remains unconfirmed. Does this still happen with 2.1 beta1 or SVN?
Comment 4 Myriam Schweingruber 2009-05-15 10:28:37 UTC
Closing for lack of feedback
Comment 5 jonny sutton 2009-06-11 19:22:30 UTC
I can confirm this bug still exists using OpenSuse RPM build, version 2.1, to replicate = set up a playlist, enable "random track" play song, enable "repeat track" when track ends a new track will play
Comment 6 Myriam Schweingruber 2009-06-11 19:53:51 UTC
Can somebody have a look at that, please?
Comment 7 Alexey Shildyakov 2009-06-25 13:40:30 UTC
Confirm at 2.2-SVN at revision 987027 with the following settings:
1) Repeat mode - Track, Random mode - Tracks
2) in Dynamic playlist mode with no additional settings. Also Repeat mode - Track, and Random mode - Tracks, Off a both.
Comment 8 Beat Wolf 2009-07-13 20:43:00 UTC
I can confirm with 2.1.1

the workaround works too.
Comment 9 Kuba Serafinowski 2009-08-15 23:29:44 UTC
okay confirmed here with latest GIT, rendom track and repeat track are on, but it keeps playing next track rather repeating
Comment 10 Lydia Pintscher 2009-09-09 15:01:53 UTC
Is this still a problem? I think there was a commit to fix it.
Comment 11 Myriam Schweingruber 2009-10-15 01:34:57 UTC
*** Bug 210610 has been marked as a duplicate of this bug. ***
Comment 12 Myriam Schweingruber 2009-10-15 19:48:51 UTC
Comment from bug 210610:

--- Comment #2 from Michal Ziabkowski <mziab o2 pl>  2009-10-15 17:59:02 ---
Ah, sorry about the dupe. Anyway, I made something like this:

--- src/playlist/PlaylistActions.cpp    2009-10-15 02:36:36.083025219 +0200
+++ src/playlist/PlaylistActions.cpp.new    2009-10-15 02:51:23.451025250 +0200
@@ -275,7 +275,9 @@
    {
        if ( Amarok::randomTracks() )
        {
-            if( Amarok::favorNone() )
+            if( Amarok::repeatTrack() )
+                m_navigator = new RepeatTrackNavigator();
+            else if( Amarok::favorNone() )
                m_navigator = new RandomTrackNavigator();
            else
                m_navigator = new FavoredRandomTrackNavigator();

This might not be the optimal approach and I'm not sure what the behaviour for
Random + Repeat Album should be. Regardless, at least the Repeat Track + Random
combo works as I'd expect it to, giving priority to repeating the track.
Comment 13 Nikolaj Hald Nielsen 2009-10-31 12:11:46 UTC
commit 0a5e1ab0b9d5f042cc4a83bb1e2b463e995e4e26
Author: Nikolaj Hald Nielsen <nhnFreespirit@gmail.com>
Date:   Sat Oct 31 12:04:52 2009 +0100

    Reverse the priority of repeat and random modes. Repeat now always takes precedence.
    This is a band-aid on the real issue though, which is that the UI for this is a big fat lier! It allows the user to select both a random and a repeat mode at the same time, but internally Amarok always selects only one navigator, making the actual result very hard to
    Also, some combinations of repeat and random really makes no conceptual sense at all, like repeat album and random album, or repeat track and any random mode. Come end of string freeze I am going to redo this interface completely.