Bug 177954 - seaching collection does not always expand
Summary: seaching collection does not always expand
Status: RESOLVED DUPLICATE of bug 172379
Alias: None
Product: amarok
Classification: Applications
Component: Collection Browser (show other bugs)
Version: 2.0
Platform: Fedora RPMs Unspecified
: HI wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-17 03:28 UTC by Chad Calkins
Modified: 2009-05-18 13:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chad Calkins 2008-12-17 03:28:23 UTC
Version:           2.0 2.fc10 (using KDE 4.1.3)
Installed from:    Fedora RPMs

Searching the collection does not always expand to show items that match the search.

To Reproduce:
1) With the collection collapsed so that only Local Collection is visibile.
2) Enter part of the name of a song that you have
3) Nothing happens.

Expected the collection to expand to show the items that match the current query, but instead it only will display stuff that was already expanded, if nothing was expanded then the collection will just display "Local Collection".
Comment 1 Mark Kretschmann 2008-12-17 08:42:41 UTC
I think you misunderstand how the system works. The filter is subtractive, not additive.

What you do is expand the collection, then enter the filter terms, and then Amarok will remove any non matching items.
Comment 2 Chad Calkins 2008-12-17 09:30:26 UTC
Actually I do know how it works.  When you enter filter terms the collection is filtered such that only things that match the terms are visible in the collection.  The issue is that the tree itself remains collapsed.  Previously the tree would be expanded when the filter was used.

Example:
Enter NOFX in the filter.  The collection would show NOFX and all the songs under the artist.

Or
Enter Fish
The first couple matching entries in the collection would be expanded down to the track level, after that the ones below would be expanded to perhaps artist.

The thing missing is that the collection would uncollapse as the filter was used.  It was and extremely handy thing.

Sounds like that instead of a bug, this is an enhancement.
Comment 3 Chad Calkins 2008-12-17 09:59:06 UTC
Fiddled with the behaviour of 1.4 Amarok.  The tree is expanded as the filter narrows the total collection of things.  In my collection entering fish expands the tree to display a couple songs, clearing the filter causes the collection to contract.

Clearly this behaviour was intended at 1.4 and was not included into 2.0. It is incredibly handy and makes the filter much more useful.  As it is now with 2.0, I enter a search term, expand the tree, expand one of the artists, expand one of the albums, and finally see the song.  This is OK if I know the exact term I am looking for, but, if I am using the filter to only narrow my choices it is far more difficult and requires that I expand each potential selection by hand to find what I am looking for.
Comment 4 Myriam Schweingruber 2009-01-31 10:23:09 UTC
It's not a bug, but a missing feature. Added to the whislist as high priority.
Comment 5 Myriam Schweingruber 2009-05-18 13:16:49 UTC

*** This bug has been marked as a duplicate of bug 172379 ***