Bug 177692 - Konqueror crashed when being closed
Summary: Konqueror crashed when being closed
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-13 18:00 UTC by Oleksiy Khilkevich
Modified: 2008-12-13 19:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksiy Khilkevich 2008-12-13 18:00:24 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Failed to reproduce the problem.
Expected behaviour: not to crash, when closed :)

Loaded plugins: Adobe Flash Player, but there was no animations on the Web page.

Backtrace as reported by crash handler:

Application: Konqueror (konqueror), signal SIGABRT
[Current thread is 0 (LWP 7324)]

Thread 2 (Thread 0xb26dbb90 (LWP 7402)):
#0  0xb7f13424 in __kernel_vsyscall ()
#1  0xb653e9f1 in select () from /lib/i686/cmov/libc.so.6
#2  0xb72667d0 in QProcessManager::run (this=0x8fc7040) at io/qprocess_unix.cpp:301
#3  0xb719753e in QThreadPrivate::start (arg=0x8fc7040) at thread/qthread_unix.cpp:185
#4  0xb712e4c0 in start_thread () from /lib/i686/cmov/libpthread.so.0
#5  0xb654661e in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5f25910 (LWP 7324)):
[KCrash Handler]
#6  0xb7f13424 in __kernel_vsyscall ()
#7  0xb6491640 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb6493018 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb648a5be in __assert_fail () from /lib/i686/cmov/libc.so.6
#10 0xb3da9d01 in KHTMLGlobal::finalCheck () at /home/kde/kde/src/KDE/kdelibs/khtml/khtml_global.cpp:258
#11 0xb0e7c333 in ~KHTMLFactory (this=0x945b4a8) at /home/kde/kde/src/KDE/kdelibs/khtml/khtml_factory.cpp:35
#12 0xb759757b in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x9441b18}, end={i = 0x94a3798}) at /home/kde/qt-copy/include/QtCore/qalgorithms.h:346
#13 0xb75975e0 in qDeleteAll<FactoryHash> (c=@0x919e300) at /home/kde/qt-copy/include/QtCore/qalgorithms.h:354
#14 0xb75977f9 in ~FactoryHash (this=0x919e300) at /home/kde/kde/src/KDE/kdelibs/kdecore/util/klibrary.cpp:93
#15 0xb7596681 in destroy () at /home/kde/kde/src/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#16 0xb7467a9d in ~KCleanUpGlobalStatic (this=0xb75ed440) at /home/kde/kde/src/KDE/kdelibs/kdecore/kernel/kglobal.h:62
#17 0xb6494ab9 in exit () from /lib/i686/cmov/libc.so.6
#18 0xb647c45d in __libc_start_main () from /lib/i686/cmov/libc.so.6
#19 0x08048671 in _start ()
Comment 1 Dario Andres 2008-12-13 19:09:40 UTC

*** This bug has been marked as a duplicate of bug 151453 ***