Bug 177452 - Crash when saving changes after merging files (kompare file1 file2) (Please fix :)
Summary: Crash when saving changes after merging files (kompare file1 file2) (Please f...
Status: RESOLVED DUPLICATE of bug 165421
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-11 01:55 UTC by Maciej Mrozowski
Modified: 2009-01-23 18:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Mrozowski 2008-12-11 01:55:54 UTC
Version:            (using Devel)
Compiler:          gcc (Gentoo 4.3.2 p1.0) 4.3.2 kdelibs and kompare compiled from trunk 10 Dec  2008
OS:                Linux
Installed from:    Compiled sources

Steps to reproduce
1. kompare file1 file2 (invoked on two text files (not large, a few KBs)
2. apply some differences to file2 (destination file)
3. file->save (to update file2 with some parts from file1)

Sometimes kompare saves well, sometimes it crashes during the save operation (usually ~ 50/50)

Backtrace:

Application: Kompare (kompare), signal SIGSEGV
0x00007f1b7710ade1 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 32061)]

Thread 2 (Thread 0x7f1b6f575950 (LWP 32062)):
#0  0x00007f1b77141b42 in select () from /lib/libc.so.6
#1  0x00007f1b782a56b9 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f1b781ecc04 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f1b764763da in start_thread () from /lib/libpthread.so.0
#4  0x00007f1b7714940d in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1b7a285750 (LWP 32061)):
[KCrash Handler]
#5  0x00007f1b77989ad6 in QRegion::isEmpty () from /usr/lib64/qt4/libQtGui.so.4
#6  0x00007f1b778e4265 in QWidgetPrivate::create_sys () from /usr/lib64/qt4/libQtGui.so.4
#7  0x00007f1b778b44aa in QWidget::create () from /usr/lib64/qt4/libQtGui.so.4
#8  0x00007f1b778b4bdf in QWidget::winId () from /usr/lib64/qt4/libQtGui.so.4
#9  0x00007f1b791cb76e in KIO::SchedulerPrivate::registerWindow (this=0xd8a4d0, wid=0xbe5950) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kio/kio/scheduler.cpp:1018
#10 0x00007f1b791cc180 in KIO::Scheduler::registerWindow (wid=0xbe5950) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kio/kio/scheduler.cpp:301
#11 0x00007f1b7914e752 in KIO::JobUiDelegate::setWindow (this=0xe0d260, window=0xbe5950) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kio/kio/jobuidelegate.cpp:58
#12 0x00007f1b791bc051 in KIO::NetAccess::filecopyInternal (this=0x7fff822b58a0, src=@0x7fff822b5890, target=@0x7fff822b5c20, permissions=-1, flags={i = -2111088432}, window=0xbe5950, move=false)
    at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kio/kio/netaccess.cpp:320
#13 0x00007f1b791bc92d in KIO::NetAccess::upload (src=@0x7fff822b5c30, target=@0x7fff822b5c20, window=0xbe5950) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kio/kio/netaccess.cpp:142
#14 0x00007f1b703e7e0c in Diff2::KompareModelList::saveDestination (this=0xbf19e0, model=0xd35180) at /var/tmp/portage/kde-base/kompare-9999/work/kompare/kompare/libdiff2/komparemodellist.cpp:388
#15 0x00007f1b703e7fd6 in Diff2::KompareModelList::slotSaveDestination (this=0xbf19e0) at /var/tmp/portage/kde-base/kompare-9999/work/kompare/kompare/libdiff2/komparemodellist.cpp:294
#16 0x00007f1b703e8345 in Diff2::KompareModelList::qt_metacall (this=0xbf19e0, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x7fff822b5e00)
    at /var/tmp/portage/kde-base/kompare-9999/work/kompare_build/kompare/libdiff2/komparemodellist.moc:150
#17 0x00007f1b782d4cff in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#18 0x00007f1b77868685 in QAction::triggered () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f1b77868cf5 in QAction::activate () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f1b77b4954b in ?? () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007f1b77b4976f in QAbstractButton::mouseReleaseEvent () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007f1b77bfd300 in QToolButton::mouseReleaseEvent () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f1b778b68a1 in QWidget::event () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007f1b7786d5d5 in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00007f1b77874ef8 in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00007f1b78c32c34 in KApplication::notify (this=0x7fff822b7450, receiver=0xcb8bb0, event=0x7fff822b6750)
    at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdeui/kernel/kapplication.cpp:307
#27 0x00007f1b782c2e55 in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007f1b7787399a in QApplicationPrivate::sendMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007f1b778ce035 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#30 0x00007f1b778ccba8 in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#31 0x00007f1b778ef88b in ?? () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00007f1b73e66156 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0x00007f1b73e69345 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0x00007f1b73e69557 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0x00007f1b782e6f59 in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007f1b778ef136 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#37 0x00007f1b782c1b04 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#38 0x00007f1b782c1c82 in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#39 0x00007f1b782c3bff in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#40 0x000000000040b953 in main (argc=3, argv=0x7fff822b7ea8) at /var/tmp/portage/kde-base/kompare-9999/work/kompare/kompare/main.cpp:233
Comment 1 Kevin Kofler 2008-12-11 03:17:14 UTC

*** This bug has been marked as a duplicate of bug 165421 ***