Bug 177415 - amarok2 drop to filebrowser does not work.
Summary: amarok2 drop to filebrowser does not work.
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: File Browser (show other bugs)
Version: 2.0
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 179828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-10 19:44 UTC by Thomas Kamps
Modified: 2009-12-09 11:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kamps 2008-12-10 19:44:17 UTC
Version:           2.0 (using 4.1.3 (KDE 4.1.3) "release 55.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.18-0.2-default

Drag a random entry from playlist or collectionbrowser to a filebrowser (in my case dolphin from kde 4.1.3). Nothing happens.
Comment 1 Mark Kretschmann 2008-12-11 08:12:03 UTC
I would call this a wish.

The browsers are meant to be music sources, not destinations. So you can't necessarily expect them to be working as a drop target.
Comment 2 Dan Meltzer 2008-12-11 08:21:55 UTC
It's a regression from 1.4 however, so it may be better classified a bug in that respect...
Comment 3 Seb Ruiz 2009-01-06 22:56:25 UTC
*** Bug 179828 has been marked as a duplicate of this bug. ***
Comment 4 Frederik Gladhorn 2009-05-02 18:47:28 UTC
SVN commit 962601 by gladhorn:

Fix drag and drop to the outside world.
(Support QByteArray in QMimeData)
BUG: 177415


 M  +2 -2      AmarokMimeData.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=962601