Bug 177330 - all rss applications use their own storage
Summary: all rss applications use their own storage
Status: RESOLVED WORKSFORME
Alias: None
Product: kdepimlibs
Classification: Applications
Component: syndication (show other bugs)
Version: 4.1
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-09 19:44 UTC by Ritesh Raj Sarraf
Modified: 2016-11-25 16:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ritesh Raj Sarraf 2008-12-09 19:44:37 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Sorry if it is the wrong component.

Some time back, it was told that all rss applications were going to use a common rss backend, probably libakregator or librss kind of thing.

I just checked on KDE 4.2 Beta 1 and still all apps use their own rrs storage. This ends up requiring adding the same rss feed at multiple locations.

The applications I checked include:
* Akregator
* RSSNow Plasmoid
* News Plasmoid

Is this feature been postponed to a future milestone ?
Comment 1 FiNeX 2008-12-10 14:19:50 UTC
Hi! You should discuss about this type of issue with developers on mailing list or on the KDE forum ( forum.kde.org ). I'm closing this report because is not a bug.

Thanks!
Comment 2 Ritesh Raj Sarraf 2009-02-11 13:37:18 UTC
It is already a messy situation currently with 4.2.

There are 2 plasmoids and akregator, so a total of 3 apps, all storing rss feed source in different places.

Before 4.x, Aaron had mentioned that all rss apps should have a common store. I'm not sure what happened to that thought.

I'm re-opening it because, I as a User, can't see a better place to file bugs/wishlists, and track them.
Please don't expect a user to track devel/core-devel.
Comment 3 Christophe Giboudeaux 2009-02-11 13:45:58 UTC
"As a user", you shouldn't have to care about how applications or widgets store their datas...

This is clearly not a user question nor a bug.

Comment 4 Ritesh Raj Sarraf 2009-02-11 20:44:18 UTC
(In reply to comment #3)
> "As a user", you shouldn't have to care about how applications or widgets store
> their datas...
> 
> This is clearly not a user question nor a bug.
> 

I should.
Duplication of data is something that affects the user also. Configuring the same rss sites at 3 different locations is not the right/smart thing.