Bug 177323 - Fonts and their sizes in menus
Summary: Fonts and their sizes in menus
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
: 285476 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-09 18:53 UTC by msnkipa
Modified: 2018-04-16 20:24 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description msnkipa 2008-12-09 18:53:27 UTC
Version:            (using KDE 4.1.3)
Installed from:    SuSE RPMs

I can`t change fonts and their sizes in kdm menus (session, menu etc..) nor in themes, nor in classical mode.
Comment 1 Oswald Buddenhagen 2008-12-09 19:47:10 UTC
does changing the greeting font have any effect?
Comment 2 msnkipa 2008-12-09 20:19:48 UTC
Changing the greeting font have affect only for fonts in classic mode, exclude fonts in menus :( 

Comment 3 Victor Mataré 2009-09-19 04:04:47 UTC
(In reply to comment #2)
> Changing the greeting font have affect only for fonts in classic mode, exclude
> fonts in menus :( 

On my system (KDE 4.3.1), changing the greeter fonts doesn't work AT ALL. I can influence the font size by changing x.org's DPI setting, and that's it. In every other place, fonts work great.
Comment 4 Oswald Buddenhagen 2009-10-10 10:33:03 UTC
comment 3 is a duplicate of bug 182870.

this whole report sounds like it would be the same bug, but it is too old for that. anyway, please watch the other bug and report any (non-)changes of the situation here.
Comment 5 Eric Valette 2009-10-10 15:51:50 UTC
I recently bough a nettop. Its connected to the TV and its main purpose is to run XBMC. However, I also installed a minimal KDE, firefox to be able to surf without moving away from tv set.

After some work, all KDE application fonts are OK, Gnome fonts also (firefox, nvidia settings, ...). But as mentioned, there is no real way to change the user name font size. I cant simply read them. Font size is 10 when I need a minimum 32.
Comment 6 Eric Valette 2009-10-10 15:55:34 UTC
Forgot to say I changed all the visible login manager option for font size when logged as root => greeting is bigger but that's all.

Frankly, most netop used as enhanced HTPC will suffer from this.
Comment 7 Christoph Feck 2011-11-03 19:38:57 UTC
*** Bug 285476 has been marked as a duplicate of this bug. ***
Comment 8 Felix Miata 2014-07-28 03:48:58 UTC
Downstream https://bugzilla.novell.com/show_bug.cgi?id=888055 has been "resolved" to this bug. It has screenshots of the unthemed greeter for both kdm-4.10.5 and kdm-4.11.10 showing very tiny menu fonts.

Cauldron's kdm-4.11.11 unthemed menu fonts seem to be the same tiny size as openSUSE's. 

Rawhide's kdm-4.11.11 unthemed menu fonts are considerably bigger than Mageia's and openSUSE's, but definitely smaller than the StdFont size in its kdmrc.

This ancient bug needs to be marked confirmed/new and dealt with.
Comment 9 Nate Graham 2018-04-16 20:24:59 UTC
KDM is unmaintained and not used in KDE Plasma 5.

SDDM is the login manager used in KDE Plasma 5. If you still have this same issue with SDDM, please file an issue on the SDDM bugtracker (after doing a search for existing issues first!): https://github.com/sddm/sddm/issues/