Bug 177258 - Skip length (cursor left or right) is fixed to 10 seconds
Summary: Skip length (cursor left or right) is fixed to 10 seconds
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.6-git
Platform: openSUSE RPMs Linux
: HI normal (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 284682 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-08 21:26 UTC by Lars Müller
Modified: 2013-02-20 21:15 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments
Sample playback config UI file with settings for VLC style jumps (10.78 KB, application/x-designer)
2013-02-14 10:00 UTC, Anmol Ahuja
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Müller 2008-12-08 21:26:01 UTC
Version:            (using KDE 4.1.3)
Compiler:          gcc (SUSE Linux) 4.3.2 [gcc-4_3-branch revision 141291]  
OS:                Linux
Installed from:    SuSE RPMs

Currently the time skipped while pressing the cursor left or cursor right key is set to a fixed value of 10 seconds.

If you have a recorded interview and use amarok to listen to it it's impossible to skip back less than 10 seconds.  This is a bit annoying while transcribing as a value of 5 would be enough in most cases.

On IRC Hydrogen suggested to stay with the current default and to use an additional modifier key (Ctrl or Alt) plus the cursor keys.  If I got it right.
Comment 1 Dan Meltzer 2008-12-08 21:29:52 UTC
I'm thinking that if we made the modifier + arrow scroll in one second increments it would work fairly appropriately.

I'll look into this for 2.1
Comment 2 Lars Müller 2008-12-08 22:41:59 UTC
Would this require to press the key combination five times to skip five seconds?

I fear this isn't very user friendly in the particular use case as you have to skip back very often.

I would prefer a configuration option.  Not a very prominent one.  But one which allows to define an individual gap.
Comment 3 Mark Kretschmann 2008-12-08 23:05:34 UTC
In reality not all Phonon backends may be able to seek with the same precision. 

Something to look into too.
Comment 4 Mark S. 2011-12-23 04:59:44 UTC
This 10 second skip still happens in Amarok 2.5, and since it was filed 3 years ago, is this still necessary to be implemented?
Comment 5 Myriam Schweingruber 2011-12-23 09:58:58 UTC
Moving to bugs, this hard-coded time span should really be revised.
Comment 6 Myriam Schweingruber 2012-02-13 15:59:43 UTC
Indeed, this should be removed ASAP.
Comment 7 Edward Hades 2012-06-12 19:49:02 UTC
*** Bug 284682 has been marked as a duplicate of this bug. ***
Comment 8 Ralf Engels 2013-01-07 20:09:02 UTC
That is a low hanging fruit.

Do you want:
- Key modifier (I would use the same order as the vlc default modifiers shift, alt, control)
- Configuration option
-- Option also visible in configuration dialog (this needs new text so it would be out of scope for 2.7)
-- Hidden option (hidden meaning we have the option but it's not visible in the configuration dialog)

Any other clever idea?
Comment 9 Myriam Schweingruber 2013-01-10 11:10:48 UTC
Setting status correctly. This is marked now as a Junior Job.
Comment 10 Dead and Forgotten 2013-02-10 13:15:19 UTC
I'm interested in solving this bug. Could someone please guide me through this?
Comment 11 Myriam Schweingruber 2013-02-10 14:10:35 UTC
(In reply to comment #10)
> I'm interested in solving this bug. Could someone please guide me through
> this?

Nice to hear :) Please read through the documents listed here: http://community.kde.org/Amarok/Development/Join and install a local build of Amarok from git (all in the links) before getting in touch with us in #amarok on irc.freenode.net
Comment 12 Dead and Forgotten 2013-02-10 20:29:46 UTC
Done all of that, heading to IRC...
Comment 13 Anmol Ahuja 2013-02-11 16:12:13 UTC
Using this account on bugzilla from now on instead of spam.me.now.yeah
Comment 14 Anmol Ahuja 2013-02-14 10:00:21 UTC
Created attachment 77286 [details]
Sample playback config UI file with settings for VLC style jumps
Comment 15 Anmol Ahuja 2013-02-14 10:02:42 UTC
How should I go about implementing this? Do I implement VLC style jumps, with 4 different durations? If so, what key mapping do I choose, the same as VLC? I'm not so sure about the alt+ctrl+l/r combination, I believe it's the Unity default for moving between workspaces.

Is the attached config dialog okay?
Comment 16 Myriam Schweingruber 2013-02-14 10:11:12 UTC
(In reply to comment #15)
> How should I go about implementing this? Do I implement VLC style jumps,
> with 4 different durations? If so, what key mapping do I choose, the same as
> VLC? I'm not so sure about the alt+ctrl+l/r combination, I believe it's the
> Unity default for moving between workspaces.
> 
> Is the attached config dialog okay?

I thought that I made this clear in my mail: please ask this in the amarok-devel@mailing list and use reviewboard for proposed patches, even if those are still in an early stage.
Comment 17 Anmol Ahuja 2013-02-14 19:41:59 UTC
Review: https://git.reviewboard.kde.org/r/108964/
Comment 18 Matěj Laitl 2013-02-20 21:15:46 UTC
Git commit 265696b694559e09cad34f4b5e06077b92f91dce by Matěj Laitl, on behalf of Anmol Ahuja.
Committed on 20/02/2013 at 22:04.
Pushed by laitl into branch 'master'.

Add 2 more variants of seeking shortcuts + hidden config options

Control + L/R - Short seek
          L/R - Normal/ Medium seek
Shift   + L/R - Long seek

Along this the "Go Up in Media Sources Pane" gets renamed and reassigned
to Backspace.

FEATURES:
 * Added keyboard shortcuts for small 2 s seeks (Ctrl + Left/Right) and long 1 minute
   seeks (Shift + Left/Right) in addition to standard 10 s seeks. Durations are now
   configurable in amarokrc, see Amarok Handbook. Patch by Anmol Ahuja.

@Anmol, you may want to check minor changes I made to the patch.

REVIEW: 108964
FIXED-IN: 2.8
CCMAIL: Anmol Ahuja <darthcodus@gmail.com>

M  +3    -0    ChangeLog
M  +75   -6    src/MainWindow.cpp
M  +7    -0    src/MainWindow.h
M  +17   -2    src/amarokconfig.kcfg
M  +2    -2    src/browsers/BrowserDock.cpp

http://commits.kde.org/amarok/265696b694559e09cad34f4b5e06077b92f91dce