Bug 177081 - ktorrent application crashed while downloading
Summary: ktorrent application crashed while downloading
Status: RESOLVED DUPLICATE of bug 172198
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-06 19:35 UTC by andreaswuest
Modified: 2008-12-07 10:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreaswuest 2008-12-06 19:35:52 UTC
Version:           3.1.2 (using 4.1.2 (KDE 4.1.2), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.24-22-generic

hello,

here is the backtrace, i hope you can use it.

cheers,
andy

Application: KTorrent (ktorrent), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5e976c0 (LWP 16582)]
[New Thread 0xb2f17b90 (LWP 16607)]
[New Thread 0xb46beb90 (LWP 16606)]
[KCrash handler]
#6  QSortFilterProxyModel::parent (this=0x86b35b0, child=@0x8a6ae70)
    at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:66
#7  0xb7122066 in QTreeView::indexRowSizeHint (this=0x83eea18, 
    index=@0x8a6ae70)
    at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:364
#8  0xb7122807 in QTreeViewPrivate::itemHeight (this=0x86adfa8, item=0)
    at itemviews/qtreeview.cpp:3100
#9  0xb71274ff in QTreeView::verticalOffset (this=0x83eea18)
    at itemviews/qtreeview.cpp:2000
#10 0xb70f15b0 in QAbstractItemViewPrivate::contentsOffset (this=0x86adfa8)
    at ../../include/QtGui/private/../../../src/gui/itemviews/qabstractitemview_p.h:262
#11 0xb6c73273 in QWidgetPrivate::drawWidget (this=0x86ae280, pdev=0x834d33c, 
    rgn=@0xbff28a9c, offset=@0xbff28a74, flags=<value optimized out>, 
    sharedPainter=0x8927690) at kernel/qwidget.cpp:4504
#12 0xb6c73654 in QWidgetPrivate::paintSiblingsRecursive (this=0x86adfa8, 
    pdev=0x834d33c, siblings=@0xbff28e20, index=1, rgn=@0xbff28b4c, 
    offset=@0xbff28ec4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4626
#13 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x86adfa8, 
    pdev=0x834d33c, siblings=@0xbff28e20, index=6, rgn=@0xbff28bfc, 
    offset=@0xbff28ec4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#14 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x86adfa8, 
    pdev=0x834d33c, siblings=@0xbff28e20, index=7, rgn=@0xbff28cac, 
    offset=@0xbff28ec4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#15 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x86adfa8, 
    pdev=0x834d33c, siblings=@0xbff28e20, index=8, rgn=@0xbff28eec, 
    offset=@0xbff28ec4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#16 0xb6c72b56 in QWidgetPrivate::drawWidget (this=0x86adfa8, pdev=0x834d33c, 
    rgn=@0xbff28eec, offset=@0xbff28ec4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4569
#17 0xb6c73654 in QWidgetPrivate::paintSiblingsRecursive (this=0x83af0d0, 
    pdev=0x834d33c, siblings=@0xbff29060, index=8, rgn=@0xbff2912c, 
    offset=@0xbff29104, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4626
#18 0xb6c72b56 in QWidgetPrivate::drawWidget (this=0x83af0d0, pdev=0x834d33c, 
    rgn=@0xbff2912c, offset=@0xbff29104, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4569
#19 0xb6c73654 in QWidgetPrivate::paintSiblingsRecursive (this=0x8347cf0, 
    pdev=0x834d33c, siblings=@0xbff29350, index=2, rgn=@0xbff291dc, 
    offset=@0xbff293f4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4626
#20 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x8347cf0, 
    pdev=0x834d33c, siblings=@0xbff29350, index=3, rgn=@0xbff2941c, 
    offset=@0xbff293f4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#21 0xb6c72b56 in QWidgetPrivate::drawWidget (this=0x8347cf0, pdev=0x834d33c, 
    rgn=@0xbff2941c, offset=@0xbff293f4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4569
#22 0xb6c73654 in QWidgetPrivate::paintSiblingsRecursive (this=0x8346fb0, 
    pdev=0x834d33c, siblings=@0xbff29590, index=2, rgn=@0xbff2965c, 
    offset=@0xbff29634, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4626
#23 0xb6c72b56 in QWidgetPrivate::drawWidget (this=0x8346fb0, pdev=0x834d33c, 
    rgn=@0xbff2965c, offset=@0xbff29634, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4569
#24 0xb6c73654 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=33, rgn=@0xbff2970c, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4626
#25 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=34, rgn=@0xbff297bc, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#26 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=35, rgn=@0xbff2986c, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#27 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=38, rgn=@0xbff2991c, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#28 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=39, rgn=@0xbff299cc, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#29 0xb6c73567 in QWidgetPrivate::paintSiblingsRecursive (this=0x834c850, 
    pdev=0x834d33c, siblings=@0xbff29b40, index=41, rgn=@0xbff29c24, 
    offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4616
#30 0xb6c72b56 in QWidgetPrivate::drawWidget (this=0x834c850, pdev=0x834d33c, 
    rgn=@0xbff29c24, offset=@0x81b8ab4, flags=4, sharedPainter=0x8927690)
    at kernel/qwidget.cpp:4569
#31 0xb6dd844d in QWidgetBackingStore::cleanRegion (this=0x81b8aa8, 
    rgn=@0xbff29c78, widget=0x832a390, recursiveCopyToScreen=true)
    at painting/qbackingstore.cpp:1033
#32 0xb6dd87f7 in qt_syncBackingStore (widget=0x832a390)
    at painting/qbackingstore.cpp:319
#33 0xb6c78a2f in QWidget::event (this=0x832a390, event=0x875ad48)
    at kernel/qwidget.cpp:7303
#34 0xb6fd0a55 in QMainWindow::event (this=0x832a390, event=0x875ad48)
    at widgets/qmainwindow.cpp:1274
#35 0xb7b071df in KMainWindow::event (this=0x832a390, ev=0x875ad48)
    at /build/buildd/kde4libs-4.1.2/kdeui/widgets/kmainwindow.cpp:1064
#36 0xb7b42ddc in KXmlGuiWindow::event (this=0x832a390, ev=0x875ad48)
    at /build/buildd/kde4libs-4.1.2/kdeui/xmlgui/kxmlguiwindow.cpp:125
#37 0xb6c20f9c in QApplicationPrivate::notify_helper (this=0x810d810, 
    receiver=0x832a390, e=0x875ad48) at kernel/qapplication.cpp:3800
#38 0xb6c25ce8 in QApplication::notify (this=0xbff2a498, receiver=0x832a390, 
    e=0x875ad48) at kernel/qapplication.cpp:3765
#39 0xb7a4e483 in KApplication::notify (this=0xbff2a498, receiver=0x832a390, 
    event=0x875ad48)
    at /build/buildd/kde4libs-4.1.2/kdeui/kernel/kapplication.cpp:311
#40 0xb755a0b9 in QCoreApplication::notifyInternal (this=0xbff2a498, 
    receiver=0x832a390, event=0x875ad48) at kernel/qcoreapplication.cpp:591
#41 0xb755b469 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x80f3380)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 0xb755b68d in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0) at kernel/qcoreapplication.cpp:1095
#43 0xb758562f in postEventSourceDispatch (s=0x810ff10)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 0xb622ecc6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb6232083 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb623263e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb75859f8 in QEventDispatcherGlib::processEvents (this=0x810d8d8, 
    flags=@0xbff2a388) at kernel/qeventdispatcher_glib.cpp:325
#48 0xb6cb4a25 in QGuiEventDispatcherGlib::processEvents (this=0x810d8d8, 
    flags=@0xbff2a3b8) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb755933d in QEventLoop::processEvents (this=0xbff2a430, 
    flags=@0xbff2a3f4) at kernel/qeventloop.cpp:149
#50 0xb75594cd in QEventLoop::exec (this=0xbff2a430, flags=@0xbff2a438)
    at kernel/qeventloop.cpp:200
#51 0xb755b74d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:849
#52 0xb6c20897 in QApplication::exec () at kernel/qapplication.cpp:3330
#53 0x08067aea in _start ()
#0  0xb7fad410 in __kernel_vsyscall ()
Comment 1 Dario Andres 2008-12-06 22:21:48 UTC
This is probably a duplicate of bug 172198 (similar backtrace). Bug fixed in KTorrent 3.1.5
Comment 2 Joris Guisson 2008-12-07 10:27:10 UTC
Yes this is a dupe of 172198

*** This bug has been marked as a duplicate of bug 172198 ***