Bug 177070 - Konqueror webpage crash: nrkbeta.no
Summary: Konqueror webpage crash: nrkbeta.no
Status: RESOLVED DUPLICATE of bug 162564
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: 4.1.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-06 16:54 UTC by Andreas Nordal
Modified: 2009-02-11 01:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Nordal 2008-12-06 16:54:07 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    Fedora RPMs

Konqueror 4.1.3 crashes when visiting http://nrkbeta.no

Konqueror have never had trouble with this site before. Now, the crash is 100% reproducible.
When started from terminal, Konqueror stdouts:
Object::connect: No such signal DolphinView::redirection(KUrl,KUrl)
KCrash: Application 'konqueror' crashing...

In case the page changes (which it will), here is a snapshot of it:
http://nerdvar.com/saker/nrkbeta_6des2008.tar.gz
Comment 1 Dario Andres 2008-12-06 22:28:27 UTC
I can confirm this bug here using:
Qt: 4.4.3
KDE: 4.1.3 (KDE 4.1.3)
Konqueror: 4.1.3 (KDE 4.1.3)
on ArchLinux x86_64

Backtrace:

Aplicación: Konqueror (konqueror), señal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0x7fdc5b1d9750 (LWP 5817)]
[New Thread 0x42743950 (LWP 5862)]
[KCrash handler]
#5  0x00007fdc4c7e483f in khtml::InlineFlowBox::deleteLine (this=0x30716d0, 
    arena=0x10b6540)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_line.cpp:209
#6  0x00007fdc4c770dd6 in khtml::RenderBlock::determineStartPosition (
    this=0x2e69bf8, fullLayout=<value optimized out>, start=@0x7fff63316150, 
    bidi=@0x7fff63316030)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/bidi.cpp:1733
#7  0x00007fdc4c771fc2 in khtml::RenderBlock::layoutInlineChildren (
    this=0x2e69bf8, relayoutChildren=true, breakBeforeLine=0)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/bidi.cpp:1467
#8  0x00007fdc4c77d75d in khtml::RenderBlock::layoutBlock (this=0x2e69bf8, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:782
#9  0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x2e61e88, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#10 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x2e61e88, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#11 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x2e61700, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#12 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x2e61700, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#13 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x2e398f0, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#14 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x2e398f0, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#15 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x2537a48, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#16 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x2537a48, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#17 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x2537980, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#18 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x2537980, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#19 0x00007fdc4c771aea in khtml::RenderBlock::layoutInlineChildren (
    this=0x10f2e50, relayoutChildren=true, breakBeforeLine=0)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/bidi.cpp:1438
#20 0x00007fdc4c77d75d in khtml::RenderBlock::layoutBlock (this=0x10f2e50, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:782
#21 0x00007fdc4c779a28 in khtml::RenderBlock::insertFloatingObject (
    this=0x10f1558, o=0x10f2e50)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1861
#22 0x00007fdc4c77ad1f in khtml::RenderBlock::handleFloatingChild (
    this=0x10f1558, child=0x10f2e50, marginInfo=@0x7fff63317480, 
    handled=@0x7fff633174ef)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:947
#23 0x00007fdc4c77cad1 in khtml::RenderBlock::handleSpecialChild (
    this=0x10f1558, child=0x10f2e50, marginInfo=@0x7fff63317480, 
    compactInfo=@0x7fff63317460, handled=@0x7fff633174ef)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:920
#24 0x00007fdc4c77cd15 in khtml::RenderBlock::layoutBlockChildren (
    this=0x10f1558, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1476
#25 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x10f1558, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#26 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x10f13e0, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#27 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x10f13e0, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#28 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x10f1318, relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#29 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x10f1318, 
    relayoutChildren=true)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#30 0x00007fdc4c7de383 in khtml::RenderBody::layout (this=0x10f1318)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_body.cpp:91
#31 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x10f11a0, relayoutChildren=false)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#32 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x10f11a0, 
    relayoutChildren=false)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#33 0x00007fdc4c77cece in khtml::RenderBlock::layoutBlockChildren (
    this=0x10f0fb0, relayoutChildren=false)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:1505
#34 0x00007fdc4c77d458 in khtml::RenderBlock::layoutBlock (this=0x10f0fb0, 
    relayoutChildren=false)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_block.cpp:784
#35 0x00007fdc4c7da0f2 in khtml::RenderCanvas::layout (this=0x10f0fb0)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/rendering/render_canvas.cpp:187
#36 0x00007fdc4c683ab6 in KHTMLView::layout (this=0xf111d0)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/khtmlview.cpp:1055
#37 0x00007fdc4c6841fe in KHTMLView::timerEvent (this=0xf111d0, 
    e=<value optimized out>)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/khtmlview.cpp:4183
#38 0x00007fdc57fc3cb3 in QObject::event () from /usr/lib/libQtCore.so.4
#39 0x00007fdc56f8bb0c in QWidget::event () from /usr/lib/libQtGui.so.4
#40 0x00007fdc572c09f9 in QAbstractScrollArea::event ()
   from /usr/lib/libQtGui.so.4
#41 0x00007fdc4c681ec2 in KHTMLView::event (this=0xf111d0, e=0x7fff63318b10)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/khtml/khtmlview.cpp:586
#42 0x00007fdc56f3f4dd in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#43 0x00007fdc56f4586a in QApplication::notify () from /usr/lib/libQtGui.so.4
#44 0x00007fdc59f270d1 in KApplication::notify (this=0x7fff63319030, 
    receiver=0xf111d0, event=0x7fff63318b10)
    at /home/dario/Build/ABS/kdelibs/src/kdelibs-4.1.3/kdeui/kernel/kapplication.cpp:311
#45 0x00007fdc57fb63d1 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#46 0x00007fdc57fdde56 in ?? () from /usr/lib/libQtCore.so.4
#47 0x00007fdc57fda93d in ?? () from /usr/lib/libQtCore.so.4
#48 0x00007fdc53613aa2 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#49 0x00007fdc5361721d in g_main_context_iterate ()
   from /usr/lib/libglib-2.0.so.0
#50 0x00007fdc536173db in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#51 0x00007fdc57fda89f in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#52 0x00007fdc56fbffff in ?? () from /usr/lib/libQtGui.so.4
#53 0x00007fdc57fb4d42 in QEventLoop::processEvents ()
   from /usr/lib/libQtCore.so.4
#54 0x00007fdc57fb4ed5 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#55 0x00007fdc57fb7025 in QCoreApplication::exec ()
   from /usr/lib/libQtCore.so.4
#56 0x00007fdc5aec4a0a in kdemain (argc=<value optimized out>, 
    argv=<value optimized out>)
    at /home/dario/Build/ABS/kdebase/src/kdebase-4.1.3/apps/konqueror/src/konqmain.cpp:227
#57 0x00007fdc549f83f6 in __libc_start_main () from /lib/libc.so.6
#58 0x0000000000400849 in _start ()
#0  0x00007fdc54a78ed1 in nanosleep () from /lib/libc.so.6
Comment 2 FiNeX 2008-12-07 14:17:52 UTC
I'm using current trunk and konqueror doesn't crash (r893729). Can you try KDE 4.2 beta1 and test it?
Comment 3 Dario Andres 2008-12-07 17:29:05 UTC
When using current trunk 

Qt: 4.4.3
KDE: 4.1.82 (KDE 4.1.82 (KDE 4.2 >= 20081204))
KWrite: 4.1.82 (KDE 4.1.82 (KDE 4.2 >= 20081204))
kdelibs svn rev.893007
kdebase svn rev.893019

I can't reproduce it either :)
Comment 4 Frank Reininghaus 2008-12-07 18:14:38 UTC
I can confirm the crash in 4.1.3 (Kubuntu), but not in trunk rev. 893016.                                                                                                             I don't actually think testing 4.2 beta 1 would help much. It would be more interesting to know if it's also fixed in the 4.1 branch or not.

Note that bug 162564, bug 165158, bug 171104 look related. I can't test the Gmail crashes because Gmail works neither in 4.1.3 nor in trunk with a Firefox UA, see https://bugs.kde.org/show_bug.cgi?id=165158#c9
Comment 5 Andreas Nordal 2009-01-12 13:26:12 UTC
Konqueror 3.5.8 (32-bit Kubuntu 7.10) did not crash after opening the testcase.
Comment 6 FiNeX 2009-01-12 14:02:12 UTC
I agree, this should be a dup of bug #162564.

*** This bug has been marked as a duplicate of bug 162564 ***
Comment 7 FiNeX 2009-01-12 14:02:28 UTC
I agree, this could be a dup of bug #162564.
Comment 8 FiNeX 2009-02-01 00:38:41 UTC

*** This bug has been marked as a duplicate of bug 162564 ***
Comment 9 Andreas Nordal 2009-02-11 01:04:57 UTC
More non-crash data:
Konqueror 4.2.0 did not crash.
Konqueror 3.5.10 did not crash.
Both using openSUSE 11.1 x86_64.

I too consider the bug solved.