Bug 176772 - kmail crashes when printing an embedded email
Summary: kmail crashes when printing an embedded email
Status: RESOLVED DUPLICATE of bug 264985
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.1.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-03 09:31 UTC by Peter Fischer
Modified: 2011-02-06 17:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fischer 2008-12-03 09:31:25 UTC
Version:            (using KDE 4.1.3)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Ubuntu Packages

The situation is reproducible: I try to print an email to which another email is attached. If I do so kmail crashes. Printing pdf-files attached to this embedded email is possible.
The backtrace is as follows:

Anwendung: KMail (kmail), Signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb41f26c0 (LWP 14218)]
[New Thread 0xb03ffb90 (LWP 14224)]
[New Thread 0xb0d29b90 (LWP 14223)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb5ee0044 in ?? () from /usr/lib/libkhtml.so.5
#7  0xb5ee0705 in ?? () from /usr/lib/libkhtml.so.5
#8  0xb5ee0c2c in ?? () from /usr/lib/libkhtml.so.5
#9  0xb5f3aa78 in ?? () from /usr/lib/libkhtml.so.5
#10 0xb5da469d in KHTMLView::print () from /usr/lib/libkhtml.so.5
#11 0xb760331b in ?? () from /usr/lib/libkmailprivate.so.4
#12 0xb76169f6 in ?? () from /usr/lib/libkmailprivate.so.4
#13 0xb7f0ba60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#14 0xb7f0c7e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#15 0xb77a05e7 in ?? () from /usr/lib/libkmailprivate.so.4
#16 0xb77a1df7 in ?? () from /usr/lib/libkmailprivate.so.4
#17 0xb77a0c1f in ?? () from /usr/lib/libkmailprivate.so.4
#18 0xb77a0cad in ?? () from /usr/lib/libkmailprivate.so.4
#19 0xb7f0ba60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb7f0c7e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb7f467a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#22 0xb7f1240e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#23 0xb7f0653f in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb67e58ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0xb67ed72e in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb717cb2d in KApplication::notify () from /usr/lib/libkdeui.so.5
#27 0xb7ef6e61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0xb7f24d81 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb7f21520 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb63ab6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb63aeda3 in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb63aef61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb7f21478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb687fea5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb7ef552a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7ef56ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb7ef7da5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb67e5767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x0804a6c0 in _start ()
#0  0xb8010430 in __kernel_vsyscall ()
Comment 1 Jaime Torres 2008-12-03 12:59:06 UTC
If you can reproduce the crash, you should install the debug enabled packages and provide a new backtrace. Read this page for the instructions: http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports 
Thanks! 
Comment 2 Jaime Torres 2008-12-03 19:29:10 UTC
pasting info sent by mail.

Jaime,
I can reproduce it as often as I want. Therefore I have attached two backtrace files with more debugging information.
Regards,
Peter Fischer

Anwendung: KMail (kmail), Signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0xb42496c0 (LWP 4517)]
[New Thread 0xaf4ddb90 (LWP 5124)]
[New Thread 0xafcdeb90 (LWP 5123)]
[New Thread 0xb04dfb90 (LWP 4527)]
[KCrash handler]
#6  khtml::RenderBlock::clearChildOfPageBreaks (this=0x94d7c78, 
    child=0x94d7dbc, pageBreakInfo=@0xbfa67cb0, marginInfo=@0xbfa67ca4)
    at /build/buildd/kde4libs-4.1.3/khtml/rendering/render_block.cpp:1598
#7  0xb5f37705 in khtml::RenderBlock::layoutBlockChildren (this=0x94d7c78, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.3/khtml/rendering/render_block.cpp:1535
#8  0xb5f37c2c in khtml::RenderBlock::layoutBlock (this=0x94d7c78, 
    relayoutChildren=true)
    at /build/buildd/kde4libs-4.1.3/khtml/rendering/render_block.cpp:784
#9  0xb5f91a78 in khtml::RenderCanvas::layout (this=0x94d7c78)
    at /build/buildd/kde4libs-4.1.3/khtml/rendering/render_canvas.cpp:187
#10 0xb5dfb69d in KHTMLView::print (this=0x9a16a08, quick=false)
    at /build/buildd/kde4libs-4.1.3/khtml/rendering/render_object.h:455
#11 0xb765a31b in KMReaderWin::slotPrintMsg (this=0x9ad6130)
    at /build/buildd/kdepim-4.1.3/kmail/kmreaderwin.cpp:1756
#12 0xb766d9f6 in KMReaderWin::qt_metacall (this=0x9ad6130, 
    _c=QMetaObject::InvokeMetaMethod, _id=53, _a=0xbfa68178)
    at /build/buildd/kdepim-4.1.3/obj-i486-linux-gnu/kmail/kmreaderwin.moc:209
#13 0xb7f62a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#14 0xb7f637e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#15 0xb77f75e7 in KMail::KHtmlPartHtmlWriter::finished (this=0x9d1c120)
    at /build/buildd/kdepim-4.1.3/obj-i486-linux-gnu/kmail/khtmlparthtmlwriter.moc:82
#16 0xb77f8df7 in KMail::KHtmlPartHtmlWriter::end (this=0x9d1c120)
    at /build/buildd/kdepim-4.1.3/kmail/khtmlparthtmlwriter.cpp:93
#17 0xb77f7c1f in KMail::KHtmlPartHtmlWriter::slotWriteNextHtmlChunk (
    this=0x9d1c120)
    at /build/buildd/kdepim-4.1.3/kmail/khtmlparthtmlwriter.cpp:125
#18 0xb77f7cad in KMail::KHtmlPartHtmlWriter::qt_metacall (this=0x9d1c120, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfa68318)
    at /build/buildd/kdepim-4.1.3/obj-i486-linux-gnu/kmail/khtmlparthtmlwriter.moc:72
#19 0xb7f62a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb7f637e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb7f9d7a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#22 0xb7f6940e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#23 0xb7f5d53f in QObject::event () from /usr/lib/libQtCore.so.4
#24 0xb683c8ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0xb684472e in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0xb71d3b2d in KApplication::notify (this=0xbfa68ac8, receiver=0x9d1c134, 
    event=0xbfa687ac)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#27 0xb7f4de61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0xb7f7bd81 in ?? () from /usr/lib/libQtCore.so.4
#29 0xb7f78520 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb64026f8 in IA__g_main_context_dispatch (context=0x89d0498)
    at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2144
#31 0xb6405da3 in g_main_context_iterate (context=0x89d0498, block=1, 
    dispatch=1, self=0x89cd198)
    at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2778
#32 0xb6405f61 in IA__g_main_context_iteration (context=0x89d0498, 
    may_block=1) at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2841
#33 0xb7f78478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#34 0xb68d6ea5 in ?? () from /usr/lib/libQtGui.so.4
#35 0xb7f4c52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#36 0xb7f4c6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#37 0xb7f4eda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#38 0xb683c767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#39 0x0804a6c0 in main (argc=-1239496152, argv=0x9f4cf40)
    at /build/buildd/kdepim-4.1.3/kmail/main.cpp:146
#0  0xb8067430 in __kernel_vsyscall ()

Comment 3 Thomas McGuire 2008-12-05 17:12:17 UTC
Seems to be a KHTML problem, reassigning.
Comment 4 Frank Reininghaus 2008-12-05 22:41:18 UTC
Looks related to bug 163840, but that one could not be reproduced in 4.1.3 according to a comment.
Comment 5 Björn Ruberg 2010-02-02 18:52:43 UTC
Can this still be reproduced?
Comment 6 Peter Fischer 2010-02-04 10:29:00 UTC
Björn,

no not at the moment, but the environment had changed. I am still using KMail 
but with KDE Version 4.3.5 and Kubuntu Version 2.6.31-18. It seems that I have 
a similar problem on one of my laptops with network-manager but I had no time 
to look at it more detailled at the moment.

Regards,

Peter Fischer



###########################################
 Prof. Dr. Peter Fischer
 Fachhochschule Dortmund                 
 University of Applied Sciences and Arts 
 FB Informations- und Elektrotechnik     
 Sonnenstrasse 96                        
 44139 Dortmund                          
 Germany                                 
-----------------------------------------
 Tel: +49-(0)231-91 12-290               
 Fax: +49-(0)231-91 12-619               
 email: fischer@fh-dortmund.de           
 Tel: +49-(0)231-65 68 34                
 Fax: +49-(0)231-65 68 36                
###########################################


Am Dienstag 02 Februar 2010 18:52:46 schrieb Björn Ruberg:
> https://bugs.kde.org/show_bug.cgi?id=176772
> 
> 
> Björn Ruberg <bjoern@ruberg-wegener.de> changed:
> 
>            What    |Removed                     |Added
> ---------------------------------------------------------------------------
> - CC|                            |bjoern@ruberg-wegener.de
> 
> 
> 
> 
> --- Comment #5 from Björn Ruberg <bjoern ruberg-wegener de>  2010-02-02
>  18:52:43 --- Can this still be reproduced?
>
Comment 7 Maksim Orlovich 2011-02-06 17:11:24 UTC

*** This bug has been marked as a duplicate of bug 264985 ***