Bug 176486 - Failure when opening a SMB folder
Summary: Failure when opening a SMB folder
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smb (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-29 21:45 UTC by Lukas Jelinek
Modified: 2009-02-05 22:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jelinek 2008-11-29 21:45:42 UTC
Version:           4.1.3 (KDE 4.1.3) "release 55.1" (using 4.1.3 (KDE 4.1.3) "release 55.1", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.18-0.2-pae

When I try open some SMB folders (on remote machines running Windows XP) Konqueror fails to open them and reports "The process for the smb://machine protocol died unexpectedly." Many other SMB folders can be opened without any problem. Furthermore, the failed folder can be opened through smbclient, "mount -t cifs ..." and other ways as well. The problem is probably caused by non-ASCII characters inside file names - when creating (on SMB via Konqueror) a file having non-ASCII characters inside its name it fails but creating a file having only ASCII characters succeeds.
Comment 1 Dario Andres 2009-02-05 21:52:54 UTC
This should be fixed on KDE 4.2. So please try when you have the packages available.
Comment 2 Tommi Tervo 2009-02-05 22:10:34 UTC

*** This bug has been marked as a duplicate of bug 158639 ***