Bug 176214 - some emails blank, not possible to delete, but copy is right
Summary: some emails blank, not possible to delete, but copy is right
Status: RESOLVED DUPLICATE of bug 121272
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.9
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-27 07:16 UTC by Konstantin
Modified: 2010-02-02 01:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin 2008-11-27 07:16:21 UTC
Version:           1.9.9 (using 3.5.9, Debian Package 4:3.5.9.dfsg.1-6 (lenny/sid))
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.26-2.slh.2-sidux-amd64

about 1% of my email got blank content. I can see the subject, the sender, the time, but no content.

I can not answer that email, the answer button is inactiv. 
There is no sourcecode to look at.
I can not delete that email. It only shows a horizontal line over the subject and so on. But after clicking other mails in other folders and coming back the mail is there again.

If I copy that mail in another folder everything is there: The copy has the contant, I can answer the mail, the sourcecode is back..
Even if I copy (ore move) that copy into the original folder the copy workes, but I cant delete the broken-blank-email which stays there for ever?

I can not reproduce this bug. Some emails arrive with this problem, others change to that problem on writing an answer.
Comment 1 Jaime Torres 2008-12-02 16:54:38 UTC
I'm 80% sure this bug is a copy of bug 121272
Comment 2 Konstantin 2008-12-08 21:31:11 UTC
I found some info which might help:
I made a copy of a bad mail in contact. The copy shows right in all the functions.
Than I compared the files which are in
/.kde/share/apps/kmail/mail/inbox/cur/

There are only very less differences in the two mails:
It's in line 38 and 39:

The bad mail has there:
Status: R
X-Status: NT

the good functioning mailcopy has this:
Status: RO
X-Status: VAT

In other good working mails I do also find:
Status: R
X-Status: NC

which workes.

So why does sometimes changes the Status and X-Status?
Comment 3 Björn Ruberg 2010-02-02 01:31:29 UTC

*** This bug has been marked as a duplicate of bug 121272 ***