Bug 175981 - Random crash KMail / IMAP
Summary: Random crash KMail / IMAP
Status: RESOLVED DUPLICATE of bug 175584
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-24 14:21 UTC by Simon
Modified: 2009-03-19 00:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon 2008-11-24 14:21:40 UTC
Version:            (using KDE 4.1.3)
Compiler:          gcc (Gentoo 4.3.2 p1.0) 4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

I experience reandom crash with kmail while doing nothing (I can leave the computer an find a crashed kmail when I come back).

I seems an loop is iterating after the end of a QVector

Console messages :

kmail(17143) KMail::PopAccount::slotJobFinished: stage == Quit
kmail(17143) KMail::PopAccount::saveUidList:
kmail(17143)/kio (KIOJob) KIO::Job::doKill: this= KIO::TransferJob(0x9fddcb0) KIO::TransferJob
kmail(17143) KMail::NetworkAccount::setCheckingMail: connections to server "81.91.64.63" now 0
kmail(17143) KMail::AccountManager::processNextCheck: processNextCheck, remaining 0
kmail(17143) KMail::AccountManager::processNextCheck: account "Cythos"  finished check
kmail(17143)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  114   "pop.tele2.fr: Unknown error"
kmail(17143) KMail::PopAccount::processRemainingQueuedMessages:
kmail(17143) KMail::PopAccount::saveUidList:
kmail(17143) KMail::PopAccount::slotJobFinished: stage == Quit
kmail(17143) KMail::PopAccount::saveUidList:
kmail(17143)/kio (KIOJob) KIO::Job::doKill: this= KIO::TransferJob(0xa093388) KIO::TransferJob
kmail(17143) KMail::NetworkAccount::setCheckingMail: connections to server "pop.tele2.fr" now 0
kmail(17143) KMail::AccountManager::processNextCheck: processNextCheck, remaining 0
kmail(17143) KMail::AccountManager::processNextCheck: account "Tele2"  finished check
kmail(17143) KMFolderImap::slotCheckValidityResult: Of: "INBOX"
kmail(17143) KMFolderImap::reallyGetFolder: ""
kmail(17143) KMFolderImap::reallyGetFolder: listDir KUrl("imap://me@imap.myserver.net:143/INBOX/;SECTION=UID FLAGS") KIO::ListJob(0xa6f2780)
kmail(17143) KMFolderImap::slotListFolderResult: KIO::ListJob(0xa6f2780) 0
kmail(17143) KMFolderImap::slotListFolderResult: "INBOX"  download KUrl("imap://me@imap.myserver.net:143/INBOX/;UID=3130:3130;SECTION=ENVELOPE")
kmail(17143) KMFolderImap::getMessagesResult: KIO::TransferJob(0x98aae38) 0 true
kmail(17143) KMFolderImap::finishMailCheck: "INBOX"  finishMailCheck getMessage 3
kmail(17143) KMail::NetworkAccount::setCheckingMail: connections to server "imap.laposte.net" now 0
kmail(17143) KMail::AccountManager::processNextCheck: processNextCheck, remaining 0
kmail(17143) KMail::AccountManager::processNextCheck: account "La Poste"  finished check
kmail(17143) KMail::ImapJob::slotGetMessageResult: Retrieved part ""
kmail(17143) KMFolderImap::slotCheckValidityResult: Of: "INBOX"
kmail(17143) KMFolderImap::reallyGetFolder: ""
kmail(17143) KMFolderImap::reallyGetFolder: listDir KUrl("imap://me@imap.myserver.fr:143/INBOX/;SECTION=UID FLAGS") KIO::ListJob(0xa1032b8)
kmail(17143)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  111   "INBOX.Envoy�s"
kmail(17143) KMFolderImap::slotListNamespaces:
kmail(17143) KMFolderImap::slotListFolderResult: KIO::ListJob(0xa1032b8) 0
kmail(17143) KMFolderImap::slotListFolderResult: "INBOX"  download KUrl("imap://me@imap.myserver.fr:143/INBOX/;UID=28231:28236;SECTION=ENVELOPE")
kmail(17143) KMail::ImapJob::slotGetMessageResult: Retrieved part ""
ASSERT failure in QVector<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qvector.h, line 331
*** KMail got signal 6 (Crashing)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kmail path = <unknown> pid = 17143
sock_file=/home/simon/.kde4/socket-yoda/kdeinit4__0


----

Backtrace :

Application : KMail (kmail), signal SIGABRT
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb488d6d0 (LWP 17143)]
[New Thread 0xb177cb90 (LWP 17369)]
[KCrash handler]
#6  0xb8038424 in __kernel_vsyscall ()
#7  0xb67ab45e in raise () from /lib/libc.so.6
#8  0xb68dfff4 in ?? () from /lib/libc.so.6
#9  0xbf854820 in ?? ()
#10 0xb67acfa8 in abort () from /lib/libc.so.6
#11 0xb68dfff4 in ?? () from /lib/libc.so.6
#12 0xbf8547c8 in ?? ()
#13 0xb67ef983 in ?? () from /lib/libc.so.6
#14 0xbf8547bc in ?? ()
#15 0xbf854880 in ?? ()
#16 0xbf85687e in ?? ()
#17 0xb67bffcb in vfprintf () from /lib/libc.so.6
#18 0xb7e521ee in qFatal () from /usr/lib/qt4/libQtCore.so.4
#19 0xb7e5223d in qt_assert_x () from /usr/lib/qt4/libQtCore.so.4
#20 0xb78dee93 in QVector<KMMsgBase*>::operator[] (this=0x9824040, i=-1)
    at /usr/include/qt4/QtCore/qvector.h:331
#21 0xb7910250 in KMFolderImap::take (this=0x9823ff0, idx=-1)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/kmfolderimap.cpp:603
#22 0xb7864621 in KMFolder::take (this=0x97e67c0, idx=-1)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/kmfolder.cpp:404
#23 0xb78ac7d4 in KMFilterMgr::endFiltering (this=0x985aff8, 
    msgBase=0xa0a4e20)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/kmfiltermgr.cpp:132
#24 0xb78ad069 in KMFilterMgr::process (this=0x985aff8, msg=0xa0a4e20, 
    set=KMFilterMgr::Inbound, account=true, accountId=1056523421)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/kmfiltermgr.cpp:258
#25 0xb78f3a82 in KMAcctImap::slotFilterMsg (this=0x9849d88, msg=0xa0a4e20)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/kmacctimap.cpp:604
#26 0xb78f4e78 in KMAcctImap::qt_metacall (this=0x9849d88, 
    _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf856b00)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail_build/kmail/kmacctimap.moc:88
#27 0xb7f630e5 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#28 0xb7f650a9 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#29 0xb7a06986 in KMail::FolderJob::messageRetrieved (this=0xa366bb0, 
    _t1=0xa0a4e20)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail_build/kmail/folderjob.moc:97
#30 0xb7a0f810 in KMail::ImapJob::slotGetMessageResult (this=0xa366bb0, 
    job=0x9fc4b80)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail-4.1.3/kmail/imapjob.cpp:460
#31 0xb7a1027e in KMail::ImapJob::qt_metacall (this=0xa366bb0, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf856c90)
    at /var/tmp/portage_tmpfs/portage/kde-base/kmail-4.1.3/work/kmail_build/kmail/imapjob.moc:81
#32 0xb7f630e5 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#33 0xb7f650a9 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#34 0xb7d1ccfc in KJob::result (this=0x9fc4b80, _t1=0x9fc4b80)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kdecore/kjob.moc:186
#35 0xb7d1d171 in KJob::emitResult (this=0x9fc4b80)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kdecore/jobs/kjob.cpp:290
#36 0xb5882edb in KIO::SimpleJob::slotFinished (this=0x9fc4b80)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/job.cpp:498
#37 0xb5883283 in KIO::TransferJob::slotFinished (this=0x9fc4b80)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/job.cpp:967
#38 0xb588964f in KIO::TransferJob::qt_metacall (this=0x9fc4b80, 
    _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbf856ed8)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kio/jobclasses.moc:336
#39 0xb7f630e5 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#40 0xb7f650a9 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#41 0xb591a46e in KIO::SlaveInterface::finished (this=0x9fe1ba0)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kio/slaveinterface.moc:161
#42 0xb591c02a in KIO::SlaveInterface::dispatch (this=0x9fe1ba0, _cmd=104, 
    rawdata=@0xbf857034)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/slaveinterface.cpp:175
#43 0xb591ca31 in KIO::SlaveInterface::dispatch (this=0x9fe1ba0)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/slaveinterface.cpp:90
#44 0xb59103b2 in KIO::Slave::gotInput (this=0x9fe1ba0)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/slave.cpp:322
#45 0xb591164a in KIO::Slave::qt_metacall (this=0x9fe1ba0, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf857158)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kio/slave.moc:75
#46 0xb7f630e5 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#47 0xb7f650a9 in QMetaObject::activate () from /usr/lib/qt4/libQtCore.so.4
#48 0xb5858e50 in KIO::Connection::readyRead (this=0x9fde028)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kio/connection.moc:84
#49 0xb5859a69 in KIO::ConnectionPrivate::dequeue (this=0x97e6608)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kio/kio/connection.cpp:82
#50 0xb585a95d in KIO::Connection::qt_metacall (this=0x9fde028, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xa41af70)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs_build/kio/connection.moc:72
#51 0xb7f5b41d in QMetaCallEvent::placeMetaCall ()
   from /usr/lib/qt4/libQtCore.so.4
#52 0xb7f5ccad in QObject::event () from /usr/lib/qt4/libQtCore.so.4
#53 0xb6b14a4b in QApplicationPrivate::notify_helper ()
   from /usr/lib/qt4/libQtGui.so.4
#54 0xb6b1c3e7 in QApplication::notify () from /usr/lib/qt4/libQtGui.so.4
#55 0xb7479e5b in KApplication::notify (this=0xbf857968, receiver=0x9fde028, 
    event=0xa419158)
    at /var/tmp/portage/kde-base/kdelibs-4.1.3-r1/work/kdelibs-4.1.3/kdeui/kernel/kapplication.cpp:311
#56 0xb7f4ceca in QCoreApplication::notifyInternal ()
   from /usr/lib/qt4/libQtCore.so.4
#57 0xb7f4ddb9 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/qt4/libQtCore.so.4
#58 0xb7f4e026 in QCoreApplication::sendPostedEvents ()
   from /usr/lib/qt4/libQtCore.so.4
#59 0xb7f7818b in ?? () from /usr/lib/qt4/libQtCore.so.4
#60 0xb66c24f7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#0  0xb8038424 in __kernel_vsyscall ()
Comment 1 Jaime Torres 2008-11-26 12:51:24 UTC
I'm not sure, but this looks like a dup of bug 175584
Comment 2 Simon 2008-11-26 17:19:44 UTC
Yes, after a look on both backtrace, it seems it is a dup.

Note that it no more happens to me. I think it disapear when I removed some mails in which there was one with weird characters in its subject (utf8/iso). I don't know if it is related.

In both bug, the crash seems to happen when filters are applied (ok, it is obvious when looking in the backtrace).
Comment 3 Thomas McGuire 2008-11-27 17:31:36 UTC

*** This bug has been marked as a duplicate of bug 175584 ***