Bug 175736 - play(-button) does not work if song did not exist the first time play was pressed
Summary: play(-button) does not work if song did not exist the first time play was pre...
Status: RESOLVED DUPLICATE of bug 171213
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.0-SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-21 09:24 UTC by S. Burmeister
Modified: 2009-04-16 13:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2008-11-21 09:24:12 UTC
Version:           2.0-SVN (using Devel)
OS:                Linux
Installed from:    Compiled sources

If you have your music on an external harddisk and that harddisk is not mounted when you click on play (having songs off that harddisk in the playlist, e.g. from the last session) nothing happens. Neither does amarok play the song nor does it notify you as to why this is not possible.

Now mount the harddisk and click on Play again, nothing happens.

Double-clicking a song does play it.

Using the play/pause hotkey pauses, but does not resume.
Comment 1 Mark Kretschmann 2008-11-21 12:17:28 UTC
But if you reload the tracks into the playlist, it works correctly I assume?
Comment 2 S. Burmeister 2008-11-21 16:12:27 UTC
I don't think it would change anything about this being a bug, since re-adding every single song would be annoying tot he user and just a crude workaround.

Apart from that, you assumed wrong.

Clearing the playlist mounting the harddrive and dropping a song from the collection to the playlist does not play the song if the play button is clicked again.
Comment 3 Gary Steinert 2009-01-28 20:18:54 UTC
@Mark I think the problem relates to the fact that once a path has been recognised as invlaid, repeated attempts to play (using the play button) will always fail, whether the file has appeared or not (i.e. mounting the drive)
Comment 4 Gary Steinert 2009-01-29 11:31:13 UTC
I cannot seem to reproduce this bug. I have been unable to test with mounting drives (as I have no mountable drives) but there seemed to be no problem when I renamed files and renamed them back after trying to play them.

Leaving this bug open until someone can check with mounting drives.

Gary
Comment 5 Myriam Schweingruber 2009-01-30 22:39:01 UTC
Well, I can reproduce that bug all the time. This happened to me several times because I forgot to mount the external HD with my collection (unfortunately, automount has gone in Kubuntu Intrepid) and a message stating that the selected track is not available (or that a necessary device is not mounted) would be very useful.
Comment 6 Mark Kretschmann 2009-04-16 13:42:44 UTC

*** This bug has been marked as a duplicate of bug 171213 ***