Bug 175353 - auto sleep doesn't work and uses CPU on 100%
Summary: auto sleep doesn't work and uses CPU on 100%
Status: RESOLVED DUPLICATE of bug 176932
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-daemon (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-16 23:21 UTC by Michal
Modified: 2010-10-02 12:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal 2008-11-16 23:21:53 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

All the options for inactivity doesn't work. Instead of sleep or lock the screen, X sever start to use CPU on 100% until I move mouse.
I don't know where can be the problem but kpowersave works without problem. This bug is not connected only to powerdevil, the same problem I have with guidance power manager. It doesn't work even with clean configuration. And sleeping when I click manualy on button works. 
I use xorg-server-1.5.2 and hal-0.5.11-r4, system gentoo.
Comment 1 Dario Freddi 2008-11-24 20:45:27 UTC
Please run kded4 from command line and paste its output here when this situation happens.
Comment 2 Michal 2008-11-24 20:59:37 UTC
When I run the kded4 the output is:

  X Error: XSyncBadAlarm 129
  Extension:    131 (Uknown extension)
  Minor opcode: 11 (Unknown request)
  Resource id:  0x0

3 times

but it appears only when I start it, later when the X start to use the CPU it not write anything, also in .xsession-errors is nothing
Comment 3 Michal 2008-11-24 22:18:45 UTC
When I recompiled kdebase with debugfull, I get this

X Error: XSyncBadAlarm 129                                                                                     
  Extension:    131 (Uknown extension)                                                                         
  Minor opcode: 11 (Unknown request)                                                                           
  Resource id:  0x0             
                                                                               
kded(19057) PowerDevilDaemon::poll: Polling started, idle time is 0 seconds                                    
kded(19057) PowerDevilDaemon::poll: Stopping timer           

nothing more, I have tested it on 2 more notebook, always the same problem, 
Comment 4 Michal 2008-12-07 16:08:29 UTC
Now it works a bit better, the function Lock Screen after some time work ok, but other still doesn't. There is not the problem with CPU usage of X-server. When it should be suspended, there appears the plasma notification about suspending in 30s and that is all, it is not doing anything.  A few second after the notification the kded4 writes

kded(1139) SuspensionLockHandler::releaseNotificationLock: Releasing notification lock
kded(1139) PowerDevilDaemon::cleanUpTimer: Disconnecting signals
Comment 5 Dario Freddi 2008-12-07 17:17:43 UTC
This is a bug in Plasma notification style. Your bug was a duplicate of the X hogging one, hence is solved.

*** This bug has been marked as a duplicate of bug 176932 ***