Bug 174923 - Kompare crash while closing the application
Summary: Kompare crash while closing the application
Status: RESOLVED DUPLICATE of bug 165421
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-12 06:38 UTC by E. Kastelijn
Modified: 2009-01-23 18:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description E. Kastelijn 2008-11-12 06:38:18 UTC
Version:           kdesdk-4.1.2-3.fc9.x86_64 (using KDE 4.1.2)
OS:                Linux
Installed from:    Fedora RPMs

Application: Kompare (kompare), signal SIGSEGV
(no debugging symbols found)                  
(no debugging symbols found)                  
(no debugging symbols found)                  
(no debugging symbols found)                  
[Thread debugging using libthread_db enabled] 
[New Thread 0x7f59ad56c800 (LWP 6669)]        
[New Thread 0x42472950 (LWP 6671)]            
[KCrash handler]                              
#5  0x0000003957e0fb08 in QX11Info::screen (this=<value optimized out>)
    at kernel/qx11info_x11.cpp:471                                     
#6  0x0000003957e0776d in QWidgetPrivate::create_sys (                 
    this=<value optimized out>, window=<value optimized out>,          
    initializeWindow=<value optimized out>,                            
    destroyOldWindow=<value optimized out>) at kernel/qwidget_x11.cpp:466
#7  0x0000003957dd2a52 in QWidget::create (this=<value optimized out>,   
    window=<value optimized out>, initializeWindow=<value optimized out>, 
    destroyOldWindow=<value optimized out>) at kernel/qwidget.cpp:1236    
#8  0x0000003957dd326f in QWidget::winId (this=<value optimized out>)     
    at kernel/qwidget.cpp:1977                                            
#9  0x0000003958d6b895 in KIO::SchedulerPrivate::registerWindow (         
    this=<value optimized out>, wid=<value optimized out>)                
    at /usr/src/debug/kdelibs-4.1.2/kio/kio/scheduler.cpp:1019            
#10 0x0000003958d71794 in KIO::Scheduler::registerWindow (                
    wid=<value optimized out>)                                            
    at /usr/src/debug/kdelibs-4.1.2/kio/kio/scheduler.cpp:301             
#11 0x0000003958d5c2e9 in KIO::NetAccess::filecopyInternal (              
    this=<value optimized out>, src=<value optimized out>,                
    target=<value optimized out>, permissions=<value optimized out>,      
    flags=<value optimized out>, window=<value optimized out>,            
    move=<value optimized out>)                                           
    at /usr/src/debug/kdelibs-4.1.2/kio/kio/netaccess.cpp:320             
#12 0x0000003958d5d37b in KIO::NetAccess::upload (src=<value optimized out>, 
    target=<value optimized out>, window=<value optimized out>)              
    at /usr/src/debug/kdelibs-4.1.2/kio/kio/netaccess.cpp:142                
#13 0x000000395740feed in Diff2::KompareModelList::saveDestination ()        
   from /usr/lib64/libkomparediff2.so.4                                      
#14 0x0000003957410686 in Diff2::KompareModelList::saveAll ()                
   from /usr/lib64/libkomparediff2.so.4                                      
#15 0x00007f59a71cba10 in ?? () from /usr/lib64/kde4/libkomparepart.so       
#16 0x00000039568ae074 in KMainWindow::closeEvent (this=<value optimized out>, 
    e=<value optimized out>)                                                   
    at /usr/src/debug/kdelibs-4.1.2/kdeui/widgets/kmainwindow.cpp:562          
#17 0x0000003957dd4b57 in QWidget::event (this=<value optimized out>,          
    event=<value optimized out>) at kernel/qwidget.cpp:7313                    
#18 0x00000039580ed43b in QMainWindow::event (this=<value optimized out>,      
    event=<value optimized out>) at widgets/qmainwindow.cpp:1268               
#19 0x00000039568e6ea8 in KXmlGuiWindow::event (this=<value optimized out>,    
    ev=<value optimized out>)                                                  
    at /usr/src/debug/kdelibs-4.1.2/kdeui/xmlgui/kxmlguiwindow.cpp:125         
#20 0x0000003957d827dd in QApplicationPrivate::notify_helper (                 
    this=<value optimized out>, receiver=<value optimized out>,                
    e=<value optimized out>) at kernel/qapplication.cpp:3803                   
#21 0x0000003957d8a58a in QApplication::notify (this=<value optimized out>,    
    receiver=<value optimized out>, e=<value optimized out>)                   
    at kernel/qapplication.cpp:3768                                            
#22 0x00000039567fb55b in KApplication::notify (this=<value optimized out>,    
    receiver=<value optimized out>, event=<value optimized out>)
    at /usr/src/debug/kdelibs-4.1.2/kdeui/kernel/kapplication.cpp:311
#23 0x0000003954943081 in QCoreApplication::notifyInternal (
    this=<value optimized out>, receiver=<value optimized out>,
    event=<value optimized out>) at kernel/qcoreapplication.cpp:587
#24 0x0000003957dd799a in QWidgetPrivate::close_helper (
    this=<value optimized out>, mode=<value optimized out>)
    at ../../src/corelib/kernel/qcoreapplication.h:212
#25 0x0000003957ddc195 in QApplication::x11ClientMessage (
    this=<value optimized out>, w=<value optimized out>,
    event=<value optimized out>, passive_only=<value optimized out>)
    at kernel/qapplication_x11.cpp:4810
#26 0x0000003957dedc71 in QApplication::x11ProcessEvent (
    this=<value optimized out>, event=<value optimized out>)
    at kernel/qapplication_x11.cpp:3293
#27 0x0000003957e13d9c in x11EventSourceDispatch (s=<value optimized out>,
    callback=<value optimized out>, user_data=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:142
#28 0x000000395043742b in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#29 0x000000395043ac0d in ?? () from /lib64/libglib-2.0.so.0
#30 0x000000395043adcb in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
#31 0x000000395496b56f in QEventDispatcherGlib::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:319
#32 0x0000003957e1350f in QGuiEventDispatcherGlib::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:198
#33 0x0000003954941992 in QEventLoop::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qeventloop.cpp:143
#34 0x0000003954941b1d in QEventLoop::exec (this=<value optimized out>,
    flags=<value optimized out>) at kernel/qeventloop.cpp:194
#35 0x0000003954943fed in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#36 0x0000000000409abd in _start ()
Comment 1 Dario Andres 2008-12-04 22:27:21 UTC

*** This bug has been marked as a duplicate of bug 165421 ***