Bug 174812 - ktorrent crash on removing torrents
Summary: ktorrent crash on removing torrents
Status: RESOLVED DUPLICATE of bug 172198
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-10 21:04 UTC by Alex Tunc
Modified: 2008-11-15 19:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
here is the SIGSEGV bug trace file (8.96 KB, application/octet-stream)
2008-11-10 21:05 UTC, Alex Tunc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Tunc 2008-11-10 21:04:29 UTC
Version:           3.1.4-1 (using KDE 4.1.2)
OS:                Linux
Installed from:    Fedora RPMs


I`m using ktorrent 3.1.4-1  I`ve 50-60 seeded torrents and 4-5 download section when I remove torrents in seed side ktorrent crashed also ktorrent process consumes %40-70 cpu it didnt consume that much earlier..
Comment 1 Alex Tunc 2008-11-10 21:05:54 UTC
Created attachment 28477 [details]
here is the SIGSEGV bug trace file
Comment 2 Joris Guisson 2008-11-11 10:29:07 UTC
Already fixed, fix will be part of 3.1.5

*** This bug has been marked as a duplicate of bug 172198 ***
Comment 3 Alex Tunc 2008-11-14 19:54:44 UTC
fixed but where it is ? when will be 3.1.5 release ?  I cant use it ktorrent since this bug.. it uses %100 cpu and crash...
Comment 4 Joris Guisson 2008-11-15 11:08:21 UTC
Release is today or tomorrow
Comment 5 Alex Tunc 2008-11-15 14:48:26 UTC
I still get %100 cpu consume on ktorrent-3.1-5.fc9.x86_64  release candidate
Comment 6 Joris Guisson 2008-11-15 16:49:38 UTC
Then you are not running 3.1.5, judging from the name of the package, this is probably the 5th version of the 3.1 package. Check Help -> About KTorrent, to be sure.
Comment 7 Alex Tunc 2008-11-15 17:05:45 UTC
yea its ktorrent 3.1 in about section... but file ktorrent-3.1-5..  can I test your 3.1.5 ?
Comment 8 Joris Guisson 2008-11-15 19:15:07 UTC
You will have to download the 3.1.5 package from our website http://ktorrent.org and then compile it yourself.