Bug 174630 - amarok doesn't use nepomuk to rate music files
Summary: amarok doesn't use nepomuk to rate music files
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.3-GIT
Platform: Mandriva RPMs Unspecified
: NOR wishlist with 100 votes (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords:
: 222089 275472 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-08 15:33 UTC by marcello
Modified: 2012-09-23 02:32 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcello 2008-11-08 15:33:29 UTC
Version:            (using KDE 4.1.2)
Installed from:    Mandriva RPMs

hi,
i don't know if it's a bug or this feature hasn't been yet implemented, but amarok doesn't use nepomuk to rate files in beta 1 (mandriva 2009) as should do thanks to summer of code project 

http://lists.kde.org/?l=amarok&m=120671838014374&q=p3

can you provide me some info? this feature hasn't been implemented yet or is it a bug? thank you

Regards,
Marcello
Comment 1 Seb Ruiz 2008-11-08 23:51:46 UTC
I guess it hasn't been done.
Comment 2 Daniel Winter 2008-11-11 03:07:28 UTC
Yes, that is not ready now. 

The thing is: Just putting the rating into Nepomuk would be quite easy (maybe we should just do it for now, i.e. keep the DB in sync with Nepomuk).  

But my overall goal is to use strigi + a nepomuk service for indexing and use Nepomuk to store all Amarok collection data.  And for that Nepomuk is not really ready at the moment. The indexing in KDE 4.1 was quite instable and buggy. Most issues (together with a bugfix in upcomming Qt 4.4.4)) will be solved with KDE 4.2.  But general there is still the Nepomuk backend problematic (redland, slow and unusable, Soprano faster but java based with a huge memory leak). 

But it looks like we will also see a solution for that (a new 3rd Soprano backend) hopefully in time with KDE 4.2.

But anyway I am thinking of a way to use the sql based collection and at least store the rating (and other infos?) also in Nepomuk. (sync those) But as Amarok 2.0 is in feature freeze that will wait for 2.1.
Comment 3 Kuba Serafinowski 2009-08-09 19:25:45 UTC
Anyone could implement at least exporting ratings to Nepomuk? It would really be great, also maybe Nepomuk sucks less now, according to Daniel. I really dunno, though i'd love to see this feature.
Comment 4 Kolja 2009-09-02 22:34:41 UTC
I think we should retag to 2.3 because of feature freeze.
Comment 5 Thijs Heus 2010-02-01 18:52:31 UTC
Given the quality of Nepomuk right now (i.e., very good) could it be considererd to get the Nepomuk backend working? I like the way Bangarang makes use of it, but Amarok is featurewise clearly my audioplayer of choice.
Comment 6 Myriam Schweingruber 2010-02-01 22:54:32 UTC
It is on the ToDo list, the developers just didn't come round to it yet. A few more hands would be welcome
Comment 7 Kevin Funk 2010-02-18 19:54:01 UTC
*** Bug 222089 has been marked as a duplicate of this bug. ***
Comment 8 Sven Krohlas 2010-04-30 13:21:23 UTC
2.3.1 is in feature freeze -> 2.3.2
Comment 9 marcello 2010-05-16 18:15:59 UTC
thank you the same for the great work you're doing. i understand there are a lot of work to do and time isn't never enough... we'll wait with patience : )

cheers,
Marcello
Comment 10 Myriam Schweingruber 2011-06-13 10:56:49 UTC
*** Bug 275472 has been marked as a duplicate of this bug. ***
Comment 11 Tomas 2011-06-13 13:05:26 UTC
Hi guys,

At the beginning I want to thank you for great application you guys are developing and improving, Amarok has been my #1 audio player for many years.   

But let me point at this silly bug which should be resolved.

There is a comment #2 From Daniel Winter 2008-11-11 who wrote:
>> The thing is: Just putting the rating into Nepomuk would be quite easy (maybe we should just do it for now, i.e. keep the DB in sync with Nepomuk).<<

So, according to this i suppose it would be easy for you to implement sync with Nepomuk, am I right?

But Daniel wrote more:
>> But my overall goal is to use strigi + a nepomuk service for indexing and use
Nepomuk to store all Amarok collection data.  And for that Nepomuk is not
really ready at the moment. The indexing in KDE 4.1 was quite instable and
buggy. Most issues (together with a bugfix in upcomming Qt 4.4.4)) will be
solved with KDE 4.2.  But general there is still the Nepomuk backend
problematic (redland, slow and unusable, Soprano faster but java based with a
huge memory leak).<<

I am using KDE 4.6.4 and I must say there has been really great progress since  KDE 4.2, especially on both Strigi and Nepomuk. Isn't a good time to reconsider  implementing this functionality now? In case of this would have some performance issue, would it be possible to perform that easy implementation of sync with Nepomuk?

With huge respect to your work,

Tomas

btw: I wouldn't worry about performance with Nepomuk as there is already a multimedia player application called Bangarang based on this. It's performance is good, but do I prefer both Amarok's functionalities and GUI :-)
Comment 12 Manuel Amador (Rudd-O) 2011-11-08 03:19:27 UTC
I think it's time to revise this.  KDE 4.7.3 has brought a lot of improvements to NEPOMUK, and it runs fine now.  At the very least, the first thing to do is to sync the ratings from NEPOMUK into Amarok and vice versa.  Then, collection itself should be (by default) using NEPOMUK if there isn't a database-based collection set up, with the option of using the old collection code if people want more performance or whatnot.

How can this be accomplished?
Comment 13 Myriam Schweingruber 2011-11-08 11:21:23 UTC
By getting us a developer who has time to do the implementation, as easy as that :)
Comment 14 Phalgun Guduthur 2012-09-18 22:51:17 UTC
Hello people from the past, 

This request has been completed now with the Nepomuk plugin that was developed as part of GSoC 2012. The code can now be found in Amarok master. http://quickgit.kde.org/index.php?p=amarok.git&a=summary

The Nepomuk plugin lets you play and rate your tracks using the Nepomuk database as of now. With time, I hope to implement the other features of managing your tracks and you can completely let go off the SQL Collection.
Comment 15 Matěj Laitl 2012-09-18 22:55:50 UTC
Git commit 3284e6c9d0daba91297a47e5aaa0d8b0cbdd4784 by Matěj Laitl.
Committed on 19/09/2012 at 00:45.
Pushed by laitl into branch 'master'.

Improve ChangeLog text wrt Nepomuk ratings a bit

Phalgun, we usually use "positive" sentences in ChangeLog - e.g. what
got fixed, not what was broken. As the hooks didn't run for your merge
commit I pull repeat the keywords here:
FIXED-IN: 2.7
CCMAIL: me@phalgun.in

M  +1    -1    ChangeLog

http://commits.kde.org/amarok/3284e6c9d0daba91297a47e5aaa0d8b0cbdd4784
Comment 16 marcello 2012-09-19 13:32:59 UTC
THANK YOU!!! How this feature will work? the tracks already rated using the SQL database will be imported to the nepomuk one? thank you again


cheers,
Marcello
Comment 17 Phalgun Guduthur 2012-09-20 07:26:48 UTC
(In reply to comment #16)
> THANK YOU!!! How this feature will work? the tracks already rated using the
> SQL database will be imported to the nepomuk one? thank you again
> 

You are welcome Marcello. 

Right now, the ratings are done according to the Nepomuk database. So if you have some tracks that were rated using Dolphin ( or any other Nepomuk based application ) you get the same ratings in Amarok as well.
Comment 18 Phalgun Guduthur 2012-09-23 02:32:55 UTC
> the tracks already rated using the SQL database will be imported to the nepomuk one? 

There was another GSoC project by Matej Laitl, which unifies all statistics across the different collections ( SQL, Nepomuk, iPod, Playdar etc ). When this is completed, it would be easy to synchronize all your statistics from different collections. 

Read more about the project :  http://strohel.blogspot.com/