Bug 174462 - crash in normal run
Summary: crash in normal run
Status: RESOLVED DUPLICATE of bug 172198
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-06 18:42 UTC by Juha Tuomala
Modified: 2008-11-06 19:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juha Tuomala 2008-11-06 18:42:46 UTC
Version:            (using KDE 4.1.2)
Installed from:    Fedora RPMs

Application: KTorrent (ktorrent), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0x7f75bde19800 (LWP 1456)]
[New Thread 0x41de3950 (LWP 1484)]
[New Thread 0x42a6e950 (LWP 1483)]
[KCrash handler]
#5  QSortFilterProxyModelPrivate::source_to_proxy (
    this=<value optimized out>, source_index=<value optimized out>)
    at ../../src/corelib/kernel/qabstractitemmodel.h:358
#6  0x0000003632a770bd in QSortFilterProxyModel::mapFromSource (
    this=<value optimized out>, sourceIndex=<value optimized out>)
    at itemviews/qsortfilterproxymodel.cpp:2262
#7  0x0000003632a71029 in QSortFilterProxyModel::parent (
    this=<value optimized out>, child=<value optimized out>)
    at itemviews/qsortfilterproxymodel.cpp:1451
#8  0x0000003632a2a310 in QTreeView::indexRowSizeHint (
    this=<value optimized out>, index=<value optimized out>)
    at ../../src/corelib/kernel/qabstractitemmodel.h:358
#9  0x0000003632a2a9d5 in QTreeViewPrivate::itemHeight (
    this=<value optimized out>, item=<value optimized out>)
    at itemviews/qtreeview.cpp:3112
#10 0x0000003632a2fa05 in QTreeView::verticalOffset (
    this=<value optimized out>) at itemviews/qtreeview.cpp:2006
#11 0x00000036329fb2de in QAbstractItemViewPrivate::contentsOffset (
    this=<value optimized out>)
    at ../../src/gui/itemviews/qabstractitemview_p.h:256
#12 0x00000036325d3c5f in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4612
#13 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#14 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#15 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#16 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#17 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#18 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#19 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#20 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#21 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#22 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#23 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#24 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#25 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#26 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#27 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#28 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#29 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#30 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#31 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#32 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#33 0x00000036325d4012 in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4735
#34 0x00000036325d3f3b in QWidgetPrivate::paintSiblingsRecursive (
    this=<value optimized out>, pdev=<value optimized out>, 
    siblings=<value optimized out>, index=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, flags=)
    at kernel/qwidget.cpp:4725
#35 0x00000036325d35e8 in QWidgetPrivate::drawWidget (
    this=<value optimized out>, pdev=<value optimized out>, 
    rgn=<value optimized out>, offset=<value optimized out>, 
    flags=<value optimized out>, sharedPainter=<value optimized out>)
    at kernel/qwidget.cpp:4677
#36 0x000000363272c601 in QWidgetBackingStore::cleanRegion (
    this=<value optimized out>, rgn=<value optimized out>, 
    widget=<value optimized out>, recursiveCopyToScreen=<value optimized out>)
    at painting/qbackingstore.cpp:1035
#37 0x000000363272ca67 in qt_syncBackingStore (widget=<value optimized out>)
    at painting/qbackingstore.cpp:313
#38 0x00000036325d4d15 in QWidget::event (this=<value optimized out>, 
    event=<value optimized out>) at kernel/qwidget.cpp:7447
#39 0x00000036328ed43b in QMainWindow::event (this=<value optimized out>, 
    event=<value optimized out>) at widgets/qmainwindow.cpp:1268
#40 0x00000036336e6ea8 in KXmlGuiWindow::event (this=<value optimized out>, 
    ev=<value optimized out>)
    at /usr/src/debug/kdelibs-4.1.2/kdeui/xmlgui/kxmlguiwindow.cpp:125
#41 0x00000036325827dd in QApplicationPrivate::notify_helper (
    this=<value optimized out>, receiver=<value optimized out>, 
    e=<value optimized out>) at kernel/qapplication.cpp:3803
#42 0x000000363258a58a in QApplication::notify (this=<value optimized out>, 
    receiver=<value optimized out>, e=<value optimized out>)
    at kernel/qapplication.cpp:3768
#43 0x00000036335fb55b in KApplication::notify (this=<value optimized out>, 
    receiver=<value optimized out>, event=<value optimized out>)
    at /usr/src/debug/kdelibs-4.1.2/kdeui/kernel/kapplication.cpp:311
#44 0x0000003630d43081 in QCoreApplication::notifyInternal (
    this=<value optimized out>, receiver=<value optimized out>, 
    event=<value optimized out>) at kernel/qcoreapplication.cpp:587
#45 0x0000003630d43d2a in QCoreApplicationPrivate::sendPostedEvents (
    receiver=<value optimized out>, event_type=<value optimized out>, 
    data=<value optimized out>)
    at ../../src/corelib/kernel/qcoreapplication.h:209
#46 0x0000003630d6b8e3 in postEventSourceDispatch (s=<value optimized out>)
    at ../../src/corelib/kernel/qcoreapplication.h:214
#47 0x0000003cabc3742b in IA__g_main_context_dispatch (
    context=<value optimized out>) at gmain.c:2012
#48 0x0000003cabc3ac0d in g_main_context_iterate (
    context=<value optimized out>, block=<value optimized out>, 
    dispatch=<value optimized out>, self=<value optimized out>)
    at gmain.c:2645
#49 0x0000003cabc3adcb in IA__g_main_context_iteration (
    context=<value optimized out>, may_block=<value optimized out>)
    at gmain.c:2708
#50 0x0000003630d6b56f in QEventDispatcherGlib::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qeventdispatcher_glib.cpp:319
#51 0x000000363261350f in QGuiEventDispatcherGlib::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qguieventdispatcher_glib.cpp:198
#52 0x0000003630d41992 in QEventLoop::processEvents (
    this=<value optimized out>, flags=<value optimized out>)
    at kernel/qeventloop.cpp:143
#53 0x0000003630d41b1d in QEventLoop::exec (this=<value optimized out>, 
    flags=<value optimized out>) at kernel/qeventloop.cpp:194
#54 0x0000003630d43fed in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#55 0x0000000000420eeb in main (argc=5, argv=0x7fffc5e64498)
    at /usr/src/debug/ktorrent-3.1.4/ktorrent/main.cpp:166
Current language:  auto; currently c
Comment 1 Joris Guisson 2008-11-06 19:04:21 UTC
This is fixed, fix will be part of 3.1.5

*** This bug has been marked as a duplicate of bug 172198 ***