Bug 173563 - "Display Images on Page" keyboard shortcut becomes unset when new blank tab is opened
Summary: "Display Images on Page" keyboard shortcut becomes unset when new blank tab i...
Status: RESOLVED DUPLICATE of bug 195717
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.1.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-26 08:11 UTC by Andrew Munkres
Modified: 2010-10-19 22:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Munkres 2008-10-26 08:11:40 UTC
Version:            (using KDE 4.1.2)
OS:                Linux
Installed from:    Unlisted Binary Package

I am using Arch Linux and its standard KDE packages, including kdebase 4.1.2-1, kdebase-runtime 4.1.2-1, and kdelibs 4.1.2-2.

To reproduce the bug, do this:

- Uncheck the "Automatically load images" check box in Konqueror's configuration.
- Set the keyboard shortcut for "Display Images on Page" to something (I set it to Ctrl+\).
- Load an HTML page in the current tab, then press the shortcut key to verify that it works.
- Open a new blank tab (Ctrl+Shift+N).
- Load an HTML page in this new tab, then press the shortcut key. It won't do anything.
- Bring up the "Configure Shortcuts..." dialog. It will show that there is no shortcut assigned to "Display Images on Page".

It seems that if you use the "Open in New Tab" action on a link, and then change to the new tab before the page starts to load, the shortcut will become unset; but if you "Open in New Tab" and wait until the page is partially or completely loaded (e.g. until the page title shows up in the tab), the shortcut will remain set.

This doesn't seem to be the same as the behavior described in bug 56518, because if you set the shortcut, then quit Konqueror without first opening a new tab, then restart Konqueror, then immediately press the shortcut key while Konqueror is showing the "introduction page", it will load images on the introduction page. However, when the location page is displayed, it seems that entering a URL in the location bar and pressing Enter will cause it to lose the shortcut. (When viewing a normal web page, however, entering a new URL in the location bar and pressing Enter doesn't cause it to lose the shortcut.)

The shortcut key combination does get saved correctly in the ~/.kde4/share/apps/khtml/khtml_browser.rc file.
Comment 1 Andrew Munkres 2008-10-26 08:18:59 UTC
I forgot to mention that I'm using packages compiled for x86_64.
Comment 2 David Faure 2010-10-19 22:25:33 UTC
Fixed by my plugActionList fix, so a duplicate of 195717.

*** This bug has been marked as a duplicate of bug 195717 ***